Joomla.it Forum

Joomla! 2.5 (versione con supporto terminato) => Joomla! 1.6/1.7/2.5 => Installazione, migrazione e aggiornamento => Topic aperto da: padova59 - 25 Lug 2011, 13:22:02

Titolo: installazione metodo 4
Inserito da: padova59 - 25 Lug 2011, 13:22:02
Credo di aver trovato un nuovo sistema per istallare l'aggiornamento da 1.6.5 a 1.7.0 per superare il problema del time-out nel mio sito

per ora funziona ma non do alcuna garanzia (consiglio sempre backup)
padova59


installazione n.4

scompattare il file Joomla_1.6.5_to_1.7.0_Package_ita.zip
avrete 2 file .zip

Joomla_1.6.5_to_1.7.0-pre_Package.zip
Joomla_1.7.0-Stable-Update_Package.zip

scompattare nelle dir

Joomla_1.6.5_to_1.7.0-pre_Package
Joomla_1.7.0-Stable-Update_Package

copiare con ftp nella dir tmp del sito

entrare in joomla parte amministrativa
estensioni
gestione estensioni

Installa da cartella
Cartella installazione
/web/htdocs/www.miosito.it/home/unart/tmp/Joomla_1.6.5_to_1.7.0-pre_Package
/web/htdocs/www.miosito.it/home/unart/tmp/Joomla_1.7.0-Stable-Update_Package

installa
Titolo: Re:installazione metodo 4
Inserito da: MarkOne - 26 Lug 2011, 22:14:38
Astuto!
 ;)
Titolo: Re:installazione metodo 4
Inserito da: alexred - 27 Lug 2011, 10:56:59
ciao padova59,
ho fatto un test seguendo il metodo da te descritto e non mi ha aggiornato nulla,
cio non mi ha dato errori, anzi mi ha dato il messaggio: file installato correttamente
ma non mi ha aggiornato nulla.
In amministrazione di Joomla, in basso leggo ancora:  Joomla! un software libero rilasciato sotto licenza GNU/GPL.    Versione 1.6.5
Titolo: Re:installazione metodo 4
Inserito da: padova59 - 28 Lug 2011, 16:13:44
Io ho aggiornato 4 siti e sembra che funzionino regolarmente e sotto c' scritto
  Joomla! (http://www.joomla.org/) un software libero rilasciato sotto licenza GNU/GPL (http://www.gnu.org/licenses/gpl-2.0.html).         Versione 1.7.0
c' un altro sistema per vedere se 1.7 ?
padova59
 
 
Titolo: Re:installazione metodo 4
Inserito da: padova59 - 28 Lug 2011, 16:16:09
Cartella installazione

/web/htdocs/www.miosito.it/home/unart/tmp/Joomla_1.6.5_to_1.7.0-pre_Package    installa

dopo
/web/htdocs/www.miosito.it/home/unart/tmp/Joomla_1.7.0-Stable-Update_Package   installa
Titolo: Re:installazione metodo 4
Inserito da: alexred - 28 Lug 2011, 16:16:44
controlla se presente questo file:
/administrator/manifests/packages/joomla.xml
Titolo: Re:installazione metodo 4
Inserito da: padova59 - 28 Lug 2011, 16:54:32
ciao

administrator/manifests/packages/pkg_joomla.xml
va bene lo stesso ?
padova59
Titolo: Re:installazione metodo 4
Inserito da: alexred - 28 Lug 2011, 16:59:07
controlla se presente questo file:
/administrator/manifests/packages/joomla.xml

se non presente un buon segno, la procedura di aggiornamento lo ha cancellato.
Titolo: Re:installazione metodo 4
Inserito da: padova59 - 28 Lug 2011, 17:04:48
in questa cartella ci sono solo questi due file

administrator/manifests/packages/

index.html
pkg_joomla.xml

padova59

Titolo: Re:installazione metodo 4
Inserito da: alexred - 28 Lug 2011, 17:18:29
ok, ho provato a ripetere la procedura,
lanciando prima
/............/tmp/Joomla_1.6.5_to_1.7.0-pre_Package    installa

dopo
/............/tmp/Joomla_1.7.0-Stable-Update_Package   installa
mi da un errore:
Errore nella cancellazione del file o della cartella /media/mod_languages/images/ta.gif

ma l'aggiornamento sembra riuscito, il database aggiornato ed i vecchi file della 1.6.5 eliminati.
L'errore su quella immagine sembra corretto perch nella 1.6.5 non c' quella immagine da eliminare

Procedo ad inserire anche questa procedura nella pagina del wiki,
grazie per l'aiuto
Titolo: Re:installazione metodo 4
Inserito da: cos - 28 Lug 2011, 17:43:26
se non presente un buon segno, la procedura di aggiornamento lo ha cancellato.

Scusa Alex

Io c' l'ho invece
usato metodo 2

Mi devo preoccupare ??

Grazie


edit

Aggiungo che controllando i files che si devono cancellare (elencate nel metodo3)

ci sono tutti !!!! >:(

a qualcun altro il metodo 2 non ha cancellato i files???

Sito funziona cmq..

che faccio cancello??

grazie
Titolo: Re:installazione metodo 4
Inserito da: alexred - 28 Lug 2011, 17:49:18
Mi devo preoccupare ??
direi di si, probabilmente la procedura di eliminazione dei vecchi file non ha funzionato sul tuo sito.
Verifica se anche gli altri vecchi file sono presenti, trovi l'elenco qui:
http://wiki.joomla.it/index.php?title=Aggiornare_da_1.6.5_a_1.7#Metodo_n.C2.B03:_Aggiornamento_manuale
Titolo: Re:installazione metodo 4
Inserito da: cos - 28 Lug 2011, 17:50:10
direi di si, probabilmente la procedura di eliminazione dei vecchi file non ha funzionato sul tuo sito.
Verifica se anche gli altri vecchi file sono presenti, trovi l'elenco qui:
http://wiki.joomla.it/index.php?title=Aggiornare_da_1.6.5_a_1.7#Metodo_n.C2.B03:_Aggiornamento_manuale (http://wiki.joomla.it/index.php?title=Aggiornare_da_1.6.5_a_1.7#Metodo_n.C2.B03:_Aggiornamento_manuale)

ok grazie
Titolo: Re:installazione metodo 4
Inserito da: alexred - 28 Lug 2011, 17:50:21
inserita la procedura 2.1 nel wiki:
http://wiki.joomla.it/index.php?title=Aggiornare_da_1.6.5_a_1.7#Metodo_n.C2.B02.1:_Installa_da_cartella (http://wiki.joomla.it/index.php?title=Aggiornare_da_1.6.5_a_1.7#Metodo_n.C2.B02.1:_Installa_da_cartella)
Titolo: Re:installazione metodo 4
Inserito da: cos - 28 Lug 2011, 17:58:07
domanda

adesso che ho aggiornato alla 1.7  ( 2 gg fa)

se facessi il metedo 2.1  per eliminare i files che ho e che non dovrei avere

faccio solo casini o posso provare?

grazie



Titolo: Re:installazione metodo 4
Inserito da: cos - 28 Lug 2011, 18:22:21
Dunque

Usato metodo 2.1 dopo aver usato 2 gg fa il metodo2

Mi diceva 1.7 ma in realt

il metodo 2 non mi aveva cancellato i files (elencati nel metodo 3)

e non mi aveva installato un tabella
jos_associations`

adesso dopo avere usato questo innovativo metodo  :D ;D   sempre sullo stesso sito

i file si sono cancellati e ho ben 34 ( confermate??) tabelle  invece di 33

( il sito di test- (pulito))


Suggerirei a coloro che hanno usato metodo 2  di verificare ...

Io non avevo nessun errore

ciao

aggiungo che nel db dumpato prima di usare metodo2.1  che avrebbe dovuto essere 1.7


c'era
-- Dump dei dati per la tabella `jos_schemas`
INSERT INTO `jos_schemas` (`extension_id`, `version_id`) VALUES
(700, '1.6.5');

 
adesso dopo metodo 2.1

c'e
-- Dump dei dati per la tabella `jos_schemas`

INSERT INTO `jos_schemas` (`extension_id`, `version_id`) VALUES
(700, '1.7.0-2011-06-06-2');