Joomla.it Forum

Joomla! 2.5 (versione con supporto terminato) => Joomla! 1.6/1.7/2.5 => I Template di Joomla 1.6/1.7/2.5 => Topic aperto da: la casetta - 05 Feb 2012, 07:54:04

Titolo: Favicon joomla 1.7.3 RISOLTO
Inserito da: la casetta - 05 Feb 2012, 07:54:04
Vorrei sostituire il favicon di Joomla con il mio.
Ho creato il mio favicon personale, l'ho trasformato in .ico e l'ho chiamato "favicon.ico".
Sono andato nel mio template, in index.php ed ho sostituito il file favicon.ico esistente con il mio.
Ho fatto anche la stessa operazione nel template scelto per l'amministratore.
Purtroppo niente!
Prima di sostituire con il mio file sono andato a vedere che immagine c'era, ma non c'era niente.
Il sistema dove lo va a prendere il marchietto di joomla? Ho girato per tutti i file del htdocs ma non sono riuscito a trovarlo !!!
 
Titolo: Re:Favicon joomla 1.7.3
Inserito da: la casetta - 05 Feb 2012, 07:58:02
PS: ho pulito la cache e anche i file del browser; ovviamente quello di joomla rimane sempre lì.!
 
Titolo: Re:Favicon joomla 1.7.3
Inserito da: jfaxus - 05 Feb 2012, 15:37:05
Index php?


Va semplicemente messo dentro la cartella del template in uso, solo quella
Titolo: Re:Favicon joomla 1.7.3
Inserito da: luca7761 - 05 Feb 2012, 15:49:25
La favicon va appunto messa semplicemente nella cartella con il nome del template...! Ovviamente vai a sostiture quella già presente! Controlla il nome devi scrivere favicon.ico
Titolo: Re:Favicon joomla 1.7.3
Inserito da: la casetta - 05 Feb 2012, 16:25:43
Quello che mi dite l'ho gia detto e fatto io!
Però ho una novità, adesso, senza aver fatto altro, si vede su google Crome.
Ma con explorer 9 niente... favicon di joomla fisso!
 
 
Titolo: Re:Favicon joomla 1.7.3
Inserito da: ilvanni - 05 Feb 2012, 16:30:36
Hai per caso anche la cache lato sito attiva?

Con ie niente? E ti sorprendi?

Ripulisci daccapo tutte le cache del mondo e per non perdere tempo installa questa, tanto è leggera e non si sente proprio:
http://extensions.joomla.org/extensions/style-a-design/design/16820?qh=YToyOntpOjA7czo3OiJmYXZpY29uIjtpOjE7czo4OiJmYXZpY29ucyI7fQ%3D%3D
Titolo: Re:Favicon joomla 1.7.3
Inserito da: giovi - 05 Feb 2012, 16:36:48
ciao la casetta, posso confermarti che la cache è una memoria un po bizzarra, soprattutto mal gestita da "certi" browser (ilvanni capisce perfettamente quello che voglio dire ;) !) Se riesci a vedere la favicon su chrome, comunque, puoi stare tranquillo che la modifica è stata registrata sul server e che prima o poi la vedrai anche sul tuo ie9. Nel frattempo puoi fare questa verifica: accedi al sito da un altro pc con lo stesso browser e controlla che ie9 riconosca la nuova favicon!
Titolo: Re:Favicon joomla 1.7.3
Inserito da: jfaxus - 05 Feb 2012, 16:53:24
Comunque, se ti fa piacere saperlo, io la vedo (si fa per dire, che è diafana e poco comprensibile)
Da OS X, Safari, Chrome, Opera e Firefox.


Per IE dovrei accendere il pc, ma non ne dubito...
Titolo: Re:Favicon joomla 1.7.3
Inserito da: ilvanni - 05 Feb 2012, 17:18:21
Risparmia corrente, di questi tempi è meglio tagliare sulle spese inutili.  ;D
Titolo: Re:Favicon joomla 1.7.3
Inserito da: Ago_ - 05 Feb 2012, 17:27:04
l'importante è che si vede negli altri...anche se IE non te la aggiorna fregatene....il problema è solo sul tuo pc....
Titolo: Re:Favicon joomla 1.7.3
Inserito da: needweb - 05 Feb 2012, 18:00:53
confermo quello che avete già detto tutti...la favicon si vede su tutti i browser e anche a me ha funzionato la stessa procedura, ripeto solo i passaggi qui di seguito:


se hai risolto non dimenticare di scriverlo nel titolo  ;)


ciao a tutti
Titolo: Re:Favicon joomla 1.7.3
Inserito da: la casetta - 05 Feb 2012, 18:04:52
da come dite si direbbe risolto ...
ma aspetto ancora un po'; piacerebbe vederla nche a me!
 
Titolo: Re:Favicon joomla 1.7.3
Inserito da: jfaxus - 05 Feb 2012, 18:08:53
(http://img6.imageshack.us/img6/427/schermata022455963alle1.png) (http://img6.imageshack.us/i/schermata022455963alle1.png/)
Titolo: Re:Favicon joomla 1.7.3
Inserito da: ilvanni - 05 Feb 2012, 18:15:58
@jfaxus: La corrente!  ;D

Lacasetta vai tranquillo.
Titolo: Re:Favicon joomla 1.7.3
Inserito da: jfaxus - 05 Feb 2012, 18:34:57
Ilvanni hai ragione, ma il Mac lo tengo acceso 24ore su 24, 365 giorni all'anno.
È il pc che devo accendere...
Titolo: Re:Favicon joomla 1.7.3
Inserito da: ilvanni - 05 Feb 2012, 19:10:19
Ah, il mac usi? Aspetta, per cortesia vedi qua se puoi seguire questo utente, sembra avere problemi con mamp:

http://forum.joomla.it/index.php/topic,155386.msg695140.html#msg695140 (http://forum.joomla.it/index.php/topic,155386.msg695140.html#msg695140)

ti ringrazio per la collaborazione e interoperabilità fra topic. Bella questa sinergia se funziona.
Titolo: Re:Favicon joomla 1.7.3
Inserito da: la casetta - 06 Feb 2012, 07:40:37
Credo che non sia proprio concluso questo post.
Oggi, dopo l'ennesimo azzeramento di explorer9, ho trovato che finalmente l'icona di joomla è sparita.
 :o :o :o :o :o
Ma adesso c'è quella di explorer!!!!!  :( :( :(
 
Titolo: Re:Favicon joomla 1.7.3
Inserito da: needweb - 06 Feb 2012, 10:58:55
ciao "la casetta" guarda che se attendi che si visualizzi anche su IE9 allora aspetta e spera...fidati lo stesso difetto lo fa anche a me (con il mio sito), tutti i browser citati anche dagli altri sono ok (chrome, firefox, opera, safari) ma solo su IE9 non vedo la favicon, ma sinceramente me ne sbatto xkè purtroppo IE ha sempre questi piccoli difetti di compatibilità...in effetti il tuo post aveva come interrogativo solo quello di far visualizzare la favicon  ;)


quindi se posso darti un consiglio mettiti l'anima in pace che la favicon su IE9 nn la vedrai mai  ;D
Titolo: Re:Favicon joomla 1.7.3 con Explorer9
Inserito da: la casetta - 06 Feb 2012, 12:48:51
Scasami Mauriziomerli,
ammesso che comunque anche se non si vede la favicon non è un gran danno; ma mi sembra che comunque c'è un bug, anche se piccolo.
E poi perché le favicon degli altri siti si vedono? Perché quella di joomla c'è?
Se il problema è esplorer9 non si dovrebbero vedere neanche quella di joomla e di tutti gli altri siti.
Quindi un errore c'è. Immagino sia mio l'errore. Ma dove sta?
Se per te il problema è il titolo lo cambio subito  ;)
 
 
 
 
Titolo: Re:Favicon joomla 1.7.3
Inserito da: ilvanni - 06 Feb 2012, 18:21:07
Vuoi provare ad usare quell'estensione che ti ho detto su? Così usi una cosa che metti radicata in joomla, in modo tale che se non funziona neanche così ti metti l'anima in pace ed avrai imparato una cosa in più su quel browser  ;)
Titolo: Re:Favicon joomla 1.7.3
Inserito da: la casetta - 06 Feb 2012, 19:40:11
L'ho appena installata ed attivata.
Il tempo di capire come funziona e faccio sapere!!!
 
 
Titolo: Re:Favicon joomla 1.7.3
Inserito da: ilvanni - 06 Feb 2012, 20:04:56
Vai da menu 'estensioni' - -> 'gestione plugin' - scegli il plugin 'system favicon' e lo abiliti.

Poi vai da menu 'componenti' -> 'favicon' e clicca sul tasto in alto a destra 'create'; scegli da qui il percorso ed il file di cui vuoi fare l'upload sul server per creare la favicon (va bene anche il file immagine originale) scegliendo chiaramente fra una delle estensioni riportate e poi clicca su 'add image'. Dovrebbe bastare.

p.s. pulisci tutte le cache possibili e immaginabili.
Titolo: Re:Favicon joomla 1.7.3
Inserito da: la casetta - 06 Feb 2012, 20:22:39
Non ci ho capito un gran ché sul funzionamento di questo plugin, ma dopo aver fatto qualcosa ( nemmeno io so bene cosa) è comparsa subito!!!
all'istante   ;D :D ;) :)
Grande ... Ilvanni
grazie!!!!!!!
Adesso è proprio RISOLTO!
 
Titolo: Re:Favicon joomla 1.7.3 RISOLTO
Inserito da: ilvanni - 06 Feb 2012, 20:46:31
Di nulla figurati, come vedi bastava proprio poco se mi avessi seguito dall'inizio, bravo ad aver messo il risolto mi raccomando ricordatene anche per le prossime volte, ciao.