Joomla.it Forum

Componenti per Joomla! => Gestione e-commerce => Topic aperto da: gswant - 21 Mag 2007, 17:37:31

Titolo: Caratteri accentati e apostrofi
Inserito da: gswant - 21 Mag 2007, 17:37:31
Ciao a tutti, vi pongo questo quesito
perchč i caratteri accentati e gli apostrofi solo ed esclusivamente sul componente VM vengono sostituiti da "?" ho provato a fare le seguenti modifiche trovate nel forum:

In italian.php cercare DEFINE('_ISO','charset= e scrivere
DEFINE('_ISO','charset=UTF-8');

In index.php del template, dopo <head> (la riga di sotto va bene),
scrivere <meta http-equiv="Content-Type" content="text/html;
charset=UTF-8" />

In configuration.php cercare $mosConfig_locale = 'it_IT e sostituire
con $mosConfig_locale = 'it_IT.UTF8';

ma nulla di fatto

ho pensato al browser uso firefox ma non mi pare l'unica differenza che ho notatto che se uso il file della lingua inglese ciņ non accade.

Ciao e grazie a tutti
Titolo: Re: Caratteri accentati e apostrofi
Inserito da: gswant - 23 Mag 2007, 16:48:11
Ok ho fatto ulteriori prove ed ho capito che la pagina di amministrazione di VM č impostata con il caratteri di codifica UTF-8 mentre per essere visualizzato correttamente deve essere impostato su ISO-8859-1.

Qualcuno sa dove dover scrivere il:

<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />

solo per le pagine di VM in quanto Joomla č impostato perfettamente.

Saluti e grazie
Titolo: Re: Caratteri accentati e apostrofi
Inserito da: axxe16 - 31 Mag 2007, 12:56:26
non so se puņ esserti utile ma io ho sostituito tutti gli accenti del file di traduzione con le equivalenti in html e va benone...