Joomla.it Forum

Componenti per Joomla! => Gallerie di immagini => Topic aperto da: P.K. - 18 Mar 2016, 00:43:20

Titolo: Album list button does not work
Inserito da: P.K. - 18 Mar 2016, 00:43:20
Hi,


I added new album on my google plus and wanted to add it to my site. I created new menu item and clicked on the "options button" just next to the "Album list" edit box: A pop-up appeared with request to log-in to my google account. I logged in and the pop-up disappeared, but there should another pop-up shown with the option to make an album public. Unfortunately this does not happen.


I tried it under IE, Opera and Chrome. Does not work, so I can't publish my new album.


I upgraded the Ozio Gallery to the newest version (4.6.1) and it also does not work.
I have joomla 3.4.8.


What to do?
Titolo: Re:Album list button does not work
Inserito da: alexred - 18 Mar 2016, 08:26:31
Hello    P.K.,
What happens?
Any error message?
Titolo: Re:Album list button does not work
Inserito da: P.K. - 18 Mar 2016, 21:42:47
Hi Alex,


No. Nothing happens.
The steps I did:
1. Click the button with the cogwheel
2. New window appears with request to log-in to Google
3. I log-in to my google profile
4. The window in which I logged-in to google closes
5. On the joomla window nothing happens - but if I remember well, there should be displayed a list of albums with permissions.


P.K.
Titolo: Re:Album list button does not work
Inserito da: alexred - 18 Mar 2016, 21:50:18
but your albums are in Google Plus business page?
and you login in Ozio Gallery album list params with your Google profile, in your Google profile maybe there are no albums.
If our albums are in a G+ business page the istructions about business page:
http://www.opensourcesolutions.es/en/ext/ozio-gallery.html

Please post a link to your albums in Google

Regards
Titolo: Re:Album list button does not work
Inserito da: P.K. - 18 Mar 2016, 23:47:05
Everything was working when I was adding new album few months ago. Now it does not work.
Sample album on Google Photos:
https://photos.google.com/share/AF1QipMJ0XjbcTLBx65sXJjLIVKX1-KZY79u0TTkE_TlTyJ11gC_XDjR0XcEl6gNXuHdiA?key=bWc1VVEyOXliaHB6amplVzAtMlViTjVvbUpyZmJn


On the page you provided, there is a video. Please go to the part 2min 22sec and watch it till 2 min 34 sec: I do not see this pop-up window, but it was working few months ago.


In the mean time the only thing I did, I upgraded my joomla to version 3.4.8.

Titolo: Re:Album list button does not work
Inserito da: alexred - 19 Mar 2016, 08:03:53
but your albums are in Google Plus business page?
and you login in Ozio Gallery album list params with your Google profile, in your Google profile maybe there are no albums.
If your albums are in a G+ business page the istructions about business page:
http://www.opensourcesolutions.es/en/ext/ozio-gallery.html

ATTENTION: It does not support the new Google Photos SHARED album, use the normal Google Photos album
Titolo: Re:Album list button does not work
Inserito da: P.K. - 19 Mar 2016, 14:18:38
Ups. Can you please advice how to do it? I mean how to not use "shared" but use "normal" instead.
I was always using Google Photos always the same way, so I did not notice any change.
I will gladly put these pictures in "normal" and see if Oizo Gallery will work again, but I'm not sure what I need to do in the Google Photos.


No matter on that, the popup in Oizo joomla admin should appear - i think.





Titolo: Re:Album list button does not work
Inserito da: alexred - 19 Mar 2016, 15:10:25
in Google Photos  you can add images in new Album or in new SHARED album, use Album.
Titolo: Re:Album list button does not work
Inserito da: P.K. - 19 Mar 2016, 16:16:38

I checked and in the "shared" albums I had 3 albums and in "normal" I had all the remaining (approx 20).
I created just one more album as the "normal". The Ozio Gallery pop-up with option to make albums visible was still not showing.


I deleted the one album I created 2 days ago and recreated it, making sure it is "normal" and not "shared". After refreshing joomla, the pop-up eventually appeared. That's strange. I currently see that I still have few albums on Google Photos created as "Shared", but the gallery works normal.


For now the problem is resolved, but maybe it would be good to check why the pop-up was not showing at all (with all remaining 20+ albums which are "normal").
One more thing - the album I created now and made public on my joomla site is not set as publicly accessible on Google, but I can see it on my web page.


By the way - on the list of available albums in Ozio I see approx. 10 albums which are just dates (like 2015.07.14). When I look for such albums in Google Photos, I can't find them. Can you please write how Ozio gets the list of albums and how to eliminate these fake "date-albums"?
Titolo: Re:Album list button does not work
Inserito da: alexred - 19 Mar 2016, 16:56:40
When you ad a new post in G+ and insert a photo in a post for Google it is an new album and the name of album is the date.
Titolo: Re:Album list button does not work
Inserito da: estfellenoord - 27 Mar 2016, 18:45:46
Hi! I have the exact same problem and the solutions above did not help. Do you know when an update will be released which will fix this bug?
Titolo: Re:Album list button does not work
Inserito da: alexred - 27 Mar 2016, 20:50:19
but your albums are in Google Plus business page?
and you login in Ozio Gallery album list params with your Google profile, in your Google profile maybe there are no albums.
If our albums are in a G+ business page the istructions about business page:
http://www.opensourcesolutions.es/en/ext/ozio-gallery.html

Please post a link to your albums in Google

ATTENTION: It does not support the new Google Photos SHARED album, use the normal Google Photos album
Titolo: Re:Album list button does not work
Inserito da: estfellenoord - 28 Mar 2016, 11:22:45
Thank you for your quick response. My account is indeed a google business account, but my albums are stored in google photos and not in google plus. My google business account does not contain a google plus page, hence I am not able to follow the instructions in your link. Furthermore, I used the normal album option instead of the shared album option. It all worked a couple of weeks ago, but now it does not. This link is an example of an album that does needs to be set to public: https://goo.gl/photos/9bzxgzsBQRDaiQ1X8

Titolo: Re:Album list button does not work
Inserito da: alexred - 28 Mar 2016, 12:09:42
Sorry but Ozio Gallery support only  Google personal profile or  google plus business page.
Titolo: Re:Album list button does not work
Inserito da: estfellenoord - 28 Mar 2016, 12:24:03
I logged in with my personal google account, but the album list still does not appear.
Titolo: Re:Album list button does not work
Inserito da: alexred - 28 Mar 2016, 12:33:37
you need to set it Public by the Ozio Gallery button
Titolo: Re:Album list button does not work
Inserito da: estfellenoord - 28 Mar 2016, 12:36:08
That button did work until a couple of weeks ago. If I press the button, the google login screen does appear. But if I login with my personal account or business account (does not matter which), the screen disappears and the album list does not appear. Hence, I cannot set my albums to public.
Titolo: Re:Album list button does not work
Inserito da: alexred - 28 Mar 2016, 14:12:54
do you use the last Ozio Gallery version ?
Now  4.6.1
Titolo: Re:Album list button does not work
Inserito da: estfellenoord - 28 Mar 2016, 14:15:08
Yes I do
Titolo: Re:Album list button does not work
Inserito da: alexred - 28 Mar 2016, 14:17:25
try to use different browser, Firefox or Chrome or Opera
Titolo: Re:Album list button does not work
Inserito da: estfellenoord - 28 Mar 2016, 14:18:52
I used Chrome/Firefox and Safari on my mac and IE on my windows machine. None of them did the trick unfortunately
Titolo: Re:Album list button does not work
Inserito da: alexred - 28 Mar 2016, 16:24:32
try to reinstall Ozio Gallery and clear the browser cache.
Titolo: Re:Album list button does not work
Inserito da: estfellenoord - 28 Mar 2016, 16:33:05
That fixed the problem. Thank you so much for taking the time to help solve my problem!
Titolo: Re:Album list button does not work
Inserito da: alexred - 28 Mar 2016, 16:41:20
Fantastic!

Remember, ....if you use Ozio Gallery, please post a rating and a review at the Joomla! Extensions Directory (JED) http://extensions.joomla.org/extensions/extension/photos-a-images/galleries/ozio-gallery#reviews   
Thanks for your help.