Joomla.it Forum

Joomla! 3 => Joomla! 3 => Topic aperto da: ita4012 - 16 Mag 2018, 18:17:42

Titolo: [Risolto] Associazione voci menu non funzionante in sito multilingua
Inserito da: ita4012 - 16 Mag 2018, 18:17:42
Ciao. Il mio sito Ŕ multilingua.


La voce di menu corrispondente a questa pagina,


https://www.waterwind.it/new/it/windsurf/report-e-foto.html (https://www.waterwind.it/new/it/windsurf/report-e-foto.html)


nel backend Ŕ stata da me associata alle seguenti voci del meu inglese e francese


https://www.waterwind.it/new/en/windsurfing/reports-and-photos.html (https://www.waterwind.it/new/en/windsurfing/reports-and-photos.html)


https://www.waterwind.it/new/fr/planche-a-voile/rapports-et-photos.html (https://www.waterwind.it/new/fr/planche-a-voile/rapports-et-photos.html)




Nonostante abbia impostato queste associazioni, quando si clicca sulla bandierina per il passaggio dalla voce italiana a quelle corrispondenti inglesi o francesi, si viene reindirizzati sulle seguenti voci

https://www.waterwind.it/new/en/windsurfing/reports-and-photos/session-reports.html (https://www.waterwind.it/new/en/windsurfing/reports-and-photos/session-reports.html)

https://www.waterwind.it/new/fr/planche-a-voile/rapports-et-photos/rapports-et-photos.html (https://www.waterwind.it/new/fr/planche-a-voile/rapports-et-photos/rapports-et-photos.html)

che corrispondono a delle voci di menu nascoste (sottovoci di quelle che dovrebbero invece apparire).

Sia le voci di menu, che le sottovoci che erroneamente appaiono, sono categorie blog che devono visualizzare la stessa categoria di articoli (ma con moduli ed altri elementi differenti).

Ho usato la stessa impostazione per quest'altra voce di menu

https://www.waterwind.it/new/it/windsurf/spot.html (https://www.waterwind.it/new/it/windsurf/spot.html)

associata a queste altre due

https://www.waterwind.it/new/en/windsurfing/spots.html (https://www.waterwind.it/new/en/windsurfing/spots.html)

https://www.waterwind.it/new/fr/planche-a-voile/spots-critiques.html (https://www.waterwind.it/new/fr/planche-a-voile/spots-critiques.html)

ed in questo caso, l'associazione impostata nel backend funziona senza problemi, senza che compaiano le sottovoci nascoste, che pure in questo caso ho creato.

Apparentemente, la configurazione del backend di tutte le voci e relative sottovoci nascoste Ŕ sempre identica.

Qualcuno sa risolvere il rebus?

Grazie
Titolo: Re:Associazione voci menu non funzionante in sito multilingua
Inserito da: giusebos - 16 Mag 2018, 23:17:29
non corrispondono le associazioni delle categorie e degli articoli.

In un sito multilingua le associazioni sono su tre livelli: categoria, articolo, voce men¨

gli articoli non devono essere necessariamente collegati ad una voce di men¨, ma sarÓ necessario avere una voce di men¨ collegata alla categoria.
Titolo: Re:Associazione voci menu non funzionante in sito multilingua
Inserito da: ita4012 - 17 Mag 2018, 09:31:13
Grazie giusebos. Mi hai dato l'indizio giusto! nel caso delle voci di menu mal funzionanti, avevo impostato anche l'associazione a livello di categoria degli articoli nelle varie lingue. Questo probabilmente prevaleva sull'associazione delle voci di menu, e creava il problema. Togliendo l'associazione anche a livello di categoria (come era per nel caso delle voci di menu da subito funzionanti), il problema si Ŕ risolto. Grazie ancora.