Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Post - milkplus

Pagine: [1] 2 3 4 ... 18
1
IMHO è totalmente inutile.

2
Scusate se insisto con l'argomento ma ho verificato il seguente problema:

- apache in esecuzione con utente apache gruppo webusers

- owner dello spazio web webuser1 assegnato al gruppo webusers

- spazio web con permessi a 775 per le cartelle e 664 per i files

Questa è la mia situazione e funziona tutto. Funziona tutto fino a quando non installo nuovi componenti. Quando installo qualche cosa di nuovo infatti (tramite la procedura automatica dal pannello administrator di joomla) vengono assegnati alle cartelle utente apache e gruppo webusers (correttamente) il problema è che in automatico imposta i permessi a 755 per le cartelle e 644, di conseguenza devo agire manualmente per assegnare i permessi compatibili con la mia configurazione. Soluzioni per evitare queste operazioni che possono risultare un pò macchinose soprattutto nel caso in cui non abbia accesso diretto al server?
Grazie..     :)

3
verifica l'owner delle varie directory del tuo spazio web

4
Dovresti utilizzare per tutti i domini lo stesso db mysql, ma non capisco che senso abbia.
Tanto vale avere piu dns che puntano allo stesso server, o no?

5
i file di joolma ci sono tutti?

6
Sezione dedicata ai Server / Re:Client Mail
« il: 17 Giu 2010, 11:26:07 »
Se hai un server di posta elettronica in casa con accesso tramite un client web al massimo puoi aggiungere un modulo visibile solo agli utenti registrati nel quale inserire il pannello di login del client web.

Ma in tal caso sarebbe sufficiente solamente un link al client web.

7
Sezione dedicata ai Server / Re:Sendmail problema headers
« il: 08 Giu 2010, 17:25:58 »
mmleoni innanzi tutto grazie!

ho disinstallato sendmail ed installato postfix, a parte che tutto risulta molto più semplice anche la configurazione è molto banale!

8
Sezione dedicata ai Server / Re:Internal Server Error
« il: 08 Giu 2010, 17:09:12 »
Sicuro? il sito funziona ora.

9
E' semplice, phpMyAdmin è molto intuitivo..

10
Joomla! 1.5 / Re:Scomparso www accanto al sito
« il: 07 Giu 2010, 12:48:01 »
Potrebbe dipendere anche dal file .htaccess

11
ma questa configurazione risulta abbastanza sicura? o qualche cosa non va?

In ogni caso si la path della temp è esatta!

Grazie per l'aiuto..

12
Joomla! 1.5 / Re:Scomparso www accanto al sito
« il: 04 Giu 2010, 12:10:54 »
ma il www di cui parli è "sparito" da dove? Dalla barra degli indirizzi o dal titolo del sito?

13
il caso in cui il proprietario sia l'utente con cui l'ftp scrive i files e apache giri come membro del gruppo del proprietario, è uno di quelli che preferisco. i permessi per il proprietario saranno rwX (ma solo per pigrizia), quelli per i gruppo invece r-X, tranne per alcune cartelle (images, tmp, logs, cache...) che avranno anch'esse rwX, quelli per others r-X.
in questo modo joomla funzionerà perfettamente, ma sarà impossibile per terze persone modificare i files od installare estensioni non desiderate.

Lo spazio web ha come proprietario l'utente ftp che è assegnato al gruppo "webusers". Il servizio apache gira sotto utente "apache" che appartiene al gruppo "webusers" ed impostando i permessi come dici tu non funziona l'installazione di nuovi moduli, dall'errore sembra che oltre la cartella tmp non va.

14
Scusate l'intrusione,

ma credo ci sia parecchia confusione su questo aspetto dei permessi dei files e delle cartelle.
Del resto su un server condiviso la cosa giusta, recepita seguendo le varie guide, sarebbe quella di:
- creare un utente (es. pippo) che ha come home directory il suo spazio web, (es. /home/pippo_public);
- assegnare tale utente al gruppo di utenti apache;
- attribuire privilegi "rwx" per il proprietario, e lettura/esecuzione per gli altri, quindi 755 alle cartelle e 644 per i files;

Beh io ho fatto tutto ciò. Funziona tutto, ma nell'amministrazione di joomla giustamente mi dice che le cartelle non sono scrivibili poichè, solo l'owner (pippo) ha i permessi di scrittura e quindi apache (che nel mio caso gira con utente apache) non riesce a scrivere sulle cartelle. 
A logica per far funzionare tutto seguendo questo iter, dovrei inserire i permessi 775 --> in modo da consentire la scrittura anche al gruppo (ovvero apache) e non esclusivamente all'owner (pippo), ma non è il massimo in ambienti condivisi.

Potrei invece modificare l'owner delle cartelle mettendo "apache" in questo modo le cartelle risulterebbero scrivibili ma l'utente pippo non riuscirà a fare alcuna operazione all'interno del suo spazio web.

Dove sbaglio??

PS Sono su Fedora.

Grazie!

15
Sezione dedicata ai Server / Re:Sendmail problema headers
« il: 29 Mag 2010, 15:07:17 »
Bene!

Ti ringrazio della dritta, proverò qmail e postfix non appena ho la possibilità. Spero di non impazzire..

Ciao!

16
Sezione dedicata ai Server / Re:Sendmail problema headers
« il: 28 Mag 2010, 18:02:11 »
ciao mmleoni!

ho inserito il mio dominio nel file /etc/hosts, è inesistente invece il file /etc/host

perchè dici che sendmail non è il massimo? Alternative migliori?

17
Sezione dedicata ai Server / Re:Sendmail problema headers
« il: 28 Mag 2010, 14:25:19 »
Per questo ho scritto nella sezione dedicata ai servers.

18
Sezione dedicata ai Server / Sendmail problema headers
« il: 28 Mag 2010, 12:38:52 »
Buongiorno a tutti.

Credo di aver acquisito col tempo un bel pò di esperienza con joomla.
Da qualche giorno però mi è stato commissionata la configurazione di un server web partendo da zero, quindi tutto quello che riguarda l'installazione del sistema operativo, apache, php, sendmail e così via.

Premetto che funziona tutto quanto.
L'unica nota dolente è stata la configurazione del sendmail. Dopo parecchi grattacapi sono riuscito a far funzionare anche l'invio delle e-mail.
Il problema iniziale era che nell'header delle e-mail risultava nella Return-Path: apache@localhost.localdomain risolto inserendo le opportune direttive nel file sendmail.mc --> MASQUERADE_DOMAIN(miodominio.it)dnl ora le e-mail arrivano con Return-Path: apache@miodominio.it

Inoltre tra le varie righe dell'header c'è: Received: from miodominio (localhost [127.0.0.1])

Spero di essere riuscito a spiegarmi, grazie!

 :o

19
Joomla! 1.5 / Re:Modulo homepage per news [RISOLTO]
« il: 23 Giu 2009, 23:16:51 »
finalmente, grazie ilvanni!

ho scelto PhotoSlide GK2

http://extensions.joomla.org/extensions/content-&-news/articles-slideshow/5967/details

che tra l'altro è la stessa usata in homepage su questo sito, giusto?

Grazie ancora :D

20
Joomla! 1.5 / Re:Modulo homepage per news
« il: 23 Giu 2009, 09:43:19 »
grazie ilvanni! Avevo già guardato li ma non c'è nulla che mi entusiasmi per cui ho deciso di scrivere qui sul forum per vedere se qualcuno avesse trovato qualche cosa di più interessante

Pagine: [1] 2 3 4 ... 18
Host

Torna su