Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Post - faustrace

Pagine: [1] 2 3
1
Joomla! 3 / Re:Malfunzionamento indirizzamento categoria
« il: 07 Gen 2019, 11:33:43 »
Assegnando gli articoli a "uncategorized" e eliminando la vecchia categoria, e successivamente creando una nuova categoria e assegnando gli articoli alla nuova categoria, il blog funziona correttamente con l'indirizzo sito/categoria/articolo.


Il problema mi rimane in home page: il read more di un articolo mostrato in home tramite il modulo newsflash non indirizza correttamente ma a sito/articolo e restituendo un errore 404




2
Joomla! 3 / Re:Malfunzionamento indirizzamento categoria
« il: 06 Gen 2019, 17:12:27 »
Ho trovato uno dei possibili problemi:
facendo un test con JA Extension Manager sulle differenze tra il template originale e le modifiche apportate da me, ho trovato del codice in pi¨ nel file:
/templates/purity_iii/html/com_content/category/features-intro_item.php
questo codice viene visto dall'estensione, ma non Ŕ realmente presente sul file se lo apro via FTP


Pu˛ essere lui il colpevole dell'apertura non corretta degli articoli?
Quale pu˛ essere il componente o l'estensione che me lo aggiunge?


[/size][/color][/color]   <?php if ($params->get('show_readmore') && $this->item->readmore) : if ($params->get('access-view')) : $link = JRoute::_(ContentHelperRoute::getArticleRoute($this->item->slug, $this->item->catid, $this->item->language)); else : $menu = JFactory::getApplication()->getMenu(); $active = $menu->getActive(); $itemId = $active->id; $link1 = JRoute::_('index.php?option=com_users&view=login&Itemid=' . $itemId); $returnURL = JRoute::_(ContentHelperRoute::getArticleRoute($this->item->slug, $this->item->catid, $this->item->language)); $link = new JUri($link1); $link->setVar('return', base64_encode($returnURL)); endif; ?> <p class="readmore btn btn-default"> <a href="<?php echo $link; ?>"> <?php if (!$params->get('access-view')) : echo JText::_('COM_CONTENT_REGISTER_TO_READ_MORE'); elseif ($readmore = $this->item->alternative_readmore) : echo $readmore; if ($params->get('show_readmore_title', 0) != 0) : echo JHtml::_('string.truncate', ($this->item->title), $params->get('readmore_limit')); endif; elseif ($params->get('show_readmore_title', 0) == 0) : echo JText::sprintf('COM_CONTENT_READ_MORE_TITLE'); else : echo JText::_('COM_CONTENT_READ_MORE'); echo JHtml::_('string.truncate', ($this->item->title), $params->get('readmore_limit')); endif; ?> [/url] </p> <?php endif; ?>[/size][/color][/font]

3
Joomla! 3 / Re:Malfunzionamento indirizzamento categoria
« il: 06 Gen 2019, 14:46:18 »
Hai perfettamente ragione, comunque un problema simile non mi era mai successo.
Ti ho inviato il link in privato, non mi va di pubblicare il sito


Continuando a fare prove stupide, mi rendo conto che il link sito/categoria/articolo esiste, anche se il "read more" di tutti gli articoli puntano a sito/articolo, pubblicando l'articolo in home page.


Sai dirmi dove posso verificare le impostazioni e il funzionamento del "read more"?

4
Joomla! 3 / Re:Malfunzionamento indirizzamento categoria
« il: 06 Gen 2019, 13:53:24 »
Lo so, Ŕ da 11 anni che faccio i miei siti in joomla, ed Ŕ la prima volta che mi succede una cosa simile.
La voce di men¨ in questione Ŕ una "categoria blog" che si chiama news, e contiene le news del sito con una raccolta di articoli della corretta categoria.
Se dal pannello di amministrazione sposto la voce di men¨ come ultima del men¨, cliccando su read more di un articolo, appare sito/categoria/articolo ,
se tengo la voce di men¨ non come ultima voce del men¨, il read more punta a sito/articolo con i moduli della home page visualizzati


sono giorni che provo tutte le combinazioni possibili, ho anche ricreato la categoria e riassegnato gli articoli, ma nulla. Per caso ho scoperto che tenendo la voce di men¨ come ultima, tutto funziona normalmente

5
Joomla! 3 / Malfunzionamento indirizzamento categoria
« il: 06 Gen 2019, 12:41:23 »
Buongiorno, ho un problema legato alle news che si aprono in home, ma non Ŕ il problema noto, infatti se sposto la voce di men¨ come ultima voce dei men¨, gli articoli si aprono correttamente come www.sito.ext/categoria/articolo
Se invece posiziono la voce di men¨ nel giusto punto del men¨, l'articolo si apre in home page come www.sito.ext/articolo con tutti i moduli della home visibili.


La home Ŕ creata tramite un hidden men¨, per non avere la voce "home" in men¨.


Sto utilizzando Joomla 3.9.1, con Purity III come template. Funziona tutto correttamente ad eccezione di questo problema.


Grazie a chi pu˛ aiutarmi

6
Non ho fatto pubblicitÓ e non sto chiedendo come funziona il componente a pagamento, ma semplicemente come indirizzare la pagina di registrazione standard ad un indirizzo che decido io.


Non c'entra nulla il fatto che il link vada ad un componente a pagamento, potrebbe anche essere un freeware.
Sto chiedendo, per chi vuole rispondere, come si fa a modificare un modulo standard in joomla.

7
Sto utilizzando un componente a pagamento per la registrazione degli utenti a Joomla,
contemporaneamente ho alcuni articoli che prevedono la presenza del bottone: "Registrati per leggere il seguito".


Vorrei che il link della registrazione potesse essere quello del componente a pagamento (che si occupa di molti altri servizi giÓ integrati nel sito) e non quello del componente strandard di Joomla (che tra l'altro non ha la registrazione attiva).


Grazie

8
Joomla! 1.6/1.7/2.5 / Re:Aggiornamento automatico
« il: 26 Lug 2012, 22:33:25 »
Grazie!

9
Joomla! 1.6/1.7/2.5 / Re:Aggiornamento automatico
« il: 26 Lug 2012, 16:36:32 »
Grazie, lo stavo per fare, ma aspettavo conferma da qualcuno.
Il sito Ŕ in multi-lingua, pensi che ci possano essere problemi?


10
Joomla! 1.6/1.7/2.5 / Aggiornamento automatico
« il: 26 Lug 2012, 15:49:41 »
Ho il sito fermo alla 2.5.4 e chiedendo la verifica aggiornamenti mi viene comunicato che ho giÓ l'ultima versione, come mai?
Qualcuno pu˛ aiutarmi a procedere con l'aggiornamento automatico all'ultima versione?
grazie

11
Purtroppo avevo giÓ avviato il processo, si Ŕ concluso da pochi secondi...


riprovo tutto dall'inizio e vedr˛ di leggere attentamente le istruzioni, anche quelle dopo i passaggi fatti...


Grazie per l'aiuto anche ad un disattento come me...




12
Quindi era finita?
Sto cancellando proprio in questo momento il folder jupgrade...
....
Riprovo tutto e sposto i folder alla fine?

13
Ho installato JUpgrade,
ho attivato i mootools
ho lanciato l'installer e si Ŕ bloccato.


Ho cancellato il contenuto di tmp (eccetto index) e di cache e gli altri folder che aveva creato JUpgrade
ma non parte pi¨ il frontend...


Ho fatto un bel casino, eh?


Il pannello di amministrazione funziona tutto, e nel sito ho tutto, sto confrontando i files con un backup, e non manca nulla, anche il contenuto dei vari index sembra tutto uguale.


Non capisco...

14
sembra che ci sia tutto, articoli, categorie.. tutto come prima
a parte il frontend

15
Nel backend appare ancora J1.5.22...

16
grazie per la rapida risposta, ma il problema persiste...

17
Ho da poco provato a fare la migrazione da J 1.5.22 a J 2.5
Il processo si Ŕ interrotto, riesco ad accedere al backend ma il frontend restituisce un 404 su qualsiasi pagina del sito...
sapete da cosa pu˛ dipendere?


Grazie


18
Grazie
non so ancora come funziona il redirect, ma mi informer˛
Grazie ancora

19
vorrei che l'indirizzo assoluto attuale delle mie pagine non cambi

20
Grazie per la risposta.
In questo momento il sito Ŕ solo in Italiano, la semplicitÓ di utilizzo del 2.5 ci ha definitivamente invogliati a fare il sito in multilingua

Pagine: [1] 2 3
Host

Torna su