Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Post - cyberlupo

Pagine: [1] 2
1
non è implementata nella versione free. Ciao

2
Sviluppo / Re:Invalid backend response. Data is not JSON.
« il: 01 Mar 2012, 18:09:04 »
Ho provato a chiedere aiuto al mio host e ho avuto come risposta questo:

Gentile cliente,
in merito alla Sua segnalazione, La informiamo che la problematica da Lei riscontrata è nota agli sviluppatori del componente K2, come da topic nel forum ufficiale:
http://getk2.org/community/New-to-K2-Ask-here-first!/520-Cant-Browse-Server-invalid-backend-response?limit=12&start=12
Tale componente effettua una chiamata alla funzione proc_open che all’interno dei nostri sistemi in Hosting Condiviso è disabilitata per motivi di sicurezza, generando tale errore. La configurazione di tale variabile non è modificabile.
La invitiamo pertanto ad attendere il rilascio di una nuova versione del Suo componente che vada a fixare tale bug o ad effettuare l’installazione di una versione precedente di K2.
In alternativa potrà eseguire l’installazione del Suo applicativo all’interno di una soluzione Server Virtuale e/o Dedicato, dove le configurazione di sicurezza della macchina sono a discrezione dell’utente:

3
Joomla! 1.6/1.7/2.5 / Re:virtuemart 2.0 su joomla 2.5?
« il: 01 Mar 2012, 18:03:51 »
Scusate ho sbagliato sezione :P

4
Gestione e-commerce / Errori VM2.0.0 su Joomla2.5
« il: 06 Feb 2012, 19:09:18 »
Salve a tutti, spero che qualcuno possa aiutarmi a risolvere un problema.

Appena installato Vm2.0.0 su Joomla2.5 (pulito) sia in locale con XAMPP1.7.1 sia su Hosting

mi compaiono degli errori di VM dal lato backend, alcune voci di esempio risultano con il lucchetto
tipo in configurazione/campi clienti le prime 6 voci risultano con il lucchetto,
se provo a cliccare su 1 qualsiasi voce dell'elenco mi riporta a questa pagina:


5
Joomla! 1.6/1.7/2.5 / Re:Estensioni per Joomla 2.5
« il: 05 Feb 2012, 13:08:45 »
Testato Udjacomments su Joomla 2.5 in locale e funziona alla grande  ;)

Saluti a tutto lo staff!

6
Si, le ultimissime Virtuemart 2.0.1 e Kunena 1.7.2

7
Mi era stato detto da te che la versione PHP 5.3 è meglio per Joomla 2.5,

allora sono andato a settare PHP a 5.3, l'installazione di j2.5 è andata a buon fine
mentre Virtuemart a risposto con un sacco di errori e la stessa cosa ha fatto Kunena.

Saranno Virtuemart e Kunena che non digeriscono PHP 5.3?

8
si, sbagli

Allora perchè in locale ho dovuto installare una versione di XAMPP più vecchia con PHP 5.2 per
far funzionare j2.5?

scusa se ribadisco ma vorrei capire meglio.

9
Grazie per la risposta, ho disattivato il debug ed è andato tutto a posto.

Riguardo al problema di prima ho capito che j2.5 con PHP 5.3 ha ancora dei problemi, sbaglio?



10
Aggiungo che non fnirò mai di ringraziare maicolstaip per l'aiuto che mi sta dando
e a questo forum in generale per il lavoro e l'aiuto anche indiretto che forniscono a tutti
quelli che vengono a leggere qui e risolvono i loro problemini.

Credo che proverò intanto la versione gratuita dell'hosting di Joomla.it e appena riuscirò
a creare il mio sito per bene trasferirò il mio dominio per sempre su Joomla.it (mi sembra il minimo).

11
Intanto chiedo scusa per il rif. com.  pensavo che quel nome fosse già un modo per non dire il proprio prov.
infatti non è quello ma un altro.

Per quanto riguarda la situazione coesistenza credo allora che l'unico modo
è lavorare in locale per poi sostituire tutto con j2.5 bello e rifatto.

Adesso però  i dubbi aumentano, sto provando contemporaneamente 2 versioni
di Joomla 2.5 in locale con XAMPP 1.7.1 che ha la versione PHP 5.2.9,
1 con dati di esempio installati e 1 senza,
così per capire un po' come funziona.

La stessa cosa sto facendo direttamente online con PHP settato sempre alla vers. 5.2.9

Adesso il mio più grande dubbio è: perchè in rete j2.5 sembrava funzionare anche con PHP 5.3
mentre in locale no ?

Come funziona meglio Joomla 2.5 in rete, con PHP 5.2 o con PHP 5.3?

Grazie maicolstaip per la risposta, ho risolto il problema degli errori come hai detto tu. :D

12
E' sorto solo un problema, il vecchio sito basato su Joomla 1.0.x è andato a farsi benedire,
adesso nonostante aver settato di nuovo a 5.2.x il suddetto sito presenta degli errori in fondo alla
Home.

Consigli dai più esperti sono sempre ben accetti.

13
Grazie per la risposta,

questo lo avevo intuito però pensavo che nelle ultime versioni di tutto doveva essere tutto più compatibile,

inoltre mi hanno consigliato in un altro post di usare PHP 5.3.x per Joomla 2.5.

ma adesso ho capito che ho tanto da imparare  :-[ ;D

14
Grazie a tutti per essere intervenuti in questo Post, il mio problema è doppio, mi spiego meglio:

Ho la possibilità, dal provider XXXXXX dove ho installato il mio sito Joomla, di scegliere io stesso
la versione di PHP 5.2.17 o 5.3.9.

Mi è stato consigliato per j2.5 la 5.3.9 ma il mio problema principale è che nello stesso spazio Web
al momento ho installato il mio sito joomla versione 1.0.x. Ho provato a settare PHP 5.3.9 ma il sito
è andato a farsi benedire, quindi ho rimesso alla versione precedente il PHP, nonostante questo sono
rimasti visibili degli errori in fondo alla pagina  come si può benissimo vedere qui.

In un prossimo futuro ho intenzione di spostare tutto all'ultima versione di Joomla e sto cercando
di studiarmelo un po' prima di cancellare il vecchio sito, cosa che ,visto la mia poca esperienza, mi sta venendo alquanto difficile.

Per questo motivo la mia domanda iniziale è se posso preparare il nuovo sito basato sull'ultima versione di Joomla su PHP 5.2.x per poi passare a PHP 5.3.x senza pregiudicare il lavoro fatto.

P.S. Ho intenzione di installare, insieme a Joomla 2.5, Virtuemart 2.0, e Kunena.

Tutti i consigli su come muovermi sono bene accetti.

Edited:eliminato rif. commerciale

15
In effetti dopo aver installato XAMPP 1.7.1 è andato tutto a posto e non ho più problemi.

Posso modificare il titolo del post con [risolto] anche se sarebbe più bello
sapere per quale motivo, ma non sono a quel livello.

Grazie 100K per la risposta :)

16
Come da oggetto mi sono fatto questa domanda dopo aver fatto diverse prove in locale, mi spiego meglio

Ho scaricato e installato Xampp versione 1.7.7 che contiene:

+ Apache 2.2.21
  + MySQL 5.5.16 (Community Server)
  + PHP 5.3.8 (VC9 X86 32bit thread safe) + PEAR
  + XAMPP Control Panel Version 2.5 from www.nat32.com
  + (BETA) XAMPP Control Panel Version 3.0.2 by Steffen Strueber (not in the USB & lite version)
    see http://www.apachefriends.org/f/viewtopic.php?f=16&t=46743
  + XAMPP Security
  + OpenSSL 1.0.0e
  + phpMyAdmin 3.4.5
  + ADOdb 5.14
  + Mercury Mail Transport System v4.62 (not in the USB & lite version)
  + FileZilla FTP Server 0.9.39 (not in the USB & lite version)
  + Webalizer 2.23-04 (not in the USB & lite version)
  + Perl 5.10.1 (not in the USB & lite version)
  + Mod_perl 2.0.4 (not in the USB & lite version)
  + Tomcat 7.0.21 (not in the USB & lite version).

Quando installo in locale Joomla 2.5 ita stabile  non ho nessun problema.

I problemi vengono fuori quando cerco di installare altre estensioni
dal backend di joomla tipo Virtuemart, es:

Strict Standards:  Non-static method VmConfig::loadConfig() should not be called statically in C:\xampp\htdocs\joomla25\administrator\components\com_virtuemart\admin.virtuemart.php on line 37
ecc... ecc...

Oppure Kunena 1.7.1
 
  • Installazione completata con successo.
 
 Strict Standards:  Non-static method KunenaError::initialize() should not be called statically in C:\xampp\htdocs\joomla25\administrator\components\com_kunena\admin.kunena.php on line 42
 
 Strict Standards:  Non-static method CKunenaConfig::getInstance() should not be called statically in C:\xampp\htdocs\joomla25\administrator\components\com_kunena\libraries\factory.php on line 28
 
 Strict Standards:  Only variables should be assigned by reference in C:\xampp\htdocs\joomla25\administrator\components\com_kunena\admin.kunena.php on line 44
 
 Strict Standards:  Declaration of KunenaControllerInstall::display() should be compatible with that of JController::display() in C:\xampp\htdocs\joomla25\administrator\components\com_kunena\install\controller.php on line 22
 
 Strict Standards:  Declaration of KunenaModelInstall::getError() should be compatible with that of JObject::getError() in C:\xampp\htdocs\joomla25\administrator\components\com_kunena\install\model.php on line 1784
 
 Strict Standards:  Only variables should be passed by reference in C:\xampp\htdocs\joomla25\administrator\components\com_kunena\install\view.php on line 43
 
 Strict Standards:  Only variables should be passed by reference in C:\xampp\htdocs\joomla25\administrator\components\com_kunena\install\view.php on line 45
 
 Strict Standards:  Only variables should be passed by reference in C:\xampp\htdocs\joomla25\administrator\components\com_kunena\install\view.php on line 46
 
 Strict Standards:  Only variables should be passed by reference in C:\xampp\htdocs\joomla25\administrator\components\com_kunena\install\view.php on line 49
 
 Strict Standards:  Only variables should be passed by reference in C:\xampp\htdocs\joomla25\administrator\components\com_kunena\install\view.php on line 54

A questo punto credo che nessuna installazione andrà a buon fine se non correggo quello che ho sbagliato

Sono sicuro che ho sbagliato qualcosa nella configurazione di Xampp (ho dei dubbi) oppure la suddetta versione di XAMPP non è adatta.

Potreste aiutarmi?

17
ciao cyberlupo,
per Joomla 2.5 è consigliato PHP 5.3

Per il tuo problema dei link prova a disabilitare i seo in configurazione globale.

Perfetto! Risolto, Attiva URL SEF messo su "no" ed è tornato tutto normale.

Grazie mille per la risposta.

18
versione PHP  5.2.17

Safe Mode                             Off                                 Off                               
Display Errors                             Off                                 On                               
File Uploads                             On                                 On                               
Magic Quotes Runtime                             Off                                 Off                               
Magic Quotes GPC                             Off                                 On                               
Register Globals                             Off                                 Off                               
Output Buffering                             Off                                 On                               
Session Auto Start                             Off                                 Off                               
Native ZIP support                             On                                 Off                             
CHiedo aiuto ai più esperti, con queste impostazioni incontrerò problemi?

19
Grazie per la risposta celere, ho provato a settare il PHP a 5.3 ma mi fa sballare il sito
che da anni faccio funzionare su j1.0.13.

Il mio dilemma è che voglio rifare il mio sito www.cybermodel.it in una veste tutta nuova
con 2.5in una cartella tipo www.cybermodel.it/joomla25, quando sarà tutto pronto e funzionante
disattiverò il vecchio sito e passerò il nuovo sotto 2.5 nella directory principale.

faccio qualcosa di sbagliato? non voglio rischiare di fare migrazioni dal vecchio e poi ritrovarmi senza niente.

20
Salve a tutti, come da titolo mi faccio questa domanda perchè, a me
la versione 2.5 dal lato frontend mi da problemi e tutti i link degli articoli di
esempio non funzionano, mentre con 1.7.3 era tutto a posto.

Ho provato a installare la 2.5 in locale ed invece è tutto ok, pensavo allora
che con PHP settato a 5.2 non va bene per j2.5.

Scusate se scrivo baggianate ma non mastico molto bene queste cose.

Pagine: [1] 2
Host

Torna su