Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Post - Bas83

Pagine: [1]
1
Joomla! 1.5 / Re: Pubblicazione su sgaragnao
« il: 17 Ott 2008, 15:23:08 »
Comunque nel regolamento c' scritto che non bisogna fare riferimenti commerciali.

Chiedo scusa :P

Si, per devi scegliere hosting linux.
Differenze? Diciamo che ad un'occhiata veloce quasi nulla, tranne che quello Windows non permette Joomla.
Non ho mai avuto problemi.

Grazie mille per l'aiuto!

2
Joomla! 1.5 / Pubblicazione su aruba
« il: 17 Ott 2008, 12:20:20 »
Ciao a tutti!
Qualcuno ha provato a pubblicare il proprio sito su aruba.it? E' fattibile?
Ad ogni modo, per pubblicare il mio sito, devo SEMPRE acquistare un dominio con PHP 5 e MySQL? Soprattutto quest'ultimo sempre necessario? Mi spiego: se voglio pubblicare un sito che contiene solamente contenuto statico (intendo semplici pagine di testo e immagini) devo per forza acquistare anche il database?

Altra domanda: che differenza fa se scelgo un server Linux piuttosto che uno Windows?

Grazie per l'attenzione.
Buona giornata!

Federico

3
Ho risolto il problema. E a differenza di molti altri tread in cui tutti, una volta risolto, se ne scappano senza scrivere la soluzione, io voglio dirvi cosa c'era che non andava:
come si legge dal sito

http://www.php-architect.com/blog/tag/leopard-mac-arabic-os-php-php5-mysql-enable-developer-t/

"This is a known issue in Leopard, basically the system is looking for the mysql.sock file in the wrong place."
Tradotto, il sistema cerca il "collegamento" al database nel posto sbagliato. Il problema si risolve creando un link con i seguenti due comandi da terminale (mi rifaccio sempre al suddetto sito)

sudo mkdir /var/mysql/
sudo ln -s /tmp/mysql.sock /var/mysql/mysql.sock


Una volta eseguiti alla lettera questi due comandi, ho riavviato il server (forse non era necessario, ma l'ho fatto per precauzione) ed ho potuto finalmente completare l'installazione di joomla, dopo aver perso un pomeriggio intero.

Buon lavoro a tutti.

Federico

4
Ciao a tutti!
Sono in fase di installazione di joomla 1.5 su macOs X 10.5.5, e mi sono bloccato al punto 4. Ho visto che questo un errore piuttosto comune, tuttavia non ho trovato nessun post che mi aiutasse a risolverlo.
Illustro la mia situazione:
- Apache attivo (la cartella del server Sites)
- Php attivo
- MySQL attivo
Ho creato un server usando phpMyAdmin 3.0 (che, non so come mai, non ha per niente la bella interfaccia che vedo negli screenshot in giro per il web). Ho creato un utente di amministrazione che si chiama root, e gli ho assegnato una password. Nonostante questo, da linea di comando non riuscivo ad accedere con quella password al server, e l'ho dovuta reimpostare da terminale con il seguente comando:
mysqladmin -u federico -h localhost password '<nuova password>'

Ad ogni modo, ho creato un database (sempre da linea di comando, perch con phpMyAdmin sembra non essere possibile), e l'ho chiamato "sevedb".
Scompatto la cartella joomla in Sites e inizio la procedura di installazione. Al passo 4 inserisco:
- Nome Host: localhost
- Nome utente: root
- Password: <la mia password>
- Nome database: sevedb
Vado avanti, e mi d l'errore.
Suppongo di aver fatto qualche casino con MySQL, ma non saprei dove...
Help please!  :'(

Federico

Pagine: [1]
Host

Torna su