Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Topics - aomegax

Pagine: [1]
1
Sviluppo / Funzionalità VM - codice
« il: 01 Nov 2009, 11:49:25 »
ciao, devo aggiungere una funzionalità a VM per cui ho scritto il codice php che dovrebbe risolvermi il problema.
l'obiettivo è partendo da un padre voglio tutti i prodotti delle categorie figlie.
siccome non sono un esperto di php potete dare una correzione al seguente codice? grazie a tutti...

Codice: [Seleziona]
function analizeTree ($parent, &$children) {

$db=JFactory::getDBO();
$query="SELECT category_child_id FROM #__vm_category_xref WHERE category_parent_id=".$parent;
$db->setQuery($query);
$son=$db->loadObjectList();

if ($son) {
$tmp = next($son);
while ($tmp) {
$query="SELECT category_child_id FROM #__vm_category_xref WHERE category_parent_id=".$tmp;
$db->setQuery($query);
$tmpson=$db->loadObjectList();
analizeTree($tmp,$tmpson);
$tmp = next($son);
}
}
else {
$query="SELECT product_id FROM #__vm_product_xref WHERE category_id=".$parent;
$db->setQuery($query);
$product=$db->loadObjectList();

$products = append($product);
}
}

2
Joomla! 1.5 / JAfilia
« il: 28 Ott 2009, 10:46:05 »
Salve, qualcuno sa come si usa JAfilia?

in particolare il funzionamento di
Pay Per Sale
Pay Per Click
Pay Per Lead

grazie...

3
Ciao, ho effettuato una modifica lato admin nella scheda del prodotto per poter inserire le caratteristiche dei prodotti. la cosa che non capisco è come mai nell'editor che ho aggiunto io nn mi viene memorizzato il codice HTML mentre in quello esistente tutto funziona correttamente. potete darmi un aiuto?
il codice dell'editor esistente è il seguente:
Codice: [Seleziona]
editorArea( 'editor1', htmlspecialchars( $db->sf("product_desc"), ENT_QUOTES ), 'product_desc', '400', '150', '55', '25' );
il codice dell'editor inserito da me è:
Codice: [Seleziona]
editorArea( 'editor3', htmlspecialchars( $db->sf("product_desc_features"), ENT_QUOTES ), 'product_desc_features', '550', '300', '55', '25' );
grazie.


edit: ho letto che non è possibile inserire editorarea multipli...è vero? in caso affermativo come posso risolvere?

4
Joomla! 1.5 / Help Url - Settare un terzo sito come helper
« il: 05 Giu 2009, 09:56:24 »
Ciao, vorrei settare un terzo sito diverso sia da "Locale" che da "Joomla.it" per fornire gli aiuti all'utente nella fase di gestione.
Tuttavia non riesco a capire dove inserire l'url del nuovo sito e inoltre le modifiche apportate al file configuration.php, più nello specifico alla variabile "var $helpurl", non vengono considerate nel backend.
Infine, nel nuovo sito helper basta creare gli articoli e mettere le keyref (come ad esempio screen.config.15) ?
Qualcuno saprebbe aiutarmi?
Grazie.

5
Joomla! 1.5 / [risolto] Problema con contattaci
« il: 14 Mag 2009, 16:07:36 »
Salve ho un problema con il componente "contatti".
Ho sviluppato il sito su un dominio, stamattina l'ho scaricato per fare l'upload su un altro dominio ma putroppo ho un problema quando clicco su contattaci. L'errore è il seguente:

Codice: [Seleziona]
Fatal error: Call to a member function getName() on a non-object in /home/sito/public_html/libraries/joomla/application/component/view.php on line 449
come posso risolvere?

grazie.

Soluzione:
ho risolto ricaricando il sito

6
Joomla! 1.5 / Come configurare/creare "Aiuto"
« il: 11 Apr 2009, 18:34:37 »
Ciao, sinceramente non sapevo come intitolare il post, spero sia chiaro. Comunque il mio intento è configurare in un determinato modo le pagine di "aiuto", ovvero ciò che si visualizza cliccando sul salvagente. L'obiettivo non è quello di farlo locale, mettendo le pagine html in /administrator/help ma configurare il mio sito in modo così come quello di joomla.it
Come posso fare? dove devo applicarmi? e soprattutto in che modo?

sperando di essere stato chiaro, vi ringrazio per l'aiuto.

7
Ciao, mi è successa una cosa stranissima, ho effettuato l'accesso da admnistrator e non visualizzo niente...eppure non ho modificato proprio nulla...allego l'immagine...

8
Ciao, devo inserire nel codice php (per cui o nell'index o da qualche altra parte) un link dinamico che deve puntare sempre al penultimo articolo di una determinata categoria.
Ho notato che gli id degli articoli aumentano e non sono vincolati all'id della categoria. Per cui immagino che dovrei selezionarmi prima la categoria e poi prendermi il penultimo articolo.
Come posso fare?
Grazie.

9
Salve, ho creato un modulo simile ad un almanacco, il problema che riscontro è che non mi funziona dopo averlo caricato come modulo, ovvero il file php non riesce a leggere dei valori in un file xml.
se gli stessi file li carico in una cartella creata da me nella root diversa da modules mi funziona...
come posso risolvere quest'increscioso problema? grazie

10
Editor / [JCE] Non visualizzo niente [RISOLTO]
« il: 21 Ago 2008, 13:29:41 »
Ciao, ho installato jce 1.1.1 ITA su joomla 1.0.15.
Quando scrivo un articolo e voglio inserire un'immagine clicco mi si apre il pop up ma non visualizzo niente.
Stesso discorso è se provo ad aprire html.
Come mai? che problema ho?
Grazie.

11
Joomla! 1.5 / [Risolto][J!1.5.5] Problea creazione moduli
« il: 06 Ago 2008, 14:47:38 »
Ciao a tutti, riscontro un problema enorme: ho installato la Joomla 1.5.5 ma quando vado nella gestione dei moduli e premo nuovo mi da quest'errore:

JFolder::folder: Path is not a folder /home/hosting/jordancafe.it/modules

Warning: Invalid argument supplied for foreach() in /home/hosting/jordancafe.it/administrator/components/com_modules/controller.php on line 524

e non vado avanti....come posso risolvere? grazie...

12
Joomla! 1.5 / [J! 1.5.2] Gestione articoli non si visualizza
« il: 08 Apr 2008, 12:15:11 »
Ciao, ho un problema nel visualizzare gli articoli.
Ho creato la sezione e la categoria ma quando vado su gestione articoli non si visualizza niente. Ciò si verifica sia utilizzando firefox che ie...
che problema ho?
sarà il fatto che nn ho popolato il db all'installazione di joomla 1.5.2?
Come posso risolvere, ovviamente senza reinstallare tutto?

Grazie.
 ???

13
Gestione e-commerce / Cerco componente stile ebay
« il: 21 Feb 2008, 13:21:39 »
Ciao a tutti...spero che il titolo sia chiaro...
cmq cerco un componente che permetta agli utenti di inserire i propri articoli e metterli in vendita, proprio come succede su ebay...anche se a me non serve il modello ad asta, ma il "compralo subito".

qualcuno sa darmi qualche dritta?
Grazie.

14
Salve a tutti. Ho un problema di visualizzazione del forum con internet explorer (ke zozza!!!) mentre con firefox viene visualizzato tutto correttamente. Come posso risolvere?

Le versioni che ho installato sono
Joomla 1.0.12
SMF 1.1.3
Bridge Joomlahacks 2.0

Grazie a tutti...

15
Gestione Forum / Problema reindirizzamento login CB - SMF
« il: 13 Set 2007, 15:35:22 »
Salve, ho integrato il forum smf (v. 1.1.3) in joomla (v. 1.0.12) con il bridge Joomlahacks (v. 2.0).
Ho settato come modulo per il login quello di cb xò riscontro un problema quando effettuo l'accesso: vengo reindirizzato all'index del forum e non a quella del sito. Stessa cosa quando effettuo il logout.
Che faccio? come posso risolvere?

Ho cercato in giro ma nn ho trovato niente a riguardo.

16
Gestione Forum / [Fireboard] Utenti, sezioni e privilegi
« il: 04 Set 2007, 17:31:06 »
Ciao, ho cercato in giro ma nn ho trovato nulla che fa al caso mio.
Vi spiego cosa voglio fare. Supponiamo che il forum abbia 3 sezioni: la prima è comune al gruppo di utenti A e B la seconda deve essere visitata solo dal gruppo di utenti A e la terza solo dal gruppo di utenti B.
Come faccio a fare questo con fireboard? c'è qualche plugin che mi permette tutto ciò? oppure devo rinunciare a questo forum e sceglierne un altro?
Grazie.

17
Ciao a tutti, ho cercato in giro ma non ho trovato risposta alla mia domanda.
Ho installato il componente JIM per i messaggi privati solo che riscontro un problema di visualizzazione con firefox, ovvero le informazioni del componente mi escono più in basso, cosa che non avviene con iexplorer.
Allego un'immagine per farmi capire meglio.

Come posso risolvere il problema? grazie

[allegato eliminato da un amministratore]

18
Gestione utenti e community / CB e update immagine utente
« il: 19 Giu 2007, 08:17:37 »
Ciao, ho installato CB ver 1.0.2 (ancora nn sono riuscito a trovare il file italian.php; se qlcn dovesse sapere dove trovarlo mi faccia sapere) e ho un problema quando un utente tenta di aggiornare la sua foto: mi esce un pop-up con la scritta session expired... :-\
che posso fare? qualcuno sa come risolvere il problema?

p.s. ma esiste una guida su come utilizzare al meglio CB e tutti i vari plugin?

19
Ciao...ho un problema con fireboard e firefox:
seleziono il forum vado per vedere il messaggio e mi esce \n e basta...mentre se apro il sito con iexplorer si vede tutto correttamente...
...che faccio? come posso risolvere il problema?
grazie

20
Ciao a tutti...mi sto apprestando a creare un sito utilizzando Joomla come CMS. Poichè sono una totale frana  non riesco a caricarlo sul web...
Lo spazio ce l'ho su netsons.org e il sito dovrebbe essere ascupe.netsons.org
Ieri sera ho fatto l'upload del sito che ho fatto in locale, ho importato il database, ma nn riesco a farlo visualizzare...come devo fare? Potete spiegarmelo semplicemente per favore?
Grazie in anticipo.

Pagine: [1]
Host

Torna su