Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Topics - Lucio71

Pagine: [1]
1
Joomla! 1.5 / K2: nascondere un campo extra se vuoto
« il: 28 Apr 2011, 10:14:25 »
Ciao,
per chi utilizza K2 e ha bisogno di nascondere un campo extra se vuoto: basta modificare questo file: public_html/components/com_k2/templates/default/item.php inserendo nella posizione opportuna il seguente codice al posto dell'originale:
<div class="itemExtraFields">
                <h3><?php echo JText::_('Additional Info'); ?></h3>
                <ul>
                        <?php foreach ($this->item->extra_fields as $key=>$extraField): ?>
                        <?php
                        $emptyValue = false;
                        switch ($extraField->type) {
                                case "textfield":
                                case "textarea":
                                        if ($extraField->value =="") $emptyValue = true;
                                break;
                                case "link":
                                        if (strpos($extraField->value,"\"http://\"")) $emptyValue = true;
                                break;
                                case "radio":
                                break;
                                case "multipleSelect":
                                        // Test already done by K2. If value is empty, this type of field does not appear.
                                break;
                                case "select":
                                        // This type of field can't have an empty value (first item select by default)
                                break;
                        }
                        ?>
                        <?php if (!$emptyValue): ?>
                        <li class="<?php echo ($key%2) ? "odd" : "even"; ?> type<?php echo ucfirst($extraField->type); ?> group<?php echo $extraField->group; ?>">
                                <span class="itemExtraFieldsLabel"><?php echo $extraField->name; ?>:</span>
                                <span class="itemExtraFieldsValue"><?php echo $extraField->value; ?></span>
                                <br class="clr" />
                        </li>
                        <?php endif; ?>
                        <?php endforeach; ?>
                        </ul>
            <div class="clr"></div>
          </div>
Per chi ha scarsa dimestichezza coi codici, basta scaricare il file da qui http://www.joomlahosting1.net/faq/item/53-k2-nascondere-un-campo-extra-se-vuoto , aprirlo, copiare tutto il contenuto e sostituirlo al contenuto del file item.php originale.

2
ciao,
ho un sito sul quale ho installato CB e circa 200 utenti, ci saranno delle pagine con elenchi di file .pdf accessibili solo agli utenti registrati; l'admin deve poter inviare via e-mail ogni singolo .pdf a tutti gli utenti registrati col minor sforzo possibile. Qualcuno ha qualche consiglio sul modo più semplice da usare, o conosce qualche add-on di CB, o extension compatibile con CB che fa al caso mio?
Grazie

3
Ciao,
sto usando CB 1.2.2 con Joomla 1.5.15, mi chiedo se quando uso la Community Builder: Userslist è possibile non solo settare l'ordine degli utenti da CB > List management > sort by ma anche prevedere nella pagina la possibilità di ordinare in base a un diverso criterio scelto dall'utente (es. nome, o cognome, o data di nascita, ecc.)

4
Ciao a tutti,
prima di scrivere questo post ho consultato varie discussioni ma ho un problema che non mi spiego. I miei siti si caricano molto lentamente (oltre 10 secondi per la home).
Ho provato a testare su http://www.selfseo.com/website_speed_test.php un po di siti miei e di altri siti, per avere un benchmark; i miei siti risultano avere ottime performance, non sono troppo pesanti e il tempo di caricamento per kb è buono; però la realtà così non è (prova manuale e cronometro alla mano). Ho fatto i test sia con IE8 che con Firefox. Dato che uso template tutti dello stesso fornitore, ho provato a cambiare template mettendo quelli di default, ma non ci sono miglioramenti significativi. Ho tutti i siti sullo stesso host, a parte uno, guarda caso quest'ultimo si carica ben più velocemente (3-4 secondi) anche se i dati teorici da test sono peggiori. Uso Joomla 1.5 su tutti i siti, dalla 1.5.8 in poi.
Alla fine quindi concluderei che è l'host, ma non riesco a capire perché ha dati teorici molto buoni e le pagine non si caricano.
Voi che ne dite?
Grazie per l'attenzione.

5
salve, sul sito www.rightontarget.it non riesco a togliere il messaggio di errore di cui sopra ... qualcuno ha già avuto problemi di questo tipo o può consigliarmi?
Grazie

6
Ciao,
utilizzo la 1.5.8 con Community Builder; quando un utente si registra il processo termina in una pagina che dice:

Registrazione completata! Adesso puoi identificarti.

Io invece vorrei cambiare la dicitura o far tornare l'utente direttamente in home page. Il motivo è che la registrazione mi serve per iscrivere gli utenti alle newsletter ma non mi serve che possano loggarsi.

Grazie a chi mi darà una mano.
Luci

Pagine: [1]
Host

Torna su