Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Post - nagato

Pagine: [1] 2 3
1
Joomla! 3 / Re:Code mirror bacato dopo aggiornamento 3.6.3
« il: 20 Ott 2016, 13:03:25 »
RETTIFICA: con una finestra anonima di ff funziona, quindi è anche la cache di ff che va svuotata!!!

2
Joomla! 3 / Re:Code mirror bacato dopo aggiornamento 3.6.3
« il: 20 Ott 2016, 13:02:07 »
L'ho appena rifatto e riavviato firefox...niente da fare! :'(

3
Joomla! 3 / Re:Code mirror bacato dopo aggiornamento 3.6.3
« il: 20 Ott 2016, 12:19:21 »
Stesso problema, ho aggiornato ieri alla 3.6.3(regolarmente con procedura automatica standard perfetta) e non posso più modificare i moduli, anche disabilitando l'editor.
Quando si tenta di aprirne uno rimane a "macinare" su pagina bianca. Quando riesco, per un puro caso di combinazioni del tasto avanti indietro del browser + stop improvviso del caricamento, sono riuscito a vedere un errore:

"Si è verificato un errore durante il recupero dei dati JSON: codice di stato HTTP 0"

Aggiungi che non è nemmeno possibile creare nuovi moduli, rimane sempre a macinare.
Bel problema.

E confermo che su Chrome invece funziona!

4
Joomla! 3 / Re:Voce di menu che scompare a condizione
« il: 04 Giu 2016, 00:04:04 »
Infatti, devo studiarmi un pò meglio la cosa e vedere dove trovare il trucco...

5
Joomla! 3 / Re:Voce di menu che scompare a condizione
« il: 03 Giu 2016, 19:30:49 »
Non vedo come e dovrei sconvolgere troppe cose...

6
Joomla! 3 / Re:Voce di menu che scompare a condizione
« il: 03 Giu 2016, 11:34:33 »
Avete ragione, cerco di spiegarmi nel dettaglio:
L'utente registered apre questa voce di menu,nell'area riservata, collegata a un articolo che contiene uno script (in realtà contiene un loadposition di un modulo personalizzato html) nel quale c'è un'interrogazione a un database esterno che non c'entra nulla con joomla. E fin quì fila tutto liscio, si collega perfettamente ed esegue le operazioni richieste(si tratta di operazioni che riguardano inserimenti di dati su un'altro server esterno al sito tramite vari form).

Il problema è che questa è un'operazione che l'utente svolge una sola volta, dopodichè sarebbe più elegante che questa voce di menu non fosse più disponibile a chi già ha effettuato quelle operazioni tramite quella voce di menu.
Per risolvere ho inserito all'inizio dello script dell'articolo in questione una condizione che controlla un flag nel database esterno (non quello di joomla) che nel caso sia positivo non mostra il contenuto dell'articolo ma un messaggio che le operazioni risultano già eseguite e non c'e' necessità di ripeterle. E fin qui funziona tutto perfettamente.

Ma mi piaceva di più che la voce di menu scomparisse direttamente a chi già l'aveva utilizzata.
Allora pensavo di inserire nella pagina di benvenuto dopo il login (e ovviamente nelle altre sezioni dell'area riservata) una piccola istruzione che interrogasse il db esterno e che,se soddisfatta, nascondesse magari tramite css, quella voce di menu.

E' una cosa fattibile? O forse ci sono altre strade...

7
Joomla! 3 / Voce di menu che scompare a condizione
« il: 02 Giu 2016, 22:20:56 »
Salve a tutti.
La domanda è per qualcuno un pò più esperto di mysql o css.
In pratica ho una condizione if che determina alcune condizioni che si verificano
all'interno di un articolo. Una volta verificate queste condizioni vorrei che una voce del menu scomparisse.

Pensavo di utilizzare un display:none come risultato della condizione, ma non riesco ad applicarlo alla voce di menu.
Qualcuno ha qualche dritta?

Grazie e ciao

8
Ok, grazie, li cancello definitivamente. In effetti sembra la cosa più corretta da fare.

9
Salve a tutti.

Volevo un consiglio su come trattare i link obsoleti nel componente redirect.
Mi spiego: in seguito a un attacco hacker (ora risolto) ho nel componente redirect una grossa lista di URL (quelli hackerati del tipo www.miosito.it/***-cialis...) che ovviamente non esistono piu in seguito alla pulizia effettuata dopo l'infezione.

Cosa fare ai sensi del Seo? Conviene lasciarli cosi' oppure reindirizzarli a una pagina corretta (ad esempio tutte sulla home)?

10
A volte l'ovvio passa per eccezione.
Che ci sta a fare il forum se non si condividono con gli altri le soluzioni?  ;)

11
Alla fine ho risolto da solo. :( :P
Immaginando che il problema fosse qualche file corrotto da un precedente aggiornamento, ho preso l'intera cartella "com_config" originale della stessa versione installata e l'ho sovrascritta. La pagina è tornata funzionante.

12
Joomla! 3 / [RISOLTO]Configurazione globale: pagina bianca!
« il: 09 Feb 2016, 18:21:27 »
Ok, salve a tutti.
Ho preso in mano la manutenzione di un sito dov'era già installato joomla 3.
Attualmente la versione è correttamente aggiornata alla 3.4.8.

Scopro oggi che andando in "configurazione globale" ottengo una pagina bianca.
Abilitando il debug degli errori mi esce questo:


Warning:  Creating default object from empty value in /home/rsaigamx/public_html/administrator/components/com_config/config.php on line 28
 
 Fatal error:  Call to undefined method stdClass::execute() in /home/rsaigamx/public_html/administrator/components/com_config/config.php on line 31



Non credo riguardi il primo warning quanto il secondo. Cosa potrebbe essere successo?

13
Joomla! 3 / Re:Inclusione file esterni php?
« il: 30 Gen 2016, 11:11:04 »
E infatti... ::) :-[
grazie per aver aperto la mia mente che ultimamente fa capricci. :P
Metto il risolto...

14
Joomla! 3 / Re:Inclusione file esterni php?
« il: 29 Gen 2016, 21:48:19 »
Ma infatti così ho fatto, uso da un po sourcerer e mi trovo bene.
Ma se provo a includere un file esterno questo è l'errore che mi restituisce:

Warning:  include(../helloworld.php): failed to open stream: No such file or directory in /web/htdocs/www.rotard.it/home/plugins/system/sourcerer/helper.php(635) : runtime-created function on line 7

15
Joomla! 3 / [RISOLTO] Inclusione file esterni php?
« il: 29 Gen 2016, 14:44:00 »
Salve a tutti.
Il problema che mi ritrovo ad affrontare è il seguente:

Ho un modulo html personalizzato nel quale ho necessità di richiamare un file esterno php.
Regolarmente si utilizza
Codice: [Seleziona]
<?php include "filename.php"?>ma ovviamente in Joomla funziona. Qual è la sintassi da utilizzare?

16
Joomla! 1.6/1.7/2.5 / Icona aggiornamento joomla ubriaca!
« il: 07 Nov 2013, 09:14:57 »
Che nervi l'icona del pannello di controllo relativa agli avvisi di aggiornamento di joomla!
Continua a dirmi che devo aggiornare alla 2.5.10 quando invece e' tutto aggiornato (2.5.14), e non riesco a trovare dove risiede il problema!
Qualcuno ne sa qualcosa?

Thanks a tutti

17
Salve a tutti, sto utilizzando joomla 1.7 e avevo la necessita' di far comparire gli articoli nella categoria vista blog senza il testo introduttivo, cioe' solo con un immagine (che poi sarebbe la prima che si trova nell'articolo). Provando con un ovveride del template (il beez5), ho provato a modificare qualcosa nel file blog_item in html\com_content\category\ ma non va....qualche suggerimento?

Gracias

18
Per incorporare un filmato flash nel template di joomla ho semplicemente utilizzato il tag <object> all'interno dell'index, direttamente dal pannello di controllo alla gestione template.
Questa e' la sintassi completa utilizzata nella pagina html per il flash:

<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000"
   codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,40,0"
   width="900" height="140">
<param name="wmode" value="transparent" />
<param name="width" value="900" />
<param name="height" value="140" />
<param name="src" value="../filmatoflash.swf" />
<param name="quality" value="high" />
<embed type="application/x-shockwave-flash" width="900" height="140"
 src="../filmatoflash.swf" quality="high">
</embed>
</object>

come vedi fra i parametri che regolano il filmato ho semplicemente aggiunto quello della trasparenza et voila'. Funziona anche su IE! ;)
Spero di essere stato chiaro...

19
Purtroppo no, e' un'animazione complessa e comunque non posso cambiarla.
Sto cercando altre informazioni in rete ma fin'ora ancora niente...maledetto sia per sempre IE! :'(

Comunque ho risolto poco fa impostando nell'html il parametro:
<param name="wmode" value="transparent" />
ossia la trasparenza dello sfondo del filmato swf. Per ora non da problemi con gli altri browser in merito. Speriamo vada bene! 8)

20
Io invece ho un problema per il quale non ho trovato ancora soluzione e che, manco a dirlo, capita solo con IE!
Con tutti gli altri browser non succede:
Quando apro un qualsiasi popup fatto con mediabox si apre regolarmente ma un filmato flash esistente sulla pagina stessa si sovrappone alla finestra lightbox. Fra i parametri del plugin ho gia' imposta to a "yes" la voce "Hide objects" ma non si risolve...e' un bel problema...

Pagine: [1] 2 3
Host

Torna su