Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Post - erna

Pagine: [1]
1
Ragazzi,
il mio collo ha risolto il problema:
dopo aver effettuato l'aggiornamento Joomla al 1.5.14, sono andato dentro le configurazioni del sito ed ho cambiato l'impostazione del file phi.ini da: safe mode on a php.ini ottimizzato per Joomla.
Tutto è tornato a funzionare.
A questo punto ho una domanda: questo file php.ini deve essere settato su safe mode on o off??
Ho letto parecchi post a rigurdo ma sinceramento non essendo esperto,non ho mai capito bene come settarlo, nel dubbio lo avevo settato so on.
Ora tutto ok, avendo settato il file php.ini su "ottimizzato per Joomla" tutto è tornato ok.
Grazie di nuovo a Maicolstaip  ;), per la disponibilità, e certo ad Agosto non è facile trovare qualcuno che ti risponde.
Un satuto a tutti  ;D

2
Carissimo Maicolstaip,
innanzitutto GRAZIE per avermi dato un aiuto  ;), avevo già provato ha rifare l'aggiornamento, ma niente.
E' come se Joomla avesse cambiato i permessi per farmi accedere al pannello di admin lato web,l'altro problema è che joomla non carica il template  ???.
Stò leggendo tutti i post del forum  :-[, per carcare di capire quale potrebbe essere il problema.
Qualsiasi aiuto è ben accetto  ;).
Grazie a tutti

3
Aiuto,
eseguendo l'aggiornamento da joomla 1.5.11 a 1.5.14 non ho più la possibilità di aprire la pagina di back end come amministartore, in quanto ricevo il seguente warning:You don't have permission to access /administrator/ on this server.
In più il sito poverino è nudo, non ha più il template;in pratica funziona tutto, ma non visualizza il vestito. www.airkite.com
Come posso fare ???
Grazie in anticipo, sperando in un aiutino, pur sapendo che in agosto non sarà facile.

4
Sicurezza / Re: Impostazione Php safe mode on
« il: 15 Mar 2009, 15:16:25 »
Buongiorno a tutti,
ho cambiato il settaggio del safe mode da off a on dal pannello di controllo che il provider offre come servizio.
Per sicurezza ho cambiato anche i permessi dei file .php disabilitando la scrittura del file.
Ho creato un'area protetta per il file administrator:servizio offerto dal provider, quindi quando ci si logga bisogna inserire due credenziali.
Ma una cosa ancora non mi è chiara: perchè il provider dove risiede il sito da la possibilità di cambiare soltanto poche variabili del php??Per esempio vi è la possibilità si settare il php ottimizzato per Joomla! ma il safe mode è OFF!!!
Io avevo appunto spuntato questa configurazione ma poi leggendo su questo forum che è meglio avere il safe mode in ON, ho cambiato settaggio e inserito safe mode on, ma oltre a questo non mi consente di fare altre modifiche.
Per i warning:
Warning. Pattern match "\\byahoo(?:-(?:mmcrawler|blogs)|! slurp)\\b" at REQUEST_HEADERS:User-Agent. [file "/etc/apache/modsecurity/modsecurity_crs_55_marketing.conf"] [line "20"] [id "910007"] [msg "Yahoo robot activity"] [severity "NOTICE"] [hostname "www........com"] [uri "/index.php"] [unique_id "Sbvo3D6VjV8AAAa3L2IAAABK"]

 cosa devo fare??? Vi è qualche parametro da ottimizzare??
Sperando in un aiuto, vi ringrazio anticipatamente.

5
Sicurezza / Impostazione Php safe mode on
« il: 14 Mar 2009, 22:27:37 »
Salve a tutti,

è da un pò di tempo che si stanno registrando sul sito nuovi utenti con e-mailxxxxxx@xxxx.ru. Fin qui niente di male, il sito è aggiornato al 1.5.9 e per ora tutto ok. ??? Leggo spesso questa parte del forum per la sicurezza, ed è moolto interessante.
Premetto che sono novello di joomla e programmazione siti web, ma l'impegno è tanto.
Ho letto un pò di info sul file .php ma ho le idee confuse.
Ho controllato dal back end la configurazione del php del mio sito ed ho riscontrato la seguente situazione:

Safe Mode:      Off
Open basedir:    Nessuna
Mostra errori:    Off
Short Open Tags:    On
Caricamento file:    On
Magic Quotes:    On
Register Globals:    Off
Output Buffering:    Off
Percorso salvataggio sessione:    /tmp
Auto start sessione:    0
XML abilitato:    Si
Zlib abilitato:    Si
Funzioni disabilitate:    system,popen,dl,passthru,proc_open,shell_exec
Mbstring abilitato:    Si
Iconv disponibile:    Si
Editor WYSIWYG:    Editor - No Editor
Come faccio a cambiare l'impostazione da off a on?
Lanciando il test di errori file  di log del sito, è venuto fuori questa roba:

[Sat Mar 14 18:26:52 2009] [error] [client 74.6.17.180] ModSecurity: Warning. Pattern match "\\byahoo(?:-(?:mmcrawler|blogs)|! slurp)\\b" at REQUEST_HEADERS:User-Agent. [file "/etc/apache/modsecurity/modsecurity_crs_55_marketing.conf"] [line "20"] [id "910007"] [msg "Yahoo robot activity"] [severity "NOTICE"] [hostname "www........com"] [uri "/index.php"] [unique_id "Sbvo3D6VjV8AAAa3L2IAAABK"]
[Sat Mar 14 18:08:27 2009] [error] [client 72.30.79.52] ModSecurity: Warning. Pattern match "\\byahoo(?:-(?:mmcrawler|blogs)|! slurp)\\b" at REQUEST_HEADERS:User-Agent. [file "/etc/apache/modsecurity/modsecurity_crs_55_marketing.conf"] [line "20"] [id "910007"] [msg "Yahoo robot activity"] [severity "NOTICE"] [hostname "www......com"] [uri "/robots.txt"] [unique_id "Sbvkiz6VjWIAAHp8YWAAAADo"]

E' tutto ok??? Ma cosa è questo "Yahoo robot activiti"???

Grazie a tutti per le vostre info del forum, ma credetemi per un neofita, non è facile, ma credo con un pò di impegno tutto si può fare.

Grazie di nuovo PIer

6
Sicurezza / Re: aiuto sito hackerato
« il: 01 Ott 2008, 13:07:44 »
Ciao Fuser,

non sono in grado di poterti aiutare,io ho scritto tre post per un problema credo semplice veramente da demente ma nessuno si e' degnato di dare neanche il benvenuto ad un neofita che cerca di passare a software opensource.
Quello che io sto'facendo per risolvere il mio problema e' reinstallare tutto.Quindi cancellare il database sql,joomla 1.5.7, per poi ricominciare da capo con l'installazione.
So che un po' di pratica non fa mai male infatti il mio impegno e' massimo.
Non so' se tu hai dei bck del tuo sito, in caso positivo l'unico consiglio che posso darti e' cancellare tutto e ricominciare da zero con la 1.5.7.
Ripeto non sono esperto di Joomla ma quando un hacker ti ha sputtanato il tuto sito, ho sai dove mettere le mani oppure non so forse e' bene dare una bella pulita a tutto????
Ti saluti Fuser, sperando che almenoa te qualcuno risponda.

Ciao






7
Sicurezza / Nuova creazione utente admin joomla 1.5.7
« il: 30 Set 2008, 22:40:58 »
Perdonatemi ma c'e' la metto proprio tutta,
non riuscendo ad entrare come admin sull'interfaccia grafica di joomla 1.5.7 ed avendo modificato la password tramite procedura pubblicata su wikijoomla, ho rimosso l'utente admin e sempre tramite procedura sto' cercando di ricrearlo.
Purtroppo seguendo passo passo tale procedura ricevo il seguente errore:
Server: xxx.xxx.xxx.xx  -   Database: Sqxxxxxxx
Errore

query SQL:

INSERT
INTO `jos_users`
VALUES ( 62, 'Amministratore', 'admin2', 'tuoindirizzo.email@email.com', 'af68ca4cc7fdb63463f924fcbc2e1ccb:HQizAYOkOcznVvrlNZeKl2zoOPd3CKaA', 'Super Administrator', 0, 1, 25, '2008-09-01 00:00:00', '2008-09-01 00:00:00', , )

Messaggio di MySQL: Documentazione
#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ' )' at line 5

Non riesco proprio ad andare avanti. ???

Il server dove si trova il database ha installato phpMyAdmin - 2.9.1.1.

So che per chi e' all'altezza e' una stupidaggine risolvere questo problema, ma credetemi per me e' veramente dura.
Sperando di comunicare con qualcuno un saluto a tutti.


8
Sicurezza / Cambio pwd admin joomla 1.5.7
« il: 30 Set 2008, 21:04:44 »
Salve a tutti,


correggo il post precedente, la versione installata di joomla e' la 1.5.7.

Ho questo problema che non riesco ad accedere al pannello di controllo di joomla, pur avendo cambiato la pwd di admin correttamente su db.

Una domanda: ma quando si cambia la password di admin sul db non dovrebbe arrivare una e-mail all'amministartore dell'avvenuto cambiamento?

Sperando in una risposta

Grazie 

9
Sicurezza / Problema pwd amministrator jommla 1.5.6
« il: 30 Set 2008, 19:05:38 »
Salva a tutti,

sono nuovo di tutto quanto riguarga programmazione,

ma con molto impegno cerco di capirci qualche cosa.

Ho installato joomla 1.5.6 sul server che ospita il mio sito.

Fino qui tutto ok, un ringraziamento a tutti, per le traduzioni in italiano dei vari tutorial  della piattaforma joomla.

Il sito inizia a funzionare regolarmente, smanetto un po' con i vari moduli, componenti ecc ecc.

Appena installato joomla 1.5.xx coma da guida ho cambiato login e pwd di amministarzione.Tutto ok ma da ieri sera non riesco piu' ad loggarmi come admin.
Ho provveduto a eseguire la procedura per il cambio password di admin tramite "Recupero password admin" pubblicato su wikijoomla.
Tutto ok il database esegue la modifica ma non riesco ugualmente a loggarmi come admin.

Il sito funziona regolarmente nel senso che non noto anomalie.
Qualcuno gentilmente potrebbe aiutarmi ad accedere al pannello di controllo di joomla?
Sto' leggendo un'infinità di post ma non riesco a trovare nulla che possa aiutarmi.
Ho riprovato a cambiare la pwd piu volte con la procedura pubblicata su wiki ma niente, sul database tutto ok ma non mi loggo.

Un preventivo ringraziamento Pier


Pagine: [1]
Host

Torna su