Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Post - Zio_Mauri

Pagine: [1]
1
Ciao a tutti,

sto cercando di provare a fare qualche modifica al template che sto usando, ma vado a sbattere contro la mia ignoranza in html e php.
Mentre provo a studiare qualcosa in merito, provo a fare qualche esperimento. Scopro così che duplicando una parte del codice html, ottengo tre nuove posizioni in fondo alla pagina. faccio qualche altra modifica ai nomi delle aree, e così ottengo "user 8,9 e 10" subito sotto alle aree "user 5,6,e 7" originali.

il codice che duplico è il seguente:
Codice: [Seleziona]
<?php if($this->countModules('user8 or user9 or user10')) : ?>
                            <div id="user_bottom">
                                    <div class="user_bg">
                                        <div class="user_left">
                                            <div class="user_right">

<?php if($this->countModules('user8')) : ?>
                                                    <div class="bottom_user<?php echo $userwidth?>">
                                                    <div class="user_inside1"><jdoc:include type="modules" name="user8" style="xhtml" /></div>
                                                    </div>
                                                <?php endif; ?>
                                                <?php if($this->countModules('user9')) : ?>
                                                    <div class="separator"></div>
                                                    <div class="bottom_user<?php echo $userwidth?>">
                                                    <div class="user_inside"><jdoc:include type="modules" name="user9" style="xhtml" /></div>
                                                    </div>
                                                <?php endif; ?>
                                                <?php if($this->countModules('user10')) : ?>
                                                    <div class="separator"></div>
                                                    <div class="bottom_user<?php echo $userwidth?>">
                                                    <div class="user_inside"><jdoc:include type="modules" name="user10" style="xhtml" /></div>
                                                    </div>
                                                <?php endif; ?>
                                            </div>
                                        </div>
                                    </div>
                            </div>
<?php endif; ?>

Mi piacerebbe capire qual'è la traduzione di questo codice, e quali sono le condizioni poste dai comandi "if".
Non capisco, ad esempi, perchè le aree non sono visibili se non vengono assegnate. Inoltre, se assegno un modulo all'area user8 e nulla alle altre, il titolo dell'area occupa tutto lo spazio a disposizione, ma l'area utile effettiva è solo un terzo.
Spero di essermi spiegato decentemente (ma in realtà un pò ne dubito  :( )
Il sito in questione è www.scicaibz.altervista.org

Grazie in anticipo a chi vorrà istruirmi  :D

2
Mi associoall'interesse.   ;)

Quali sono i componenti non free che hai trovato?

Mauri

3
Joomla! 1.5 / Re:Aspetto Categoria e Aspetto Sezione
« il: 29 Dic 2009, 13:48:52 »
intanto ti ringrazio  :D

non e' una cosa trascendentale in effetti, ma se volessi non motrare le visite ma le date per es,o togliere il filtro, non posso farlo da un aspetto sezione...
chissa che magari in un futuro nei parametri sell aspetto sezione compaia qualcosa relativo all'aspetto categoria creato in automatico...

Grazie!

Prova a creare un nuovo menu, inserisci la voce relativa alla categoria che ti interessa e selezioni le opzioni che preferisci, poi non pubblichi il modulo menu.

Secondo me così risolvi....

Auguri!!! (in tutti isensi... ::))

4
I Template di Joomla 1.5.x / Re:CSS e Firebug
« il: 17 Dic 2009, 15:08:38 »
A quel modulo puoi assegnare un Suffisso classe CSS modulo?
Se si, fallo e poi formatti solo quello...

Grazie Toni per il supporto. Non so perchè ma adesso funziona, o meglio, appena tolta la riga continuava a non funzionare, ora invece è a posto.  :o
Direi colpa mia che avevo controllato male dopo la modifica del css.
Fortuna, perchè quando ho letto di assegnare un Suffisso di classe mi si è velata la vista  :-[ Credo di essere ancora tropppo scarso per fare quello che mi hai suggerito.
Qualche dritta per trovare info "for Very Dummies" sull'argomento?


Mauri

5
I Template di Joomla 1.5.x / Re:CSS e Firebug
« il: 17 Dic 2009, 07:45:56 »
Ciao.
In genere le estensioni hanno dei css propri hai provato a vedere dove si trova il css del componente che stai utilizzando?
Il css del modulo ha questa riga:
background: #e4f2fd;
che però viene sovrascritta

E' una libera interpretazione della regola scritta nel css da parte di firebug.
Ci sta scritto:
background: none;
e firebug legge:
background:transparent none repeat scroll 0 0;
che ai fini pratici è la stessa cosa.
Tu cancella quella riga e risolvi.
Male che vada mettici un colore di background  ;)

Purtroppo non è così :-(
Ho tolto la riga, ma il problema rimane. Scavando ancora ho scoperto che questa fantomatica riga 277 è applicata a tutti i moduli del template. Essendo il Floating Box parte del modulo, riceve gli le stesse proprietà. Il punto è che che, per esempio, la riga:
-moz-background-clip:border;
non la trovo nel file template.css ne da altre parti. Sembrerebbe "iniettata" in qualche modo.
Qualche idea?

Mauri

6
I Template di Joomla 1.5.x / CSS e Firebug
« il: 16 Dic 2009, 21:52:13 »
Ciao a tutti,
sto utilizzando UddeIm come PMS, ed houn problema con il Floating Box che mi segnala i nuovi messaggi.
Lo sfondo del box è trasparente, e quindi il tutto è praticamente illeggibile.
Ho provato a studiarci un pò, ma dato che sono troppo scarso, non ho risolto nulla, ma qualcosa ho comunque scoperto. Il problema è legato al template che uso (sunshine).

Ho provato allora acontrollare la pagina con firebug, ed ho scoperto una riga...

background:red none repeat scroll 0 0;

... che se viene disattivata risolve il problema. Firebug parla di "template.css (riga 277)". Penso: "è fatta!!!"
Apro il file CSS e lo modifico, ma...
questo è il css a quella riga:

277 #left_out .module div div div,
278 #right_out .module div div div,
279 #left_out .moduletable div div div,
280 #right_out .moduletable div div div,
281 #left_out .module_menu div div div,
282 #right_out .module_menu div div div,
283 #left_out .module_text div div div,
284 #right_out .module_text div div div{
285   background: none;
286   padding: 5px 5px 10px 5px;
287   overflow: hidden;
288   width: 172px;
289 }


...invece Firebug mi visualizza:

#left_out .module div div div, #right_out .module div div div, #left_out .moduletable div div div, #right_out .moduletable div div div, #left_out .module_menu div div div, #right_out .module_menu div div div, #left_out .module_text div div div, #right_out .module_text div div div {
-moz-background-clip:border;
-moz-background-inline-policy:continuous;
-moz-background-origin:padding;
background:transparent none repeat scroll 0 0;
overflow:hidden;
padding:5px 5px 10px;
width:172px;

La domanda è: da dove arrivano le ultime righe? Non sono nel file template.css, cosa le genera? Ho provato a studiarci un pò, ma è troppo oltre il mio livello.

Qualcuno mi sa aiutare?

Mauri

7
Joomla! 1.5 / Re:EventList NextEvent
« il: 19 Mag 2009, 15:00:35 »
qualcuno ha la traduzione in italiano del modulo nextevent per eventlist?
grazie

Io mi sono tradotto il front end. Se vuoi te lo invio, ma sono quattro righe, fai prima a fartelo....

8
Joomla! 1.5 / Re: Problema con REMOSITORY
« il: 15 Mag 2009, 18:10:04 »
Idem, ho lo stesso problema.
Qualcuno ne sa qualcosa?
Grazie in anticipo a chi mi aiuterà!

Un po' in ritardo:
di default salva nel database, va bene solo per filedi pochissimi mega e per non oltre 100 file.
Per salvare in una cartella sul sito, disabilita il salvataggio nel database e dagli un percorso assoluto dove mettere i file in configurazione contenitori. Se non ti salva il percorso vuol dire che non lo trova.

Se non riesci fammi sapere che cerco di essere piu' dettagliato.
Mauri

9
Joomla! 1.5 / Re:Legacy mode on e strana gestione dei login
« il: 15 Mag 2009, 08:47:37 »
che versione c'è del php?
sei su altervista per caso?

Joomla ver 1.5.10
PHP 5
ebbene si, sono su altervista... gia' il fatto che me lo chiedi mi fa pensare che sono nei guai...  :-)

Mauri

10
Joomla! 1.5 / Legacy mode on e strana gestione dei login
« il: 13 Mag 2009, 19:40:50 »
Ciao a tutti.
Ho provato ad abilitare il legacy mode sul mio sito perche' avevo intenzione di utilizzare DocMan.
Purtroppo ho immediatamente avuto problemi sia sul back che sul front end. Era impossibile effettuare il login dal front end con qualsiasi user. Nessun messaggio di errore, semplicemente viene ricaricata pari pari la home page.
Il login amministratore va fatto due volte perche' la prima ti dice che la tua sessione e' scaduta. Poi una volta "loggati", spesso avvisa che la sessione e' scaduta.

Un vero peccato perche' cerco un gestore download che abbia la possibilita' di gestire permessi su utenti e gruppi di utenti. DocMan lo fa ma sono soggetto all'attivazione del legacy mode, che come detto, mi crea qualche imbarazzo. C'e' qualche altro download manager che gestisce bene i permessi?

Mauri

11
L'ultima versione dovrebbe mantenere la formattazione in home page ma a me non funziona.
Continua a togliermi sia i colori che le dimensioni del testo, e mi "appiattisce" i link... ;-(

12
Joomla! 1.5 / Re: modulo incancellabile...
« il: 12 Mar 2009, 10:03:21 »
Forse non hai scelto la miglior sezione del forum , ma in ogni caso, secondo me dovresti aggiungere qualche dato in piu' se vuoi che qualcuno ti aiuti. Per esempio qual'e' la "skin" di cui parli, e magari un indirizzo dove vederla installata.

Mauri

13
Joomla! 1.5 / extplorer non si installa
« il: 10 Mar 2009, 18:17:45 »
Ho provato ad installare questo componente e ricevo un errore 500, anche con installazione da cartella tmp
Il componente dopo l'installazione fallita e' presente ma non funziona.

questi alcuni errori visualizzati:
Notice: ini_set() has been disabled for security reasons in /membri/scicaibz/administrator/components/com_extplorer/libraries/PEAR.php on line 63

Warning: realpath() [function.realpath]: SAFE MODE Restriction in effect. The script whose uid is 159054 is not allowed to access /var/www/html owned by uid 0 in /membri/scicaibz/administrator/components/com_extplorer/include/functions.php on line 76

Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/var/www/html) is not within the allowed path(s): (/membri) in /membri/scicaibz/administrator/components/com_extplorer/include/init.php on line 240

Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/var/www/html) is not within the allowed path(s): (/membri) in /membri/scicaibz/administrator/components/com_extplorer/include/init.php on line 241

qualche idea?

Mauri

14
Aggiungo la soluzione che utilizzo io, per completezza...

Editor off
Nuovo articolo
"<iframe name="I1" src="/nome_del_tuo_file.pdf" width="640" height="700">
</iframe>"
Salva
Editor on

L'editor va spento altrimenti ti filtra l'html e non riesci a creare l'articolo.
Ultimamente ho installato un plug in che si chiama "Editor Button - Insert HTML" che mi evita lo switching on/off dell'editor.

Ciao e grazie a tutti.

Mauri

15
Joomla! 1.5 / Re: Modificare pagina Errore 403
« il: 13 Feb 2009, 10:18:10 »
E allora fai così:
http://www.joomla.it/articoli-della-community/781-guida-come-personalizzare-la-pagina-di-errore-404-in-joomla-15.html
ovviamente mirando all'errore 403 e non 404

buon lavoro

Ho provato a seguire questa strada per gestire la pagina di errore 403, ma ottengo "Il sito Web ha rifiutato di visualizzare la pagina Web" e "Cause più probabili:Il sito Web richiede le credenziali di accesso. "
In effetti l'errore 403 e' dovuto al tentativo di visualizzare una pagina disponibile solo a chi si e' registrato,
Pero' non visualizzo la "pagina-articolo" preparata per l'errore.

Dove sbaglio?1? :-\
Hosting Altervista.

Edit:Ora ho fatto caso che il sito locale si comporta diversmente. Viene visualizzata una pagina, in caso di contenuto "registered" ed user non loggato, che dice: "Per accedere all'area privata di questo sito, connettiti utilizzando i tuoi Nome utente e Password. "
Si tratta quindi di diversa gestione dell'errore del server locale ripetto ad altervista?

Grazie in anticipo a chi mi sapra' chiarire le idee.

Mauri


16
Torno su questo argomento, perche' mi sono accorto che alcuni plugin di CB mi restituiscono un "errore 500" se tento di accedervi lato backend (per esempio Private Message System).
Il problema si risolve disattivando php5 (host altervista)

Puo' essere relativo al bug citato nel link piu' sopra?

Mauri

17
Grazie per la segnalazione, avevo anche letto il 3d, ma non lo avevo associato al mio problema  :-[

Mauri

18
Ho installato CB 1.2 su una installazione Joomla 1.5.
Tutto sembra andare perfettamente durante l'installazione, ma quando visualizzo il lato admin del componente, mi mancano le icone ed i tab standard ( tipo "cancel" "save" ecc.)
Poco male, senonche' proprio nella sezione USER non fuzionano nemmeno i  link  "save" & "cancel".
Quindi sono in difficolta' a gestire gli utenti dal back end.
Tutto il resto non ha problemi di sorta.

Detto che offline funziona perfettamente,e che il sito risiede su Altervista, puo' essere un problema di permessi?

Grazie a chi sapra' darmi una mano....

Mauri

19
Joomla! 1.5 / Re: Visualizzare files pdf in sito con Joomla
« il: 22 Gen 2009, 14:21:29 »
Scusa Francesco, ma non ho capito, (niubbo totale!!!).
Se il file nomefile.pdf è nella mia root come lo richiamo nel menù ?


Ok, ho risolto...Grazie


Ahem... come?

Pagine: [1]
Host

Torna su