Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Post - fly76

Pagine: 1 [2] 3 4 5 6
21
Ok verifichero' anche questo.... Ma possiamo dire di aver ristretto la ricerca del problema nel template?

22
Grazie di nuovo,  quella riga di codice la devo inserire nel file error. Php in una posizione qualunque del codice?

Poi Verifico nel log error che tipo di errori mi segnala?

Potrei addirittura risolvere senza nient'altro?

23
Grazie della risposta, il file lo error c'Ŕ l'ho Ŕ i tecnici del server dicono che in particolare chi da un enorme carico al server Ŕ  quella riga di cui sopra, comunque il loro report Ŕ questo:

Buongiorno,

come indicato dal nostro reparto commerciale, le forniamo i dati disponibili per il suo dominio. Questi sono i processi attualmente collegati al suo sito web, come pu˛ notare il numero di processi Ŕ molto alto con un consumo di CPU notevole per ognuno di essi:

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
3200 trade60s 20 0 255m 23m 4504 R 3.2 2.4 0:08.57 apache2
3202 trade60s 20 0 255m 23m 4504 R 3.2 2.4 0:08.39 apache2
3236 trade60s 20 0 255m 23m 4504 R 3.2 2.4 0:08.08 apache2
3242 trade60s 20 0 255m 24m 4448 R 3.2 2.4 0:07.84 apache2
3247 trade60s 20 0 255m 24m 4448 R 3.2 2.4 0:07.55 apache2
3263 trade60s 20 0 255m 23m 4508 R 3.2 2.4 0:07.34 apache2
3264 trade60s 20 0 255m 24m 4448 R 3.2 2.4 0:07.33 apache2
3375 trade60s 20 0 255m 24m 4452 R 3.2 2.4 0:03.92 apache2
3533 trade60s 20 0 264m 33m 4624 R 3.2 3.3 0:00.98 apache2
3593 trade60s 20 0 252m 20m 4092 R 3.2 2.1 0:00.22 apache2
3596 trade60s 20 0 252m 20m 4092 R 3.2 2.1 0:00.22 apache2
3072 trade60s 20 0 255m 23m 4452 R 2.9 2.4 0:20.37 apache2
3192 trade60s 20 0 255m 24m 4452 R 2.9 2.4 0:08.86 apache2
3203 trade60s 20 0 255m 24m 4448 R 2.9 2.4 0:08.39 apache2
3237 trade60s 20 0 255m 24m 4448 R 2.9 2.4 0:08.06 apache2
3241 trade60s 20 0 255m 23m 4504 R 2.9 2.4 0:07.84 apache2
3244 trade60s 20 0 255m 23m 4504 R 2.9 2.4 0:07.56 apache2
3305 trade60s 20 0 255m 23m 4508 R 2.9 2.4 0:05.81 apache2
3523 trade60s 20 0 268m 36m 4716 R 2.9 3.7 0:01.15 apache2
3534 trade60s 20 0 255m 24m 4448 R 2.9 2.4 0:00.97 apache2
3546 trade60s 20 0 254m 23m 4504 R 2.9 2.3 0:00.69 apache2
3595 trade60s 20 0 252m 20m 4096 R 2.9 2.1 0:00.22 apache2
3598 trade60s 20 0 252m 20m 4092 R 2.9 2.1 0:00.21 apache2
3599 trade60s 20 0 252m 20m 4092 R 2.9 2.1 0:00.21 apache2
3600 trade60s 20 0 253m 20m 4092 R 2.9 2.1 0:00.19 apache2
3601 trade60s 20 0 249m 17m 4064 R 2.9 1.8 0:00.11 apache2
3603 trade60s 20 0 249m 16m 4064 R 2.9 1.7 0:00.09 apache2
3604 trade60s 20 0 249m 16m 4064 R 2.9 1.7 0:00.09 apache2

A prova del carico generato, le indichiamo anche lo stato attuale del carico sul processore: load average: 19.10, 21.72, 12.55. Su di un servizio di tipo cloud, si incontrano giÓ possibilitÓ di disservizio quanto il primo valore si aggira intorno al valore 08.00, pertanto 20 Ŕ un numero molto molto alto che genererÓ di sicuro delle problematiche di funzionamento. Altro dato utile, che potrebbe essere quello che per qualche motivo genera il problema, le forniamo l'errore costantemente riportato nel log degli errori:

[Tue May 31 14:32:30 2016] [error] [client 93.51.23.91] PHP Fatal error: Call to undefined method Exception::get() in /home/web/www.trade60secondi.com/www/templates/jomi/error.php on line 58, referer: http://trade60secondi.com/forum-traders.html

Le ricordiamo che i log sono a sua disposizione tramite accesso FTP in modo che possa prenderne visione in qualsiasi momento.

Restiamo a sua disposizione per qualsiasi ulteriore necessitÓ o chiarimenti in merito,

Cordialmente

24
L'aggiornamento php non ha risolto il problema!


25
Debug del sito tramite il backend di Joomla?

26
<?php


/**


* @package   yoo_master


* @author    YOOtheme http://www.yootheme.com


* @copyright Copyright (C) YOOtheme GmbH


* @license   http://www.gnu.org/licenses/gpl.html GNU/GPL


*/





// no direct access


defined('_JEXEC') or die('Restricted access');





// include config   


include_once(dirname(__FILE__).'/config.php');





// get warp


$warp = Warp::getInstance();





// set messages


$title   = $this->title;


$error   = $this->error->get('code'); //---<Riga 58>---


$message = $this->error->get('message');





// set 404 messages


if ($error == '404') {


    $title   = JText::_('TPL_WARP_404_PAGE_TITLE');


    $message = JText::sprintf('TPL_WARP_404_PAGE_MESSAGE', JURI::root(false), $warp['config']->get('site_name'));


}





// render error layout


echo $warp['template']->render('error', compact('title', 'error', 'message'));

27
:o :o  ci vogliono 2 min.

Non mi sei di aiuto, si cerca una soluzione non delle battutine!

Grazie

28
;D  dicono che non sia quello il codice...comunque hai attivato php 5.6?

 Me lo stanno attivando...tempi tecnici!

29
cosa c'Ŕ in quella pezzo di codice?

Se lo sapevo non aprivo il post......dovrebbe essere un modulo ma non so cos'Ŕ!

30

come giÓ detto di questo file

Ok quindi?

31
jQuery(function($) {
SqueezeBox.initialize({});
SqueezeBox.assign($('a.modal').get(), {
parse: 'rel'
});
});
function jModalClose() {
SqueezeBox.close();
}
c'Ŕ questo codice ma non riesco a capire a cosa serve!

32
ok grazie a tutti per le pronte risposte!

A domani...

33
Forse mi sono espresso male io, ma loro mi hanno trasferito ad un server dedicato tutto per me con una cpu un giga di ram e 15gb di diisco.

34
Gestisco tutto io joomla ma non sono poroprio un webmaster ho diverse limitazioni purtroppo di preparazione, il servizio Ŕ un cloud dedicato professionale!

Potrei richiedere l'aggiornamento a PHP 5.6 allora  evedere se risolviamo...ma il problema primario alla riga 58 di quel file non si riesce a capire cos'Ŕ?

35
Glie lo chiesto e non sanno se recano danni al sito aggiornando il php.

MA potrei risolvere in questo caso?? Ma perchŔ prima comunque funzionava tutto in un servere condiviso e in un server dedicato no?

36
ChissÓ. Le estensioni sono tutte aggiornate? E Joomla?

Tutto aggiornato  parte Akeeba backup che mi restituisce questo errore da una ettima circa:

 You are using an obsolete PHP version  Your site is running on PHP 5.4.45-0+deb7u2 which has stopped receiving security updates since Giovedý, 03 Settembre 2015. Using this on a live site is dangerous: unpatched security issues can get your site hacked. Moreover, we can only guarantee support for obsolete versions of PHP after nine months since their end-of-life date. Therefore, support for your version of PHP may be dropped any time after Venerdý, 03 Giugno 2016. We strongly advise you to ask your host to upgrade your site to PHP 5.6 or later.      
 

37
Ovviamente ho un forum ed Ŕ kunena l'ultima versione, quella pagina l'ho creata io per veicolare l'utenza verso il Forum che ha bisogno di registrazion obbligatoria

38
Ci˛ che Ŕ rilevante Ŕ alla linea 58 di questo file: /templates/jomi/error.php
Non di questo: forum-traders.html (che non Ŕ un file html/php)

Potrebbe esserci un errore nel template visto che jomi Ŕ il mio template che non mi ha dato mai nesun problema?

39
Ho il modulo registrazione standard di Joomla con il Recapha integrato sempre a joomla nulla di pi¨ e ha sempre funzionato.

Ieri il provider mi ha bloccato il sito che era nel server condiviso dicendomi che aveva sovraccaricato tutto il loro sistema con 400 siti e 128 gb di ram.

Era in programma l'upgrade ad un server dedicato e cosi Ŕ stato fatto ma con un CPU e 1GB di ram Ŕ tutto fermo.

A tutt'ora non riesco praticamente a far nulla.

cosa potrebbe dare conflitto o fastidio?

40
jQuery(function($) {
SqueezeBox.initialize({});
SqueezeBox.assign($('a.modal').get(), {
parse: 'rel'
});
});
function jModalClose() {
SqueezeBox.close();
}

c'Ŕ questo codice ma non riesco a capire a cosa serve!

Pagine: 1 [2] 3 4 5 6
Host

Torna su