Autore Topic: inserimento slide in javascript in un modulo...e tutti i testi diventano link!!!  (Letto 3942 volte)

Offline Noise Comunica

  • Appassionato
  • ***
  • Post: 317
  • Sesso: Maschio
    • Mostra profilo
Cari amici,
ho inserito una slide in javascript in un modulo...e mi succede che qualsiasi testo che c'è sul sito (anche benvenuto in joomla) mi diventa una parte attiva...un link!

Qualcuno sa dirmi il perchè?

www.demacart.com/index.php

Questo è il codice inserito all'interno del modulo


Codice: [Seleziona]
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>Horizontal Slide Menu</title>
<link rel="stylesheet" type="text/css" href="slidemenu.css" />
<script type="text/javascript" src="slidemenu.js"></script>
</head>
<body onload="slideMenu.build('sm',700,10,10,1)">
<div align="center">
  <ul id="sm" class="sm">
    <li><a href="http://www.livescore.com"><img src="image/1.jpg" alt="http://www.livescore.com" /></li>
    <li><a href="http://www.ansa.it"><img src="image/2.jpg" alt="" /></li>
    <li><img src="image/3.jpg" alt="" /></li>
    <li><img src="image/4.jpg" alt="" /></li>
  </ul>
</div>
</body>
« Ultima modifica: 21 Apr 2010, 14:50:18 da 56francesco »

Offline Noise Comunica

  • Appassionato
  • ***
  • Post: 317
  • Sesso: Maschio
    • Mostra profilo
qualcuno può aiutarmi?

Offline maicolstaip

  • Global Moderator
  • Instancabile
  • ********
  • Post: 17623
  • Sesso: Maschio
    • Mostra profilo
Ciao sgugniz,
per cortesia evita di uppare dopo due ore.
Quando qualcuno ti potrà e saprà aiutare risponderà  ;)
Non si risponde a PM tecnici. Postate sul forum. Grazie.

Offline Noise Comunica

  • Appassionato
  • ***
  • Post: 317
  • Sesso: Maschio
    • Mostra profilo
ok...chiedo scusa...

ancora non risolvo...

Offline Noise Comunica

  • Appassionato
  • ***
  • Post: 317
  • Sesso: Maschio
    • Mostra profilo
ragazzi..nessuno mi aiuta?

Offline santograz

  • Abituale
  • ****
  • Post: 907
  • Sesso: Maschio
    • Mostra profilo
Ciao,
ho visitato il sito con Firefox e nonho riscontrato il problema, anche i testi "prova" sono solo testi.

Comunque, se metti in un modulo un codice di quel genere, con tanto di tag <head> e <body> all'interno di quelli del template, crei un po' di problemi ai browser.

Un esperto mi ha detto:"Per avere un sito web sicuro, installalo su di un server locale, poi spegnilo e stacca i cavi". Mi hanno rubato il computer.

Offline Noise Comunica

  • Appassionato
  • ***
  • Post: 317
  • Sesso: Maschio
    • Mostra profilo
prova a cliccare su benvenuto in joomla....

Offline maicolstaip

  • Global Moderator
  • Instancabile
  • ********
  • Post: 17623
  • Sesso: Maschio
    • Mostra profilo
Ciao scugniz,
prova così ma non posso testarlo e quindi non son sicuro al 100% che funzioni:

Questo lo metti prima dell' tag </head> del file index.php del template

Codice: [Seleziona]
<link rel="stylesheet" type="text/css" href="slidemenu.css" />
<script type="text/javascript" src="slidemenu.js"></script>

---------------------------

Questo lo metti dopo <body> dell'index.php del template

Codice: [Seleziona]
<body onload="slideMenu.build('sm',700,10,10,1)">
------------------------

Questo lo metti nel modulo

Codice: [Seleziona]
<div align="center">
  <ul id="sm" class="sm">
    <li><a href="http://www.livescore.com"><img src="image/1.jpg" alt="http://www.livescore.com" /></li>
    <li><a href="http://www.ansa.it"><img src="image/2.jpg" alt="" /></li>
    <li><img src="image/3.jpg" alt="" /></li>
    <li><img src="image/4.jpg" alt="" /></li>
  </ul>
</div>
Non si risponde a PM tecnici. Postate sul forum. Grazie.

Offline MatthewG

  • Esploratore
  • **
  • Post: 90
    • Mostra profilo
Risolto?
I link del menu funzionano bene, quelli delle slide orizzontali no, ci sono link tipo a facebook!

Offline santograz

  • Abituale
  • ****
  • Post: 907
  • Sesso: Maschio
    • Mostra profilo
Eh eh,
stai usando uno slider progettato per un altro sito. Non credo lo risolvi da PHP, il problema è in JS...
Un esperto mi ha detto:"Per avere un sito web sicuro, installalo su di un server locale, poi spegnilo e stacca i cavi". Mi hanno rubato il computer.

 

Host

Torna su