Autore Topic: problema con params.ini  (Letto 661 volte)

Offline bafalobill

  • Nuovo arrivato
  • *
  • Post: 2
    • Mostra profilo
problema con params.ini
« il: 10 Nov 2010, 14:46:37 »
salve a tutti, ho un piccolo problema da sottoporvi.
Devo rendere fluido un template che non prevede la modifica dei propri parametri. Ho provato a fare quanto segue:
Ho creato un file params.ini, l'ho posizionato nella cartella del template, ho modificato il file templateDetails.xml come suggerisce la guida a questo indirizzo: http://wiki.joomla.it/index.php?title=Parametri_dei_Template.

ora nella pagina di gestione del template mi compare la possibilità di variare il parametro "Template Width". le informazioni vengono salvate, anche nel file params.ini  (ho provato a aprirlo con un editor di testo e appaiono valori diversi al variare dell'impostazione data in joomla). 
Tuttavia non appare alcuna modifica al sito. se il template fosse diventato fluido a una riduzione di dimensioni della finestra non dovrebbe comparire alcuna barra di navigazione orizzontale.

E' come se mancasse una riga che dicesse a joomla di usare il params.ini al caricamento della pagina.

sapete indicarmi cosa posso fare?

grazie, saluti

Offline conti1

  • Global Moderator
  • Instancabile
  • *****
  • Post: 9052
  • Sesso: Maschio
    • Mostra profilo
Re:problema con params.ini
« Risposta #1 il: 10 Nov 2010, 15:26:55 »
ciao
benvenuto nel forum
è normale che non funzioni  non basta dare  un un" ini "e modificare il" xml "per far si che un template diventi fluido, ora dovrai interagire con il php del template  e il css x dare le impostazioni  giuste .
esempio
xml:
leghezza template
fissa = 980px
fluida = 100%

a questo punto nel file xml  selezioni una delle due  , che  sua volta  avrà un richiamo nel php   che a secondo della tua scelta fatta che sia  980px o fluida  andrà a caricare un css fatto da te in precedenza .
solo a questo punto il template  diventa fluido o no.
non dimentichiamo anche come e stato realizzato il template , xchè se il template ah immagini  di dimensioni fisse quando lo rendi fluide  dovrai modificare anche quelle.
buon divertimento

se possibile postare il link  x risolvere al meglio il problema grazie
evitare nomi commerciali grazie

Offline bafalobill

  • Nuovo arrivato
  • *
  • Post: 2
    • Mostra profilo
Re:problema con params.ini
« Risposta #2 il: 10 Nov 2010, 18:54:03 »
grazie per la risposta, ora vedo che riesco a fare.

ciao

 

Host

Torna su