Autore Topic: Problema trasferimento  (Letto 1214 volte)

Offline akeba

  • Nuovo arrivato
  • *
  • Post: 44
  • Sesso: Femmina
    • Mostra profilo
Problema trasferimento
« il: 13 Gen 2011, 08:54:21 »
Salve amici di Joomla.it,
sono quì a chiedere il vostro aiuto perchè non sò proprio come fare per risolvere il mio problema.
Ho sviluppato un sito in Joomla su un dominio di terzo livello di Altervista e non ho avuto nessun tipo di problema.
Si tratta di un rifacimento di un vecchio sito in html ospitato da un altro provider (Consultingweb ,spero si possano scrivere i nomi..li ho trovati cercando in altre discussioni del forum quindi mi permetto di farlo..se così non è, chiedo scusa e provvederò alla modifica del post).
Al momento del trasferimento abbiamo chiesto il cambio di server da windows a linux e l' attivazione di un db.Sono riuscita a trasferire il sito manualmente in quanto joomlapack mi dava già un errore ma comunque è andato tutto a buon fine.
Adesso mi trovo però diversi problemi collegati probabilmente alla stessa matrice che però io non riesco ad individuare probabilmente perchè non ne ho le competenze necessarie.

- Il pannello di controllo di Akeeba back up mostra un avviso rosso in cui dice che non è possibile fare back up   perchè la directory temporanea non è scrivibile.
-Non riesco a intallare estensioni nè da archivio nè dalla cartella temp.
Nel primo caso (metodo classico da archivio) l' errore che mi riporta é:

WARNING!FAILED TO MOVE FILE

Nel secondo caso (dalla cartella temp) mi dice:

JFolder::create: Could not create directory
Component Install: Failed to create directory.: "/home/www-tol/xxxxxx/public/xxxxx/components/com_joomfish"

Cercando in rete e nel vostro forum queste sono i controlli e le operazioni che ho fatto:

-dal menù aiuto-system info :ho controllato che tutte le voci siano scrivibili

-da filezilla ho impostato a 777 i permessi per le cartelle components e administrator/components (le altre cartelle sono tutte a 0755 ed i file a 0644)

- ho controllato la path dei file temporanei creando un file text.php caricato sul server che mi riporta il percorso esatto presente in configuration.php

Sono certa che il problema stà nel server perchè di là funziona tutto alla perfezione ed è da ieri che apro ticket per controllare permessi e l' abilitazione delle zlib(all' inizio pensavo fosse questo il problema) ma sinceramente ,adesso non sò neanche più che cosa andargli a chiedere.La versione PHP che hanno sl server , ho controllato anche quella è la 5.2.16.

Se qualcuno riesce a darmi una mano gliene sarei molto grata.
« Ultima modifica: 13 Gen 2011, 09:10:23 da akeba »

Offline maicolstaip

  • Global Moderator
  • Instancabile
  • ********
  • Post: 17623
  • Sesso: Maschio
    • Mostra profilo
    • https://www.hoteledelweiss.net/
Re:Problema trasferimento
« Risposta #1 il: 13 Gen 2011, 14:13:54 »
Ciao akeba,
la situazione è molto fluida.
Per prima cosa ti chiedo di verificare se il server è veramente linux, a volte ci vogliono giorni per avere il cambio da win a linux.
Non si risponde a PM tecnici. Postate sul forum. Grazie.

Offline akeba

  • Nuovo arrivato
  • *
  • Post: 44
  • Sesso: Femmina
    • Mostra profilo
Re:Problema trasferimento
« Risposta #2 il: 13 Gen 2011, 14:20:48 »
Ciao Maicol,
si, è linux.Ne ho la conferma anche dal file php.info che ho caricato sul server.In effetti dalla richiesta al passaggio effettivo c'è voluto un pò di tempo .

Offline maicolstaip

  • Global Moderator
  • Instancabile
  • ********
  • Post: 17623
  • Sesso: Maschio
    • Mostra profilo
    • https://www.hoteledelweiss.net/
Re:Problema trasferimento
« Risposta #3 il: 13 Gen 2011, 14:33:00 »
Ciao akeba,
verifica che la proprietà dei files sia univoca.
Disabilita anche l'ftp layer dal backend di joomla se ce l'hai attivo.

Se il problema è nella proprietà dei files, alcuni hosting hanno un tool per mettere tutto a posto.
Altrimenti ti toccherà aprire un altro ticket chiedendo che lo facciano loro.
Ciao!

http://docs.joomla.org/Why_can%27t_you_install_any_extensions%3F
Non si risponde a PM tecnici. Postate sul forum. Grazie.

Offline akeba

  • Nuovo arrivato
  • *
  • Post: 44
  • Sesso: Femmina
    • Mostra profilo
Re:Problema trasferimento
« Risposta #4 il: 13 Gen 2011, 14:40:41 »
ciao Maicol,
nella pagina che mi hai linkato ci ho trascorso gran parte della giornata di ieri :)

l'ftp ce l' ho disabilitato...per il resto come faccio a verificare che la propprità dei file sia univoca?

Grazie mille per il tuo aiuto.

 

Host

Torna su