Autore Topic: Problemi installazione template  (Letto 4255 volte)

Offline brutal78

  • Nuovo arrivato
  • *
  • Post: 47
    • Mostra profilo
Problemi installazione template
« il: 25 Mar 2011, 14:02:55 »
buongiorno a tutti.
ultimamente ho un problema con la gestione dei siti: quando installo un modulo o un template mi da il seguente problema di permessi:

JFile: :write(/usr/local/psa/home/vhosts/********/httpdocs/tmp/install_4d8c8cb78c116/css/admin/index.html): fopen(/usr/local/psa/home/vhosts/********/httpdocs/tmp/install_4d8c8cb78c116/css/admin/index.html) [function.fopen]: failed to open stream: Permission denied
Unable to write entry


Ora, io sento spesso il gestore di hosting e mi assicura di aver sbloccato tutti i permessi ( un server condiviso) ma io continuo ad avere problemi anche impostando (solo momentaenamente) tutti i permessi su 777

Mi sapete indicare il procedimento corretto per installare i template usando FILEZILLA? infatti cosi dovrei riuscire ad ovviare il problema ma quando vado su joomla non mi trova i moduli poi

grazie

Offline 56francesco

  • Fuori controllo
  • *
  • Post: 29585
  • Sesso: Maschio
    • Mostra profilo
Re:Problemi installazione template
« Risposta #1 il: 25 Mar 2011, 14:21:26 »
Citazione
fopen

se non erro fopen una istruzione interna al server, tale istruzione disabilitata per motivi di sicurezza in quasi tutte le lamp, evidentemente un template particolare oppure c' dentro qualche porcheria, sapresti dirci di che template si tratta e dove lo hai preso?
nel caso sia commerciale evita di citarlo e rivolgiti direttamente li dove lo hai comprato, 
potrei anche  sbagliarmi su fopen ma penso di no, riesci ad installare altri template ordinari? se si allora fopen che gli da fastidio.

(uso XP perch win98 non si installa) 
PS: non sono un dipendente dello sbonzor quindi necessario un "per favore" alla richiesta e un "grazie" alla risposta, sempre! PPS: non scrivo mai per primo in MP, in caso contrario chiedimi una conferma, Grazie.

Offline brutal78

  • Nuovo arrivato
  • *
  • Post: 47
    • Mostra profilo
Re:Problemi installazione template
« Risposta #2 il: 25 Mar 2011, 14:26:39 »
se non erro fopen una istruzione interna al server, tale istruzione disabilitata per motivi di sicurezza in quasi tutte le lamp, evidentemente un template particolare oppure c' dentro qualche porcheria, sapresti dirci di che template si tratta e dove lo hai preso?

No gratuito: infatti essendo sostenitore dell'opensource uso solo cose opensource. Il template http://www.joomla.it/anteprima-template-16/4828-yougrids-16-template.html preso direttamente da qui! Ovvimante un template 1.6 per joomla 1.6.

lo fa con tutti i templates, e tutti i moduli

Ma proprio non ci sono modi per installare i templates attraverso l'ftp?
« Ultima modifica: 25 Mar 2011, 14:29:39 da brutal78 »

Offline 56francesco

  • Fuori controllo
  • *
  • Post: 29585
  • Sesso: Maschio
    • Mostra profilo
Re:Problemi installazione template
« Risposta #3 il: 25 Mar 2011, 15:08:17 »
non va bene via ftp con joomla 1.6 e gi non andava bene neanche con joomla 1.5

ho provato a scaricare il template, in locale si installato normalmente e anche nel server remoto.
comunque uno di quei template messi in giro da chi vuole reinventare l'acqua calda, pieno di link e di opzioni varie, inoltre pare preveda anche due plugin aggiuntivi,  troppo per i miei gusti, evidentemente tra le altre cose prevede anche l'uso di fopen
http://php.net/manual/en/function.fopen.php
che rimane una istruzione interna ai serve, evidentemente nel tuo server  disabilitata e difficilmente te la abilitano,  prova ad entrare nel codice del template e a ripulirlo da quella opzione,  ammesso che senza riesca ad installarsi,  io da parte mia lo cestino immediatamente per le stesse ragioni per cui a te non si installa.

(uso XP perch win98 non si installa) 
PS: non sono un dipendente dello sbonzor quindi necessario un "per favore" alla richiesta e un "grazie" alla risposta, sempre! PPS: non scrivo mai per primo in MP, in caso contrario chiedimi una conferma, Grazie.

Offline 56francesco

  • Fuori controllo
  • *
  • Post: 29585
  • Sesso: Maschio
    • Mostra profilo
Re:Problemi installazione template
« Risposta #4 il: 25 Mar 2011, 15:12:27 »
ed eccolo l, come vedi in remoto mi permette di installare ma appena dopo  cliccando su una loro opzione mi restituisce questo avviso,    una questione di usare istruzioni che mettono in pericolo l'intero server,  il mio consiglio :  buttalo via.
(uso XP perch win98 non si installa) 
PS: non sono un dipendente dello sbonzor quindi necessario un "per favore" alla richiesta e un "grazie" alla risposta, sempre! PPS: non scrivo mai per primo in MP, in caso contrario chiedimi una conferma, Grazie.

Offline brutal78

  • Nuovo arrivato
  • *
  • Post: 47
    • Mostra profilo
Re:Problemi installazione template
« Risposta #5 il: 25 Mar 2011, 15:51:55 »
ed eccolo l, come vedi in remoto mi permette di installare ma appena dopo  cliccando su una loro opzione mi restituisce questo avviso,    una questione di usare istruzioni che mettono in pericolo l'intero server,  il mio consiglio :  buttalo via.

Il consiglio poso anche seguirlo senza molti problemi, ma il fatto che allora tuttii template che provo ad installare ce l'hanno, e sono tutti presenti nel calderone principale dei template. Ovviamente spero (e sono sicuro) che non sia cos. Perch li ho provati tutti e tutti mi danno lo stesso errore!

vamba

  • Visitatore
Re:Problemi installazione template
« Risposta #6 il: 25 Mar 2011, 15:58:09 »
Citazione
non va bene via ftp con joomla 1.6 e gi non andava bene neanche con joomla 1.5
se la risposta qua sopra attribibile alla domanda
Citazione
Ma proprio non ci sono modi per installare i templates attraverso l'ftp?
Credo tutto che necessiti di una piccola integrazione in quanto giustamente non possibile effettuare il carimento del template semplicemente via FTP nella 1.6 mentre era invece possibile effettuarlo nella 1.5

Offline brutal78

  • Nuovo arrivato
  • *
  • Post: 47
    • Mostra profilo
Re:Problemi installazione template
« Risposta #7 il: 25 Mar 2011, 16:13:01 »
Credo tutto che necessiti di una piccola integrazione in quanto giustamente non possibile effettuare il carimento del template semplicemente via FTP nella 1.6 mentre era invece possibile effettuarlo nella 1.5

Si anche perch ho sentito che diversi utenti hanno questo problema che ritengo VITALE per un sistema come Joomla. Non credo, con tutto il rispetto per il gentilissimo Francesco, che sia un problema di template ma di permessi legati agli hosting condivisi.

Quindi sarebbe il caso di approfondire l'argomento, affinche tutta la community ne possa beneficiare, e si possa trovare insieme il nodo gordiano della situazione!

grazie a tutti

vamba

  • Visitatore
Re:Problemi installazione template
« Risposta #8 il: 25 Mar 2011, 17:10:25 »
Citazione
Non credo, con tutto il rispetto per il gentilissimo Francesco, che sia un problema di template ma di permessi legati agli hosting condivisi.
Concordo con Francesco sull'utilizzo o meno di fopen e credo che sia molto meglio non installare estensioni che ne facciano uso.

 

Host

Torna su