Autore Topic: sito multilingua: problema con lingua Inglese (Stati Uniti)  (Letto 2070 volte)

Offline giulia_bike

  • Nuovo arrivato
  • *
  • Post: 25
    • Mostra profilo
Ciao,
il mio sito ha 7 lingue (uso il modulo JoomFish) e a seconda dell'impostazione lingua del browser verrà visualizzato il contenuto in una lignua piuttosto che in un altra.

Tutto funziona bene tranne per la lingua Inglese (Stati Uniti) in quanto anche se il browser ha Inglese(stati Uniti) come impostazione il sito visualizza sempre il contenuto della lingua inglese (gb).

Ho installato anche un modulo (geoIp) che credevo che a seconda della provenienza dell'utente mi visualizzasse la lingua corretta e invece sembra ignorarlo.

Quello che ho notato è che il cookie jfcookie (lang) viene sempre impostato a "en" anche se il linguaggio è English(United States) quindi dovrebbe essere "us".

La lingua EN-US l'ho solo installata come frontend perchè non l'ho trovata come core si Joomla (non so se questo influisca).

Avete delle idee?
Purtroppo in tutti gli altri forum (Joomla.org, Joomfish...) non mi hanno risposto o la risposta non ha risolto nulla.

Mi basta anche conoscere delle alternative tipo redirect con altri moduli o tramite file htaccess

Offline 56francesco

  • Fuori controllo
  • *
  • Post: 29585
  • Sesso: Maschio
    • Mostra profilo
Re:sito multilingua: problema con lingua Inglese (Stati Uniti)
« Risposta #1 il: 08 Apr 2011, 14:25:45 »
Citazione
La lingua EN-US
sbagliato,  ecco perchè non funziona, devi scriverla correttamente, cioè

en-US

 ;)
(uso XP perchè win98 non si installa) 
PS: non sono un dipendente dello sbonzor quindi è necessario un "per favore" alla richiesta e un "grazie" alla risposta, sempre! PPS: non scrivo mai per primo in MP, in caso contrario chiedimi una conferma, Grazie.

Offline giulia_bike

  • Nuovo arrivato
  • *
  • Post: 25
    • Mostra profilo
Re:sito multilingua: problema con lingua Inglese (Stati Uniti)
« Risposta #2 il: 11 Apr 2011, 14:01:19 »
scusa ma dove devo scrivere en-US?
in Joomfish - Content Languages c'è già en-US nel compo Joomla file.

Solo nel plugin Jrooter c'è us in corrispondenza di Inglese (Stati Uniti) ,  ho provato a mettere en-US ma non cambia nulla

Offline 56francesco

  • Fuori controllo
  • *
  • Post: 29585
  • Sesso: Maschio
    • Mostra profilo
Re:sito multilingua: problema con lingua Inglese (Stati Uniti)
« Risposta #3 il: 11 Apr 2011, 14:13:38 »

Citazione
Solo nel plugin Jrooter

sarebbe?

sposto nella sezione joom!fish
(uso XP perchè win98 non si installa) 
PS: non sono un dipendente dello sbonzor quindi è necessario un "per favore" alla richiesta e un "grazie" alla risposta, sempre! PPS: non scrivo mai per primo in MP, in caso contrario chiedimi una conferma, Grazie.

Offline giulia_bike

  • Nuovo arrivato
  • *
  • Post: 25
    • Mostra profilo
Re:sito multilingua: problema con lingua Inglese (Stati Uniti)
« Risposta #4 il: 11 Apr 2011, 14:38:54 »
su www.pcvuesolutions.com in alto a sinistra ci sono tutte le lingue disponibili. In automatico il browser visualizza la lingua corretta in base all'impostazione della lingua. Quindi se il tuo browser ha come impostazione lingua "Italiano" vedrai italiano.

Questo non funziona per Inglese (Stati Uniti), in quanto mi fa sempre vedere la lingua Inglese (en-gb)


 

Host

Torna su