Autore Topic: [RISOLTO] Chronoform - Validazione Campi in locale funziona ma non sul server  (Letto 1812 volte)

Offline carlo789.2009

  • Nuovo arrivato
  • *
  • Post: 16
    • Mostra profilo
Salve,
vorrei sottoporvi un quesito strano.
Ho creato una form con i dati tutti obbligatori.
In locale visualizza il messaggio di errore di dato obbligatorio ma sul server non funziona.
Qualcuno ha qualche suggerrimento da consigliarmi ?
Ringrazio in anticipo
« Ultima modifica: 05 Feb 2012, 00:57:29 da carlo789.2009 »

Offline carlo789.2009

  • Nuovo arrivato
  • *
  • Post: 16
    • Mostra profilo
Scusatemi alcune info:

Utilizzo Joomla 1.5.25
Chronoform V4 RC3.0

Offline carlo789.2009

  • Nuovo arrivato
  • *
  • Post: 16
    • Mostra profilo
A nessuno è capitata una tale situazione ? Non so quali tentativi fare. L'unico dubbio è legato al fatto che sul Server esiste una versione PHP diversa ma non ci credo molto che sia questo il problema. Per verificare che versione di PHP esiste devo chiedere all'amministratore del server ?
Farò un ultimo tentativo di installare il sito sul server

Offline carlo789.2009

  • Nuovo arrivato
  • *
  • Post: 16
    • Mostra profilo
Salve,
per il problema evidenziato, ho effettuato diverse prove:
- Ho inserito nuovi campi per valorizzare la lista di un comune alla selezione di una provincia utilizzando l'evento onchange
- Ho installato Mootools Upgrade per avere le versioni 1.2 e 1.12
- Ho riinstallato tutto il sito

Ebbene facendo alcune prove ho riscontrato le seguenti anomalie:
- Qualsiasi versione di Mootolls impostato, la validazione dei campi non si attiva alla selezione del bottone "Invia Dati" sul server mentre in locale funziona solo per la versione 1.2 (infatti impostando la versione 1.12 il sito in locale si comporta come sul server)
- Inoltre sul server impostando la versione 1.2 non funziona (o non si attiva) l'evento onchange alla selezione della provincia mentre funziona con la versione 1.12; in locale funziona indipendentemente dalla versione.

Quindi il problema sembra legato alla versione di Mootools sia per la validazione campi sia per attivare gli eventi JS sul server. Poichè Chronoforms ha bisogno della versione 1.2 vi è qualcosa sul server che non ne permette il funzionamento di tale versione

Qualcuno ha suggerimenti da darmi di cosa far controllare sul server come impostazioni ?

Mi sa che dovrò passare alla versione precedente.

Ringrazio in anticipo




Offline carlo789.2009

  • Nuovo arrivato
  • *
  • Post: 16
    • Mostra profilo
Ho chiesto al produttore del componente e mi ha riferito che esistevano due versioni di Mootools diverse che giravano sulla stessa pagina.
Ho aggiornato il componente che utilizzava la versione vecchia (1.12) di Mootools ed ora la validazione funziona.
Il dubbio tuttavia rimane:
Coma mai in locale la validazione funziona.

 

Host

Torna su