Autore Topic: Problema installazione componente nuovo  (Letto 886 volte)

Offline merlyno79

  • Nuovo arrivato
  • *
  • Post: 21
  • Sesso: Maschio
    • Mostra profilo
Problema installazione componente nuovo
« il: 11 Gen 2007, 09:55:11 »
Ciao, a tutti.
E' la prima volta che scrivo in questo forum.
Io ho sviluppato un nuovo componente che funziona da backend.
Il mio problema questo: ho seguito il procedimento per creare il file di installazione xml e, se provo ad installare il mio componente, un messaggio mi dice che non installato correttamente e non compare tra i componenti installati. Per viene creata correttamente la cartella in administrator/components, vengono correttamente effettuate le modifiche al database e posso richiamare il mio componente perfettamente funzionante solo digidando l'URL.
Il componente si compone di 4 file:
admin.gestione_storico_documenti.html.p hp
admin.gestione_storico_documenti.php
toolbar.gestione_storico_documenti.html .php
toolbar.gestione_storico_documenti.php
e il file d'installazione gestione_storico_documenti.xml contiene quanto segue:

<?xml version="1.0" ?>
<mosinstall type="component">
<name>gestione_storico_documenti</name>
<creationDate>19/01/2007</creationDate>
<author>mio_nome</author>
<copyright>(c) 2007</copyright>
<authorEmail>io@mail.it</authorEmail>
<version>1.0</version>
<description>
Componente
</description>
<install>
<queries>
<query>
ALTER TABLE #__content
ADD state_changed DATETIME;
</query>
</queries>
</install>
<installfile>
install.gestione_storico_documenti.php
</installfile>
<uninstallfile>
uninstall.gestione_storico_documenti.ph p
</uninstallfile>
<uninstall>
<queries>
<query>ALTER TABLE #__content DROP state_changed;</query>
</queries>
</uninstall>
<administration>
<menu>gestione_storico_documenti</menu>
<files>
<file>admin.gestione_storico_documenti.php</file>
<file>admin.gestione_storico_documenti.html.p hp</file>
<file>toolbar.gestione_storico_documenti.php</file>
<file>toolbar.gestione_storico_documenti.html .php</file>
</files>
</administration>
</mosinstall>

naturalmente i file di installazione e di disinstallazione contengono rispettivamente:
<?php
function com_install() {
return 'Installazione completata con successo! Visita il mio sito per ulteriori informazioni ed aggiornamenti.';
}
?>

e

<?php
function com_uninstall() {
return 'Il componente stato disinstallato correttamente';
}
?>

Dove sbaglio?

Offline napo

  • Instancabile
  • ******
  • Post: 6532
  • Sesso: Maschio
  • NO MP TECNICI, verranno ignorati
    • Mostra profilo
Re: Problema installazione componente nuovo
« Risposta #1 il: 11 Gen 2007, 10:00:01 »
Codice: [Seleziona]
<files>
<file>admin.gestione_storico_documenti.php</file>
<file>admin.gestione_storico_documenti.html.php</file>
<file>toolbar.gestione_storico_documenti.php</file>
<file>toolbar.gestione_storico_documenti.html.php</file>
</files>

Il tag <filename> non <file>.
Che guida hai seguito?


AllOne.it Consulting: http://www.allone.it Gens Joomla, il : http://www.gensjoomla.org  [url=http://www.allone.it/jooml

Offline merlyno79

  • Nuovo arrivato
  • *
  • Post: 21
  • Sesso: Maschio
    • Mostra profilo
Re: Problema installazione componente nuovo
« Risposta #2 il: 11 Gen 2007, 10:10:56 »
La guida e:
Guida alla creazione di componenti per Mambo e
Joomla tradotta da Gotev Alexandro. No ricordo dove l'ho trovata... Comunque vedo di apportare le modifiche nell'xml...

Offline napo

  • Instancabile
  • ******
  • Post: 6532
  • Sesso: Maschio
  • NO MP TECNICI, verranno ignorati
    • Mostra profilo
Re: Problema installazione componente nuovo
« Risposta #3 il: 11 Gen 2007, 10:16:32 »
Leggiti il manuale dello sviluppatore. 8)


AllOne.it Consulting: http://www.allone.it Gens Joomla, il : http://www.gensjoomla.org  [url=http://www.allone.it/jooml

 

Host

Torna su