Autore Topic: Joomla 1.7 e SEO: Come ottimizzare il nostro nuovo sito per i motori di ricerca  (Letto 22685 volte)

Offline acnew

  • Nuovo arrivato
  • *
  • Post: 21
    • Mostra profilo
In xmap ti basta aggiungere il menu e vedrai le voci pubblicate nella mappa.

 
GRAZIE DAVIDE HO RISOLTO, CI RISENTIAMO PER IL RESTO

Offline m.davide82

  • Global Moderator
  • Abituale
  • ********
  • Post: 1546
  • Sesso: Maschio
    • Mostra profilo

 
GRAZIE DAVIDE HO RISOLTO, CI RISENTIAMO PER IL RESTO

Ottimo! Mi fa piacere!

Offline acnew

  • Nuovo arrivato
  • *
  • Post: 21
    • Mostra profilo
Ciao davide, pensavo di aver risolto. Purtroppo nel sito di prova è andato bene.
Quando ho caricato l'estensione nel sito ufficiale mi ha dato questo errore.

Fatal error
:  Call to undefined method JLanguage::getBackwardLang() in /membri/accurti/joomla/administrator/components/com_xmap/install.xmap.php on line 17


Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 31459
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
Come volevasi dimostrare in locale è inutile perdere tempo ad ottimizzare per il seo tanto il server remoto sarà diverso e bisogna ricominciare daccapo.

Offline acnew

  • Nuovo arrivato
  • *
  • Post: 21
    • Mostra profilo
Ciao davide da quando ho inserito l'estensione xmap  non riesco ad inserire più niente come nuove estensione. stasera ho provato ad inserire :
 
attachments-Italian-it-IT-3.0.1.zip -
purtroppo mi da questo errore.  :'( :'(    come posso fare a risolvere cosa devo sistemare
 
Fatal error: Call to undefined method JLanguage::getBackwardLang() in /membri/accurti/joomla/administrator/components/com_xmap/install.xmap.php on line 17
Grazie e spero di risolvere altrimenti non posso aggiungere altre estensioni.
 
 
 
 
 
Ciao davide, pensavo di aver risolto. Purtroppo nel sito di prova è andato bene.
Quando ho caricato l'estensione nel sito ufficiale mi ha dato questo errore.

Fatal error
:  Call to undefined method JLanguage::getBackwardLang() in /membri/accurti/joomla/administrator/components/com_xmap/install.xmap.php on line 17



Offline steikkia

  • Esploratore
  • **
  • Post: 159
  • Sesso: Maschio
  • Vivi e lascia vivere
    • Mostra profilo
ottima guida!
Siti web Brescia - Siti web Bergamo

Offline Fabrizio Fiorita

  • Abituale
  • ****
  • Post: 1315
  • Sesso: Maschio
    • Mostra profilo
In merito al consiglio di utilizzare ilo Centro webmasters di Google, per la verifica della proprietà ho adottato la collocazione del file html nella root, unica soluzione per me praticabile, visto che non ho accesso agli heads della homepage.
Risultato: se guardo io la pagina c'è solo il codice Google.
Se invece la guarda Google, ci trova la pubblicità del mio host prima del codice Google e non me l'accetta.
Qualche suggerimento?

Fabrizio
Per programmare servono i tasti e la testa. Peccato che molti usino solo i primi...
Vai a vedere il mio sito: http://www.fabriziofiorita.joomlafree.it/index.php?option=com_content&view=featured&Itemid=101

Offline eurosoftware

  • Nuovo arrivato
  • *
  • Post: 1
    • Mostra profilo
Joomla 1.7 e SEO: Help!
« Risposta #27 il: 12 Ott 2011, 17:07:51 »
Ciao a tutti,
sono nuovo nel mondo Joomla e ho un problema con i permalink di Joomla 1.7.
Ho creato una categoria per le news e nel menu l'ho messa come parent in questo caso di case history
e il  permalink mi viene cosi:
www.nomesito.it/index.php/casehistory/news.html
e la singola news cosi :www.nomesito.it/index.php/casehistory/new8-news/19-news-2.html

Il mio problema maggiore è che quando  clicco nelle news nella sidebar non mi fa vedere l'articolo  ma il contenuto della home page (uguale, anche con lo slideshow che è attivo solo in home) e la side bar si posiziona in basso invece di rimanere uguale come  nelle altre pagine.

E' possibile fare in modo che quando clicco sul menu o nella sidebar il permalink dell'articolo sia sempre uguale?

In questo modo magari evito questi problemi e non vengo penalizzato dai motori di ricerca per contenuto duplicato!

Grazie in anticipo

Offline laffal84

  • Nuovo arrivato
  • *
  • Post: 15
  • Sesso: Femmina
    • Mostra profilo


Buongiorno,


quando voglio istallare xmap, mi da il seguente errore:
Plugin Installa: il plugin Xmap - Content Plugin esiste già
  • Pacchetto Installa: si è verificato un errore nell'installazione di un'estensione: plg_com_content.zip



  • C'è da dire che io l'ho istallato in precedenza quando avevo una sottocartella, poi ho fatto i passi per mettere il tutto nella root principale...
    Mi immagino che avrò fatto un casino, comunque quando voglio disistallare il plug-in che sta già istallato (per poterlo istallare dal inizio e così utilizzarlo, mi da il seguente errore:


    [/size]Disinstallazione plugin: file manifest non valido o non trovato.
  • Disinstallazione plugin: file manifest non valido o non trovato.
  • Disinstallazione plugin: file manifest non valido o non trovato.
  • Fallito caricamento file XML
  • /web/htdocs/www.progettiled.com/home/administrator/manifests/packages/pkg_xmap.xml
  • XML: failed to load external entity "/web/htdocs/www.progettiled.com/home/administrator/manifests/packages/pkg_xmap.xml"
  • Disinstallazione pacchetto: file manifest mancante
  • Disinstallazione plugin: file manifest non valido o non trovato.

  • Aiutoooooooooo, non sono una esperta... :'( :'( :'( :'(

Offline m.davide82

  • Global Moderator
  • Abituale
  • ********
  • Post: 1546
  • Sesso: Maschio
    • Mostra profilo
Niente di che, avevi semplicemente il plugin già installato, dovrebbe funzionarti.

Offline joom_fede75

  • Nuovo arrivato
  • *
  • Post: 6
    • Mostra profilo
Ciao Alexred,

grazie per la tua pronta risposta.

Si, sono su server linux e si, ho rinominato il file htaccess.

Paradossalmente pur non selezionando SI su Riscrivi URL SEF il sito web ha cambiato il percorso delle pagine:
http://www.unviaggioalgiorno.it/index.php/il-nostro-qprogettoq.html

Cosa può essere?

Grazie ancora per la risposta.
Salve,
io ho lo stesso problema.. joomla 1.7.1 se abilito la riscrittura dei link sef vedo solo la prima pagina. Forse bisogna aggiungere qualche parametro altrove? Grazie

Offline m.davide82

  • Global Moderator
  • Abituale
  • ********
  • Post: 1546
  • Sesso: Maschio
    • Mostra profilo
Il tuo hosting è configurato bene? Mod_rewrite attivo? decommentato/commentato la riga?

Offline joom_fede75

  • Nuovo arrivato
  • *
  • Post: 6
    • Mostra profilo
Ehh non lo so... il mio hosting xxx non mi permette di guardare nel httpd.conf... quindi non lo so...
Al limite posso chiedere che me lo abilitino/disabilitino tramite l'assistenza...
Che dici?
F
 
Edit: Rimosso riferimento commerciale.
« Ultima modifica: 24 Ott 2011, 09:44:40 da tomtomeight »

Offline Ricsca

  • Ulcera
  • Appassionato
  • *
  • Post: 519
  • Sesso: Maschio
    • Mostra profilo
Qualcuno mi saprebbe dire che differenza c'è tra

Alias Unicode         Si o No ?

Grazie 1000

Offline dangerin

  • Appassionato
  • ***
  • Post: 224
  • Sesso: Maschio
    • Mostra profilo
Ciao Alexred,

grazie per la tua pronta risposta.

Si, sono su server linux e si, ho rinominato il file htaccess.

Paradossalmente pur non selezionando SI su Riscrivi URL SEF il sito web ha cambiato il percorso delle pagine:
http://www.unviaggioalgiorno.it/index.php/il-nostro-qprogettoq.html

Cosa può essere?

Grazie ancora per la risposta.

buongiorno a tutti,
ho il medesimo problema anche io e tutte le verifiche suggerite le ho eseguite ed è tutto corretto.
mantenendo l'opzione riscrivi url sef disabilitata tutto funziona ed il mio sito mi fa vedere gli articoli ed i link così : www.nomesito.est/index.php/nomearticolo.html
che differenza vi è rispetto all'abilitazione di quel parametro di cui sopra che mi blocca la navigazione ad eccezione della home page ?
Grazie mille

Offline dangerin

  • Appassionato
  • ***
  • Post: 224
  • Sesso: Maschio
    • Mostra profilo
" Dopo aver riscritto le nostre url in modo decente,etc etc etc etc "

Non è che per caso in questa frase dell'articolo si cela il mistero tale per cui ad ogni articolo pubblicato ed ogni voce di menu etc si debba andare a riscrivere il link che viene creato al momento della creazione indicando a manina il nome dell'articolo ogni volta ?
se così fosse sarebbe la soluzione ma decisamente lunga poichè credevo che appunto la comodità e l utilita di questo tip fosse che si riscrivessero in automatico.. attnedo lumi e grazie a tutti di nuovo

Offline dangerin

  • Appassionato
  • ***
  • Post: 224
  • Sesso: Maschio
    • Mostra profilo
nessuna notizia a riguardo di quetso "problema" ? mi piacerebbe capire qualcosa in più in merito

Offline loacker

  • Nuovo arrivato
  • *
  • Post: 13
    • Mostra profilo
Buona domenica a tutti.
Sto iniziando a procedere per indicizzare il sito che ho creato.
L'indirizzo attuale è
http://www.fioli.altervista.org/joomla/ .
Il prossimo posso è di collegare la index di joomla alla pagina principale ( non l'ho anchora fatto).
Ho 3 dubbi riguardo i file htaccess, robots e sitemap.

1° dubbio: va rispettato un ordine nella loro creazione o aggiornamento ?

 2° dubbio: conviene gestirle prima oppure dopo aver collegato la index di joomla come home page ?
3° dubbio: i file htaccess sitemap e robots devono risiedere nella root principale del sito o in quella principale di joomla ? In particolare esiste un htaccess nella root principale e un htaccess nella sotto cartella di joomla, quale tra le 3 devo modificare ?
Grazie a tutti.

Stefano

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 31459
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
Ciao
Che intendi per " collegare la index.php alla pagina principale " La pagina principale è la home ed il tuo sito ha già una home senza che devi collegare nulla, puoi tutt'alpiù cambiarla.

Offline loacker

  • Nuovo arrivato
  • *
  • Post: 13
    • Mostra profilo
Ciao Tomtom,
probabilmente sono stato poco chiaro.

Mi riferisco al fatto che attualmente il dominio punta alla propria root, mentre configurerò, ovviamente, che punti alla root di joomla.
Quindi per far si che visitando http://www.fioli.altervista.org/ si visualizzino direttamente i contenuti in http://www.fioli.altervista.org/joomla/ .
Ecco, i file di cui parlavo (htaccess, robots e sitemap) restano tutti sotto la cartella joomla giusto ? Oppure vanno messi nella root principale ?

Grazie.
 
Stefano

 

Host

Torna su