Autore Topic: simple image - lightbox e template bisticciano  (Letto 2284 volte)

Offline FantArte

  • Nuovo arrivato
  • *
  • Post: 15
  • Sesso: Maschio
    • Mostra profilo
simple image - lightbox e template bisticciano
« il: 31 Gen 2007, 11:10:26 »
Ispirato dai plugin inseriti da Vamba nella ext. stavo provando ad utilizzare Simple Image Gallery.

Installato il mambot e pubblicatolo, mi trovo a poter creare senza problemi una gallery (i thumb li genera); ma, sul mio template, non ottengo l'effetto lightbox (ho un popup standard)

Con i template preinstallati funziona (e nel troubleshooting del mambot dice che dovrebbe essere il template).

Per vedere se fosse un problema di css o di index.php ho provato
- mio index + css standard - Non funziona
- mio css + index standard - Funziona

Quindi il problema è l'index. In forum vari ho visto problemi simili dove il trucco era nell' head. Come prima

- mio body + head standard - Non funziona
- mio head + body standard - Funziona

Il problema è dunque nel mio body. Ho solo div nidificati, niente tables... non trovo nulla di strano o sconveniente.

Idee?

Update: Bingo!! interagiva con l'ajax rotator!! ora devo solo vedere come farli coesistere... aggiorno appena risolvo!

Offline FantArte

  • Nuovo arrivato
  • *
  • Post: 15
  • Sesso: Maschio
    • Mostra profilo
Re: simple image - lightbox e template bisticciano
« Risposta #1 il: 31 Gen 2007, 11:47:00 »
Ok! Coesistono!

Siccome non ho trovato indicazioni chiare su come risolvere questo problema, spero possa servire a qualcuno in condizioni simili.

Dopo un po' di spulciare, ho trovato in una release note su
http://www.joomlaworks.gr/
che con la versione 2.1 di ajax rotator si evitavano conflitti con altre cose tipo lightbox, ma c'era da muovere la chiamata jquery dentro al template. Ora, sarà stata anche una cosa ovvia per il team... ma a capire cosa dovevo fare c'ho messo un po':P

è bastato aggiungere nell'head
Codice: [Seleziona]
<script type="text/javascript" src="modules/mod_jw_ajaxhr/jquery.js"></script>e ora tutto funziona!

Update: quasi tutto... dove ci sono gallerie di thumbs, ajax rotator sta fermo su un'immagine. Non grave... magari riesco a metter a posto anche questo
« Ultima modifica: 31 Gen 2007, 11:51:11 da FantArte »

Offline FantArte

  • Nuovo arrivato
  • *
  • Post: 15
  • Sesso: Maschio
    • Mostra profilo
Re: simple image - lightbox e template bisticciano
« Risposta #2 il: 01 Feb 2007, 03:00:31 »
Citazione
Update: quasi tutto... dove ci sono gallerie di thumbs, ajax rotator sta fermo su un'immagine. Non grave... magari riesco a metter a posto anche questo
Si confermo ma a me accade solo sotto IE6 mentre su firefox va .... (non ho provato sotto IE7 perchè, forse colpevolmente , non essendo in buoni rapporti con i prodotti del Mago Billo  ;)  non mi va proprio di installarlo)
consolante che addiritura Il Vamba abbia avuto crucci simili:D

Ho fatto qualche prova:
IE6 - il rotator non ci prova neppure, anche senza compresenza con la simple image.

IE7 e FF il rotator.... ruota, ma non se compresente in una pagina che usa il mambot di simple image.

Gli unici punti di domanda vengon dal fatto che per FF son tranquillo, ma essendo da Ubuntu con IE sotto wine, non garantisco sul comportamento.

Già che c'ero... in Opera, (quanto è veloce!) idem con patate, rotator funge finché non si scontra con simple image. Se riesco a installare swift con wine, posterò anche per safari. (certo, fa prima un mac munito...)

Update... zoomgallery assieme al rotator mi perde la funzione zoom; se non trovo qualche via d'uscita mi sa che cambio slideshow...
« Ultima modifica: 01 Feb 2007, 11:42:43 da FantArte »

Offline ninausnino

  • Esploratore
  • **
  • Post: 79
    • Mostra profilo
Re: simple image - lightbox e template bisticciano
« Risposta #3 il: 18 Apr 2007, 11:59:28 »
grazie...
anch'io avevo lo stesso problema, ci ho perso un bel pò di tempo prima di trovare questo post!
penso che toglierò l'header rotator

 

Host

Torna su