Back to top

Autore Topic: Fix su lingua e installazione componenti  (Letto 3038 volte)

Offline stefbort

  • Nuovo arrivato
  • *
  • Post: 46
  • Sesso: Maschio
    • Mostra profilo
Fix su lingua e installazione componenti
« il: 05 Feb 2007, 10:11:54 »
Salve.
Nel personalizzare questa fantastica EXT sono incappato in un errore negli script caricando il componente docman.
Il problema risiede nell'index.php del template del pannello di amministrazione. La riga erronea è:

Codice: [Seleziona]
require( 'templates/minted_one-point-five/lang/it.php' );
In pratica conviene sostituire le prime 6 righe dell'index.php come segue per avere una correzzione completa:

Codice: [Seleziona]
$tstart = mosProfiler::getmicrotime();
// needed to seperate the ISO number from the language file constant _ISO
$iso = explode( '=', _ISO );
// xml prolog
echo '<?xml version="1.0" encoding="'. $iso[1] .'"?' .'>';

if ($mosConfig_lang=='') {
$mosConfig_lang = 'english';
}
require( $mosConfig_absolute_path . '/administrator/templates/minted_one-point-five/lang/' . $mosConfig_lang . '.php' );

In questo modo il template usa le funzioni di autoselezione del file di lingua. Per completare il fix è necessario rinominare i file di lingua del template così:

it.php --> italian.php
en.php --> english.php

Lo stesso discorso va fatto anche per il file login.php . Le righe da mettere sono le stesse riportate qui sopra.
Allego lo zip di patch contenente i files fixati.

[allegato eliminato da un amministratore]
« Ultima modifica: 05 Feb 2007, 22:30:03 da stefbort »

 



Web Design Bolzano Kreatif