Autore Topic: slide non aprono pagine nella stessa finestra  (Letto 2384 volte)

Offline LadyK

  • Appassionato
  • ***
  • Post: 475
    • Mostra profilo
slide non aprono pagine nella stessa finestra
« il: 11 Gen 2012, 20:20:35 »
ciao a tutti,
ho un problema con il sito

http://www.giffonifilmfestival.it/mygiffoni/home.html#

vorrei che l'utente quando clicca su una slide, si apra nella stessa finestra la pagina a cui punta la slide.

come posso fare?

grazie per l'aiuto

Offline conti1

  • Global Moderator
  • Instancabile
  • *****
  • Post: 9074
  • Sesso: Maschio
    • Mostra profilo
Re:slide non aprono pagine nella stessa finestra
« Risposta #1 il: 12 Gen 2012, 13:14:53 »
ciao
giusto che apri  il link  in nuoca finestra hai le impostazioni   nel richiamo link   che dice :

<a target="blank" rel="1" style="display: none; z-index: 1;">

io toglerei blank

target="blank"  questo comando fa aprire una nuova pagina al link cliccato


se possibile postare il link  x risolvere al meglio il problema grazie
evitare nomi commerciali grazie

Offline LadyK

  • Appassionato
  • ***
  • Post: 475
    • Mostra profilo
Re:slide non aprono pagine nella stessa finestra
« Risposta #2 il: 12 Gen 2012, 17:46:26 »
scusa in che file che non lo trovo ???? ???

Offline conti1

  • Global Moderator
  • Instancabile
  • *****
  • Post: 9074
  • Sesso: Maschio
    • Mostra profilo
Re:slide non aprono pagine nella stessa finestra
« Risposta #3 il: 12 Gen 2012, 18:05:49 »
ciao dovrebbe essere nel  index.php del template 
se possibile postare il link  x risolvere al meglio il problema grazie
evitare nomi commerciali grazie

Offline LadyK

  • Appassionato
  • ***
  • Post: 475
    • Mostra profilo
Re:slide non aprono pagine nella stessa finestra
« Risposta #4 il: 12 Gen 2012, 18:23:56 »
non l'ho trovato nell'index.php  :'(

Offline conti1

  • Global Moderator
  • Instancabile
  • *****
  • Post: 9074
  • Sesso: Maschio
    • Mostra profilo
Re:slide non aprono pagine nella stessa finestra
« Risposta #5 il: 12 Gen 2012, 18:32:24 »
ma scusa
il template originale "la demo "che oh guardato i nomi delle immagini sono diverse  dalle tue per cui se hai cambiato le immagini hai rinominato pure quel pezzo di file .
comunque e nel  index.php
questo il pezzo originale di php

Codice: [Seleziona]
<div id="slideshow-w">

                    <div id="slideshow">

                        <img src="templates/<?php echo $this->template ?>/images/slide1.jpg" alt="image1" />

                        <img src="templates/<?php echo $this->template ?>/images/slide2.jpg" alt="image2" />

                        <img src="templates/<?php echo $this->template ?>/images/slide3.jpg" alt="image3" />

                        <img src="templates/<?php echo $this->template ?>/images/slide4.jpg" alt="image1" />

                    </div>

                </div>

questa e la tua prima immagine che hai nel php

Codice: [Seleziona]
<div id="slideshow-w">
<div id="slideshow" class="slideshowlite" style="width: 850px; height: 310px;">
<a target="blank" rel="1" style="display: block; z-index: 1;"><img alt="image2" src="/mygiffoni/templates/boowne/images/mygiffoni.jpg">[/url]
« Ultima modifica: 12 Gen 2012, 18:35:46 da conti1 »
se possibile postare il link  x risolvere al meglio il problema grazie
evitare nomi commerciali grazie

Offline LadyK

  • Appassionato
  • ***
  • Post: 475
    • Mostra profilo
Re:slide non aprono pagine nella stessa finestra
« Risposta #6 il: 16 Gen 2012, 11:00:33 »
l'index l'ho modificato in questo modo, non capisco perch mette "blank":
Codice: [Seleziona]
<img src="templates/<?php echo $this->template ?>/images/mygiffoni.jpg" alt="image2" />
         <a target="_self" href="<?php echo $this->baseurl?>/regolamento.html"><img src="templates/<?php echo $this->template ?>/images/regolamento.jpg" alt="image2" /></a>
          <a target="_self" href="<?php echo $this->baseurl?>/video-gallery.html"><img src="templates/<?php echo $this->template ?>/images/video.jpg" alt="image3" /></a>
      <a target="_self" href="<?php echo $this->baseurl?>/votazioni.html"><img src="templates/<?php echo $this->template ?>/images/votazioni.jpg" alt="image1" /></a>

grazie per la risposta

Offline Barb

  • Esploratore
  • **
  • Post: 69
    • Mostra profilo
Re:slide non aprono pagine nella stessa finestra
« Risposta #7 il: 20 Gen 2012, 23:19:50 »
Molto probabilmente il blank settato in un file nel template dello slider, di solito un file php in una cartella"template" o "theme" del modulo, oppure un javascript.

Anzi sbirciando il codice potrebbe essere alla riga 62 del file slideshow.js, che recita:

$(this).children("a").attr("target", "blank");

Al posto di blank metti parent e vedi se funge ^^

 

Host

Torna su