Autore Topic: [RISOLTO] Problemi con immagini negli articoli con Joomla 2.5  (Letto 5144 volte)

Offline alezando

  • Esploratore
  • **
  • Post: 158
    • Mostra profilo
Salve a tutti

Ho un problemino, sicuramente sono io che non ho ben capito come impostare immagini dentro gli articoli con Joomla 2.5.

Adesso vi spiego quello che mi succede, se metto immagine all'inizio dell'articolo va tutto bene, se invece l'immagine la devo mettere tipo immezzo all'articolo oppure in altre posizioni sempre dentro l'articolo non me la fa mettere. o meglio me la fa mettere ma me la riporta sempre all'inizio.

Qualcuno di voi sa spiegarmi il motivo?

Vi ringrazio anticipatamente a tutti coloro che potranno darmi una mano in questo mio dilemma..
« Ultima modifica: 06 Feb 2012, 11:12:18 da alezando »

Offline alezando

  • Esploratore
  • **
  • Post: 158
    • Mostra profilo
Re:Immagini negli articoli con Joomla 2.5
« Risposta #1 il: 04 Feb 2012, 14:58:03 »
Premetto che me lo fa sia con l'editor TinyMCE che con JCE e non dove appellarmi :(

Offline maicolstaip

  • Global Moderator
  • Instancabile
  • ********
  • Post: 17623
  • Sesso: Maschio
    • Mostra profilo
Re:Problemi con immagini negli articoli con Joomla 2.5
« Risposta #2 il: 04 Feb 2012, 15:36:14 »
Ciao alezando,
non ci sono differenze nell'immissione di un'immagine in un articolo tra joomla 1.5 e joomla 2.5

Mi pare veramente strano che l'editor ti resetti tutto.
Non si risponde a PM tecnici. Postate sul forum. Grazie.

Offline alezando

  • Esploratore
  • **
  • Post: 158
    • Mostra profilo
Re:Problemi con immagini negli articoli con Joomla 2.5
« Risposta #3 il: 04 Feb 2012, 16:48:36 »
Ciao

Stavo guardando il motivo anche se non sembra esserci granch da fare per adesso.

Per il momento uso il taglia ed incolla con explorer e con firefox uso il ctrl+c e crtl+v per riformattare l'immagine.

Spero che comunque si risolva presto questo bug, che oltretutto non so nemmeno se lo fa solo a me o anche ad altri...

Offline wit-c

  • Nuovo arrivato
  • *
  • Post: 48
    • Mostra profilo
Re:Problemi con immagini negli articoli con Joomla 2.5
« Risposta #4 il: 04 Feb 2012, 17:00:49 »
io ho un problema simile solo con gli elementi "media" che non appena si salva l'articolo l'elemento in flash sparisce!!

Offline wariner

  • Nuovo arrivato
  • *
  • Post: 15
    • Mostra profilo
Re:Problemi con immagini negli articoli con Joomla 2.5
« Risposta #5 il: 04 Feb 2012, 19:30:13 »
mi aggrego, stesso problema di alezandro, anche con la versione 2.5.1.

Offline Barbezuan

  • Appassionato
  • ***
  • Post: 218
    • Mostra profilo
Re:Problemi con immagini negli articoli con Joomla 2.5
« Risposta #6 il: 04 Feb 2012, 19:46:47 »
Che strano, ho appena fatto 2 prove in locale su 2.5.0 e 2.5.1 entrambi con JCE e non mi d nessun problema.
Per prova, potreste disabilitare i filtri testuali, giusto per escludere.


Barb

Offline wariner

  • Nuovo arrivato
  • *
  • Post: 15
    • Mostra profilo
Re:Problemi con immagini negli articoli con Joomla 2.5
« Risposta #7 il: 06 Feb 2012, 08:43:59 »
Che strano, ho appena fatto 2 prove in locale su 2.5.0 e 2.5.1 entrambi con JCE e non mi d nessun problema.
Per prova, potreste disabilitare i filtri testuali, giusto per escludere.


Barb

anche disabilitando i filtri a me non cambia niente.

Offline alezando

  • Esploratore
  • **
  • Post: 158
    • Mostra profilo
Re:Problemi con immagini negli articoli con Joomla 2.5
« Risposta #8 il: 06 Feb 2012, 08:48:01 »
Buongiorno.

Non saprei che dire, aspettiamo altri risconti perch se per adesso il problema lo da solo a me e a wariner puo essere che tutti e due abbiamo sbagliato qualcosa, anche se non me ne capacito, visto che gli editor sono ufficiali tutti e due e aggiornati all'ultima versione.

Non ci resta che attendere e per adesso adeguarci a riformattare le immagini.



Per il momento uso il taglia ed incolla con explorer e con firefox uso il ctrl+c e crtl+v per riformattare l'immagine.



Buona giornata
« Ultima modifica: 06 Feb 2012, 09:01:00 da alezando »

Offline alezando

  • Esploratore
  • **
  • Post: 158
    • Mostra profilo
Re:Problemi con immagini negli articoli con Joomla 2.5
« Risposta #9 il: 06 Feb 2012, 08:57:24 »
Spiego meglio come riformattare l'immagine.

Creato articolo vado a mettere l'immagine e come avrete capito me la inserisce obbligatoriamente all'inzio dell'articolo, allora che si fa?
Si evidenzia immagine cliccandoci sopra poi se si usa explorer si clicca con tasto destro e si clicca su taglia poi si sceglie la posizione dove si vuol mettere immagine, sempre destro sul maus e si clicca su copia. Se si usa firefox, stessa cosa si inserisce immagine poi si evidenzia una volta evidenziata immagine si preme contemporaneamente Ctrl+c si decide dove mettere immagine e si preme contemporaneamente Ctrl+v (con Windows) stessa procedura (con Mac) solo che invece di Ctrl+c e Ctrl+v si far cosi cmd+c e cmd+v (il cmd del Mac sarebbe il command).
« Ultima modifica: 06 Feb 2012, 08:59:26 da alezando »

Offline Barbezuan

  • Appassionato
  • ***
  • Post: 218
    • Mostra profilo
Re:Problemi con immagini negli articoli con Joomla 2.5
« Risposta #10 il: 06 Feb 2012, 09:15:15 »
Creato articolo vado a mettere l'immagine e come avrete capito me la inserisce obbligatoriamente all'inzio dell'articolo, allora che si fa?
Questo strano, se posizioni il cursore al centro del testo l'immagine viene inserita comunque all'inizio?
L'immagine, almeno a me lo f cos, deve venir inserita nella posizione del cursore.
Prova ad escludere l'editor e ad inserire l'html a mano.


Barb
« Ultima modifica: 06 Feb 2012, 09:17:27 da Barbezuan »

Offline alezando

  • Esploratore
  • **
  • Post: 158
    • Mostra profilo
Re:Problemi con immagini negli articoli con Joomla 2.5
« Risposta #11 il: 06 Feb 2012, 10:12:52 »
Ciao Barb

Bhe io posso fare anche la prova che dici te di escludere l'editor e inserire l'html a mano, ma rimane il fatto che non normale che mi faccia quel lavoro descritto sopra, poi non che tanto conveniente ogni volta andare in Configurazione globale disabilitare l'editor, se propio devo lavorare cosi allora preferisco fare come ho spiegato sopra con il copia e incolla, almeno pi veloce.

Offline Barbezuan

  • Appassionato
  • ***
  • Post: 218
    • Mostra profilo
Re:Problemi con immagini negli articoli con Joomla 2.5
« Risposta #12 il: 06 Feb 2012, 10:34:12 »
Allora, il problema isolato ad i vostri sistemi, premesso questo bisogna cercar di capire dove nasce il problema.
Il sito in locale?
Avete provato con altri browser e altri SO?
Lo f con tutti i tamplate?
Lo f anche con un'istallazione pulita (senza nessun componente aggiuntivo)?


Barb

Offline alezando

  • Esploratore
  • **
  • Post: 158
    • Mostra profilo
Re:Problemi con immagini negli articoli con Joomla 2.5
« Risposta #13 il: 06 Feb 2012, 11:11:51 »
Grazie anche a Barb sembra che siamo giunti ad una conclusione, ho provato con il browser Crome e il problema di inserire l'immagine nel posto dove vuoi non lo da.

Io intanto metto RISOLTO nel post, e aspetto una conferma per una prova fatta con altro browser anche da @wariner.

Per far capire ancora meglio il tutto a me i problemi li ha cominciati a dare quando ho aggiornato firefox alla versione 10.0

Buona giornata

Offline Barbezuan

  • Appassionato
  • ***
  • Post: 218
    • Mostra profilo
Re:[RISOLTO] Problemi con immagini negli articoli con Joomla 2.5
« Risposta #14 il: 06 Feb 2012, 12:24:52 »
Bene, sono contento che hai risolto.
Se non sbaglio, gli editor di joomla sono in JS quindi fortemente dipendenti dal browser e dall'ambiente locale.
Tempo f ebbi alcuni problemi con opera e JCE, che si sono risolti  con l'aggiornamento di opera e del SO (linux ubuntu).


Barb

Offline wariner

  • Nuovo arrivato
  • *
  • Post: 15
    • Mostra profilo
Re:[RISOLTO] Problemi con immagini negli articoli con Joomla 2.5
« Risposta #15 il: 06 Feb 2012, 14:00:55 »
disattivando l'editor come suggerito da Barb posso mettere l'immagine dove voglio senza problemi.

Ora prover cambiando browser e vi faccio sapere (anche io ho firefox 10.0).

EDIT:

Si confermo, un problema di Firefox 10.0. Anche io con Chrome non ho problemi.

Grazie per l'aiuto  ;)
« Ultima modifica: 06 Feb 2012, 14:11:42 da wariner »

 

Host

Torna su