Back to top

Autore Topic: Chronoform - Problema con campi Required  (Letto 1682 volte)

Offline sinfogab

  • Nuovo arrivato
  • *
  • Post: 12
    • Mostra profilo
Chronoform - Problema con campi Required
« il: 27 Gen 2012, 22:26:21 »
Ho creato un form, ma se provo a compilarlo tralasciando i campi obbligatori, o sbagliando il formato dei campi, me lo invia lo stesso. Mi indica l'errore, ma manda la mail lo stesso.

Esempio: c'è il campo "email" contrassegnato sia come "email" che come "required", ma sia lasciandolo in bianco, sia scrivendo un testo a caso senza chiocciola, invia lo stesso i dati.

Credo che il problema sia nell'elenco delle azioni, però non riesco a capire quale manca.

Per la cronaca, uso Joomla 1.7.3
Commercialista NET - Un sito per i commercialisti
http://commercialistanet.it/

Offline Sestante2012

  • Esploratore
  • **
  • Post: 109
  • Sesso: Maschio
    • Mostra profilo
Re:Chronoform - Problema con campi Required
« Risposta #1 il: 09 Mar 2012, 18:04:29 »
Salve a tutti
Ho lo stesso problema. Lasciando vuoti tutti i campi spuntati come "required" il form viene inviato ugualmente. L'unica cosa che ferma l'invio è il CAPTCHA: se è errato il form viene riproposto.
Qualche idea?
ringrazio anticipatamente
EDIT: dimenticavo, joomla 2.5 e chronoforms 4.0 RC3.11   
« Ultima modifica: 09 Mar 2012, 18:06:01 da SestanteSrl »
================================================
Solo il passato si può copiare; il futuro dobbiamo inventarcelo.(cit)

Offline sinfogab

  • Nuovo arrivato
  • *
  • Post: 12
    • Mostra profilo
[RISOLTO] Chronoform - Problema con campi Required
« Risposta #2 il: 09 Mar 2012, 22:46:39 »
in realtà ho risolto.
bisogna andare in Form wizard, nella scheda Eventi aggiungere in "On Submit" l'evento "Auto Server Side Validation". Nelle proprietà di quello, inserisci quali sono i campi richiesti, quali devono avere un certo formato, eccetera. Ti conviene, mentre fai il form, dare nomi sensati ai campi, oppure segnarteli.

Spero di essere stato d'aiuto.
« Ultima modifica: 12 Mar 2012, 10:05:33 da sinfogab »
Commercialista NET - Un sito per i commercialisti
http://commercialistanet.it/

Offline Sestante2012

  • Esploratore
  • **
  • Post: 109
  • Sesso: Maschio
    • Mostra profilo
Re:Chronoform - Problema con campi Required
« Risposta #3 il: 12 Mar 2012, 09:56:12 »
Grazie.
Il tuo post mi è stato davvero utilissimo. Con questo ho risolto anche io! ;)
Magari ora si può cambiare il titolo al Topic e metterci davanti un bel [RISOLTO]...
Ri-Grazie,
================================================
Solo il passato si può copiare; il futuro dobbiamo inventarcelo.(cit)

Offline Sestante2012

  • Esploratore
  • **
  • Post: 109
  • Sesso: Maschio
    • Mostra profilo
Re:Chronoform - Problema con campi Required
« Risposta #4 il: 12 Mar 2012, 17:46:50 »
Salve a tutti.
Rispondo a me stesso per dirmi che la prossima volta devo avere meno fretta. Pensavo di aver risolto e invece un banale errore di digitazione nel campo "required" dell' "auto server side validation" mi ha prima illuso e poi sconfitto.
Dopo millemila ricerche e test sono (a questo punto spero di essere) ad una svolta definitiva. Ho rintracciato un post vecchio di un anno nel forum ChronoEngine:
http://www.chronoengine.com/forums/viewtopic.php?f=26&t=21247
A quanto pare già lì si lamentavano del non-funzionamento dei controlli "required" e qualcuno, stufo, ha trovato la soluzione e poi l'ha postata.
Spero possa risultare utile a qualcun'altro, così come lo è stata per me.
Saluti,
Sestante2012
================================================
Solo il passato si può copiare; il futuro dobbiamo inventarcelo.(cit)

 



Web Design Bolzano Kreatif