Autore Topic: [RISOLTO] Voce di men¨ di una componente che non funziona  (Letto 1817 volte)

Offline akasha

  • Esploratore
  • **
  • Post: 106
    • Mostra profilo
Ciao a tutti!
Come scritto alcuni giorni fa sto lavorando alla realizzazione del mio primo componente per Joomla 2.5 (nonchÚ primo in assoluto), pensato per la compilazione di una serie di schede anagrafiche di partecipanti ad un concorso musicale.
Ora, nonostante qualche intoppo (non sono proprio riuscita ad inserire una combo box nel form), il lavoro procede abbastanza bene, grazie alla guida per sviluppatori e al supporto che come sempre trovo qui sul forum.
Purtroppo per˛ sono incappata in un problemino che proprio non so risolvere: quando provo a creare una voce di men¨ che punti ad una singola anagrafica inserita nel database, dopo aver scelto il tipo di voce di men¨, la pagina viene caricata senza template, senza barra degli strumenti (salva, salva e chiudi...) e senza la possibilitÓ di inserire il riferimento all'oggetto che vorrei pubblicare.
Sono sicura di aver seguito perfettamente la guida, e d'altra parta ho lo stesso problema anche con il componente di esempio della guida stessa.
Pensavo fosse un problema della mia installazione locale di Joomla, ma con altre voci di men¨ non riscontro alcun problema.
Ho anche provato a fare dei confronti con componenti sicuramente funzionanti, ma non so bene dove metter mano...
sono davvero disperata!!!
Qualcuno pu˛ aiutarmi?

Grazie mille come sempre!
« Ultima modifica: 27 Mar 2012, 11:24:28 da akasha »

mau_develop

  • Visitatore
Re:Voce di men¨ di una componente che non funziona
« Risposta #1 il: 26 Mar 2012, 21:30:47 »
dovresti fare un sito demo.. cosý Ŕ difficile capire.

dopo aver scelto il tipo di voce di men¨, la pagina viene caricata senza template, senza barra degli strumenti (salva, salva e chiudi...) e senza la possibilitÓ di inserire il riferimento all'oggetto che vorrei pubblicare.
--------------------------------------------------
mmhh non vorrei tu confondessi ci˛ che puoi fare nella parte amministrativa e che puoi invece fare nel front-end, dove alcuni metodi e classi non li hai.
E' possibile mostrare le toolbar nel frontend... ma non ricordo di aver visto il modo nelle guide base.

M.

Offline akasha

  • Esploratore
  • **
  • Post: 106
    • Mostra profilo
[RISOLTO] Voce di men¨ di una componente che non funziona
« Risposta #2 il: 27 Mar 2012, 11:24:03 »
Ciao, grazie per la risposta!
Nel frattempo ho scoperto l'errore: ho chiuso una parentesi due volte, e questo ovviamente creava problemi.
Comunque, per completezza, voglio spiegarmi meglio: parlavo proprio del backend, dato che non riuscivo ancora a visualizzare nulla sul frontend.
Quando creavo una nuova voce di men¨ per poter visualizzare le mie schede anagrafiche su frontend, infatti, riscontravo il problema giÓ descritto. CioŔ, dopo aver scelto il tipo di voce di men¨ "anagrafica singolo partecipante", la pagina si aggiornava mostrando il form per l'inserimento della voce di men¨ senza alcuna formattazione, senza la possibilitÓ di modificare alcunchÚ e senza la possibilitÓ di salvare.
Quindi potevo solo tornare indietro dal browser e rinunciare a creare la voce di men¨, per cui non potevo visualizzare nulla nel frontend.
Mi sono accorta dell'errore (banalissimo) provando ad installare il tutto su un'altra installazione di joomla, stavolta 1.7, sempre in locale: in questo caso ottenevo lo stesso errore, per˛ venivano segnalati sia il file che la linea in cui qualcosa non andava.
Non so se questo dipende dalla versione di Joomla o dalle impostazioni del php, propenderei per le seconde anche se mi sembra strano dato che dovrebbero essere identiche.
Comunque ora il men¨ funziona sia su Joomla 1.7 che su 2.5 e, dopo qualche altra piccola modifica, il mio lavoro sarÓ terminato con grande soddisfazione!
Per altre domande aprir˛ altre discussioni.
Grazie mille per la disponibilitÓ!

 

Host

Torna su