Autore Topic: Problema con Remository 3.54  (Letto 3712 volte)

Offline charlie1black81

  • Nuovo arrivato
  • *
  • Post: 4
    • Mostra profilo
Problema con Remository 3.54
« il: 10 Lug 2012, 08:40:34 »
Ciao a tutti.
 
Ho un piccolo problema con Remository 3.54
Ho installato tutto correttamente e mi funziona tutto
tranne l'icona del file.
Mi spiego medlio, quando carico il file assegno l'icona relativa presa da quelle di default
di Remository, lo salvo e vado poi nel frontend come utente abilitato al download del file
e mi fa vedere il nome del file e tutte le informazioni relative tranne l'icona.
 
A qualcuno è già capitato?
 
 
Grazie
 

Offline Ashtii

  • Nuovo arrivato
  • *
  • Post: 7
    • Mostra profilo
Re:Problema con Remository 3.54
« Risposta #1 il: 25 Set 2012, 21:43:24 »
Ciao,
capita la stessa cosa anche a me... e non sono riuscito a trovare una soluzione! Per caso te ci sei riuscito? Se si saresti così gentile da spiegarmelo?
Grazie mille!

Offline surya

  • Nuovo arrivato
  • *
  • Post: 17
    • Mostra profilo
Re:Problema con Remository 3.54
« Risposta #2 il: 10 Dic 2012, 15:43:50 »
Stesso identico problema....ho provato anche la procedura suggerita dal forum del sito ufficiale, consultabile a qui, ma niente...non è cambiato nulla...nel frattempo qualcuno ne è venuto a capo?....grazie...

Offline Ashtii

  • Nuovo arrivato
  • *
  • Post: 7
    • Mostra profilo
Re:Problema con Remository 3.54
« Risposta #3 il: 10 Dic 2012, 17:47:59 »
Ciao, io ho fatto alcuni test con firebug e se modifico il percorso in cui salvo l'icona funziona... quindi nel mio caso credo che il problema sia semplicemente che il percorso standar non raggiunge il file. Strano perchè io non l'ho spostato... cmq non ho risolto il problema perchè non so dove andare a modificare il percorso in modo che rimanga per sempre. Usando firebug lo modifico solo nel momento della visualizzazione e basta. Non so se mi sono spiegato bene... se qualcuno trova il file in cui c'è il percorso per modificarlo me lo faccia sapere...

Offline surya

  • Nuovo arrivato
  • *
  • Post: 17
    • Mostra profilo
Re:Problema con Remository 3.54
« Risposta #4 il: 10 Dic 2012, 18:07:11 »
Ciao Ashtii...no purtroppo temo di non aver capito...tu parli di files...io del fatto che le icone dei file caricati, sia da front end sia da back end, nel sito non vengono visualizzate...unitamente  all'icona con link per effettuare il download....e in effetti nel post del portale Remository, che ho linkato, si suggerisce una procedura che io ho effettuato, proprio per visualizzare entrambe le icone...purtroppo però...con me non ha funzionato...e l'ho pure segnalato nel post originale del forum Remository....

Offline Ashtii

  • Nuovo arrivato
  • *
  • Post: 7
    • Mostra profilo
Re:Problema con Remository 3.54
« Risposta #5 il: 10 Dic 2012, 18:31:54 »
Quando faccio riferimento hai file intendo quelli (tipo css o php) su cui sono impostati i percorsi per raggiungere i file icona... Se il percorso è sbagliato non trova le immagini e non te le presenta ne sul front ne sul back...

Offline surya

  • Nuovo arrivato
  • *
  • Post: 17
    • Mostra profilo
Re:Problema con Remository 3.54
« Risposta #6 il: 11 Dic 2012, 11:05:45 »
Perfetto...infatti la procedura suggerita nel post del forum ufficiale di Remository riguarda appunto la modifica da effettuare sul file css di Remository, che gestisce il recupero delle icone, e sul file php html sempre di Remository che gestisce il lato front end ....io ho modificato permanentemente i percorsi assoluti ma purtroppo non funziona...anzi al riguardo se mi spieghi meglio la procedura che tu hai adottato con firebug magari si riesce a capire dove sta l'inghippo....cmq non molliamo...c'è una soluzione a tutto...e se si collabora si trova prima...aspetto tue notizie...ciao.
« Ultima modifica: 11 Dic 2012, 11:35:37 da surya »

Offline surya

  • Nuovo arrivato
  • *
  • Post: 17
    • Mostra profilo
Re:[Risolto]-Problema con Remository 3.54
« Risposta #7 il: 11 Dic 2012, 14:43:54 »
OK Ashtii risolto...prove su prove ma ce l'abbiamo fatta...devi modificare i files "remository.css" e "remository.html.php" entrambi nella cartella "com_remository" che normalmente trovi nella directory del sito...quindi se hai accesso al server che ospita il sito la trovi in /var/www/------/components/com_remository...dove i trattini stanno per il nome della directory del sito, diversamente se il sito si trovasse direttamente nella cartella www allora dopo / avrai componets/etc etc....nel file "remository.css" sostituisci tutte le occorrenze url con il percorso assoluto reale in cui sono ospitate le icone (sono 5 occorrenze), mentre nel file "remository.html.php" modifica, nella sezione FOOTER_SUBMIT il percorso assoluto nella stringa:

$iconlink = '/percorso assoluto reale'.($file->icon ? $file->icon : 'stuff1.gif');

In tal modo sarà correttamente visualizzata sia l'icona di download a destra, sia l'icona del file come associata in fase di upload  ;D .
Spero di essere stato chiaro. Altrimenti fatti sentire. Ciao.

« Ultima modifica: 11 Dic 2012, 14:52:02 da surya »

Offline Ashtii

  • Nuovo arrivato
  • *
  • Post: 7
    • Mostra profilo
Re:Problema con Remository 3.54
« Risposta #8 il: 23 Dic 2012, 16:21:08 »
Ciao Surya! Che dire... intanto grazie mille per il tuo preziosissimo aiuto! Il mio problema era leggermente diverso dal tuo, ma leggendo i tuoi suggerimenti ho trovato il punto esatto in cui sostituire anche io il percorso assoluto corretto nel file remository.htm.php. A me bastava sostituire il percorso relativo alla variabile $iconlink. Quindi adesso ho risolto anche io!
Grazie ancora!

 

Host

Torna su