Back to top

Autore Topic: [RISOLTO] Non partono le email di Chronoform  (Letto 4716 volte)

Offline billa18

  • Appassionato
  • ***
  • Post: 388
  • Sesso: Femmina
    • Mostra profilo
[RISOLTO] Non partono le email di Chronoform
« il: 20 Ago 2012, 18:13:35 »
Ciao a tutti
è probabile che non sia questa la sezione giusta per il mio problema, ma ci provo :
ho pubblicato un sito di un albergo da un paio d'anni, nel quale c'è un modulo gestito da Chronoform per la richiesta di info. Fino ad una decina di giorni fa tutto filava perfettamente, e l'albergo riceveva tutte le richieste dal sito. Da qualche giorno a questa parte invece le email non partono più, nè quella che deve arrivare all'albergo, nè quella che deve arrivare al mittente in copia.Come se non riuscissero ad "uscire" dal sito.
Ne ho la certezza in quanto ho abilitato il salvataggio di ogni richiesta sul database mysql, ed ho un folto elenco di invii fatti dei quali l'albergo non ha traccia. Al primo sentore del problema, ho scritto al mio register segnalando l'anomalia, e lui mi ha risposto:
 " Buonasera,

Abbiamo effettuato un test di compilazione con successo. L' email di richiesta ci è arrivata in copia. Sul server era presente della coda di email non gestita dal server smtp dato l' eelevato numero. A seguito del nostro intervento il problema segnalato è rientrato."
 
Ed in effetti da quel momento il problema sembrava risolto. Ma è durato 2 giorni. Da venerdì scorso il problema è tornato, e l'albergatore è imbufalito in quanto siamo ad Agosto, e non si può permettere di perdere nessuna di queste email.
Faccio presente che una quindicina di giorni fa ho fatto un "restyling" del sito, provvedendo anche all'aggiornamento di Joomla dalla versione 1.5.15 alla 1.5.22.
Mi sapete dire se questo aggiornamento potrebbe aver creato problemi con il PHP mail? Considerate anche che ho fatto la prova impostando l'invio tramite server smtp, ma nulla è cambiato.
Vorrei capire se il problema è legato al sito, oppure ad un malfunzionamento a livello di dominio/mantainer.
Grazie mille per i vostri suggerimenti.
 
P.S. : dimenticavo di dire che, avendo cambiato il template del sito, ho anche provveduto (ma solo poco fa) a pulire la cache di Chronoform.
« Ultima modifica: 22 Ago 2012, 12:21:19 da billa18 »

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 32023
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
Re:Non partono le email di Chronoform
« Risposta #1 il: 20 Ago 2012, 21:15:55 »
E se invece il problema è proprio della casella email? Forse proprio dato il periodo questa si affolla e le nuove email rimangono in coda avendo la casella esaurito lo spazio assegnato, io svuoterei la casella e mi farei aumentare lo spazio ad almeno 100 o più mega.

Offline billa18

  • Appassionato
  • ***
  • Post: 388
  • Sesso: Femmina
    • Mostra profilo
Re:Non partono le email di Chronoform
« Risposta #2 il: 20 Ago 2012, 21:18:54 »
No. La casella email funziona correttamente. Tutti i messaggi che ci mandiamo via Outlook arrivano perfettamente (ed in questi giorni ce ne siamo scambiate tante). Per altro lui ha la casella configurata in modo tale da NON lasciare i messaggi sul server. E di questo ne sono stracerta (gliel'ho fatta configurare io).
Infatti tutte le email inviate direttamente alla casella email gli arrivano...non arrivano solo quelle che partono dal sito.

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 32023
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
Re:Non partono le email di Chronoform
« Risposta #3 il: 20 Ago 2012, 21:24:11 »
Se non arrivano nemmeno nella posta indesiderata allora utilizza il protocollo smtp, così facendo non utilizzi più il server del sito ma proprio il server email della tua casella, lo stesso che utilizzi con outlook e che come dici funziona. Le impostazioni smtp di joomla, tutte, devono essere le stesse che inserisci in oulook.

Offline billa18

  • Appassionato
  • ***
  • Post: 388
  • Sesso: Femmina
    • Mostra profilo
Re:Non partono le email di Chronoform
« Risposta #4 il: 20 Ago 2012, 21:30:54 »
Come ho scritto nel primo post, ho fatto anche questa prova, ma inutilmente....le email non arrivano (ho compilato diversi form di prova).
Neanche l'invio via smtp funziona, al momento...
Ma la prima volta, quando il register è intervenuto, il problema si era risolto....dove potrei "mettere mani" io per risolvere da me il problema? C'è una strada praticabile?
 
« Ultima modifica: 20 Ago 2012, 21:32:47 da billa18 »

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 32023
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
Re:Non partono le email di Chronoform
« Risposta #5 il: 20 Ago 2012, 21:35:02 »
Beh allora devi ricontattare il servizio hosting, se funziona a fasi alterne certamente è un problema di porte del server.

Offline billa18

  • Appassionato
  • ***
  • Post: 388
  • Sesso: Femmina
    • Mostra profilo
Re:Non partono le email di Chronoform
« Risposta #6 il: 20 Ago 2012, 21:41:18 »
L'ho ricontattato immediatamente venerdì. ma ancora non mi hanno dato notizie....ed intanto l'albergo è fermo con tutti i danni annessi e connessi...ed io non so che fare.
L'unica soluzione "empirica" che ho trovato è stata quella di mandare al proprietario il file excel della tabella di Chronoform con tutti i dati dei mittenti, così da ricontattarli...ma non posso stare 24 ore su 24 davanti al pc a controllare la sua tabella....ed anche qualche ora di ritardo nella risposta per lui può essere molto importante.
« Ultima modifica: 20 Ago 2012, 21:43:21 da billa18 »

Offline billa18

  • Appassionato
  • ***
  • Post: 388
  • Sesso: Femmina
    • Mostra profilo
Re:Non partono le email di Chronoform
« Risposta #7 il: 22 Ago 2012, 12:20:58 »
Problema risolto : ho scoperto che il figlio del proprietario, per potere leggere le email da fuori, aveva marcato, recentemente, l'opzione di "salvare una copia dei messaggi sul server", e sulla email che avrebbe dovuto ricevere i messaggi c'erano 3256 email :)
Cancellate tutte queste (che provocavano, evidentemente, l'intasamento) sono arrivati tutti i messaggi di prova che nel corso di questi giorni avevo fatto.
In buona sostanza il tutto adesso funziona regolarmente :)
Grazie a tutti per l'attenzione :)
 

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 32023
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
Re:[RISOLTO] Non partono le email di Chronoform
« Risposta #8 il: 22 Ago 2012, 20:18:48 »
Ok, il figlio del propietario può comunque lasciare salvate le copie delle email, ma deve inpostare un tempo fra due o una decina di giorni a seconda della grandezza dello spazio della casella email in modo che comunque poi la questa  si svuota.

Offline billa18

  • Appassionato
  • ***
  • Post: 388
  • Sesso: Femmina
    • Mostra profilo
Re:[RISOLTO] Non partono le email di Chronoform
« Risposta #9 il: 23 Ago 2012, 12:42:19 »
Più facilmente gli ho fatto smarcare l'opzione, ed avendo lui capito il problema che poteva generare, sono stratranquikla che non lo rimarcherà mai più :)
Grazie mille

 



Web Design Bolzano Kreatif