Autore Topic: Re:Login non funzionante con opzioni SEO  (Letto 1978 volte)

Offline Walter Ego

  • Appassionato
  • ***
  • Post: 532
    • Mostra profilo
Re:Login non funzionante con opzioni SEO
« il: 17 Set 2012, 17:16:16 »
Ciao a tutti.
Per settimane ho lavorato ad una nuova versione del mio sito (J2.5 da 1.5) su una sottocartella (/update).
Tutto funzionava benissimo.

Oggi ho effettuato il passaggio alla cartella principale (root) ma ho delle cose che non vanno.

il sito si vede bene e sembra funzionare, ma se provo ad effettuare il login mi riporta alla home senza aver effettuato il login.


Ho disattivato le tutte le opzioni SEF/SEO nel pannello configurazione e ripristinato il file htaccess.txt (ricopiato dal file Joomla 2.5.7.)

Così funziona.

ora però se rinomino il file .htaccess e attivo le opzioni nel pannello non funziona.

Qualcuno sa cosa posso fare?

Grazie infinite
« Ultima modifica: 19 Set 2012, 23:13:31 da Walter Ego »

Offline Murphz

  • Global Moderator
  • Abituale
  • ********
  • Post: 1335
  • Sesso: Maschio
  • Trust No1
    • Mostra profilo
Re:Login non funzionante con opzioni SEO
« Risposta #1 il: 17 Set 2012, 19:22:56 »
Controlla che su .htaccess ci sia un riferimento al fatto che joomla è installato su una sottocartella (/update) sulla direttiva RewriteBase.
Freelance Web & Graphic Design // Twitter

"...Nothing Important Happened Today..."

Offline Walter Ego

  • Appassionato
  • ***
  • Post: 532
    • Mostra profilo
Re:Login non funzionante con opzioni SEO
« Risposta #2 il: 18 Set 2012, 10:42:17 »
ti ringrazio per la risposta, ma il file htaccess l'ho risovrascritto dall'ultima versione di joomla quindi era "vergine". Comunque ho risolto:

nel passaggio alla root non so perchè ma alcune impostazioni come plugin, menu hanno cambiato impostazione creando un po' di disordine. Ho rimesso tutto in ordine e poi ho cancellato nel db alcune tabelle di un componente per SEO.

Pulito tutto o rifatto il processo: ho attivato le opzioni e modificato il suffisso del file htaccess ed ora tutto funziona.

« Ultima modifica: 19 Set 2012, 23:13:54 da Walter Ego »

Offline Walter Ego

  • Appassionato
  • ***
  • Post: 532
    • Mostra profilo
Re:Login non funzionante con opzioni SEO
« Risposta #3 il: 18 Set 2012, 23:31:48 »
Purtroppo oggi improvvisamente si è ripresentato il problema però solo in homepage.
Se mi loggo in una pagina diversa dalla home funziona bene.
Non capisco.
« Ultima modifica: 19 Set 2012, 23:14:18 da Walter Ego »

Offline Walter Ego

  • Appassionato
  • ***
  • Post: 532
    • Mostra profilo
Re:Login non funzionante con opzioni SEO
« Risposta #4 il: 19 Set 2012, 23:16:08 »
ho una versione per mobile e mi sono accorto che il login non funziona su questa versione e la cosa allucinante sia frontend che backend.


E' possibile che l'impostazione SEF crei tutti questi problemi?
Grazie

Offline Murphz

  • Global Moderator
  • Abituale
  • ********
  • Post: 1335
  • Sesso: Maschio
  • Trust No1
    • Mostra profilo
Re:Login non funzionante con opzioni SEO
« Risposta #5 il: 21 Set 2012, 17:03:13 »
Direi di no, forse il problema è della versione mobile?
Freelance Web & Graphic Design // Twitter

"...Nothing Important Happened Today..."

Offline Walter Ego

  • Appassionato
  • ***
  • Post: 532
    • Mostra profilo
Re:Login non funzionante con opzioni SEO
« Risposta #6 il: 21 Set 2012, 21:56:05 »
Risolvendo un altro problema ho parzialmente risolto anche questo.
Il tutto era riconducibile al file configuration.php anche se ancora ho qualche problema

 

Host

Torna su