Autore Topic: [RISOLTO] Improvvisamente apache xampp non parte più  (Letto 9406 volte)

Offline baronepiovasco

  • Appassionato
  • ***
  • Post: 389
  • Sesso: Maschio
    • Mostra profilo
Buongiorno a tutti,

mi succede una cosa strana con apache xampp: non si avvia più.
Fino a ieri funzionava benissimo.
Premetto che ho win7 e Xampp version: 1.7.7 portable.
Ho provato tutti i consigli che si trovano in rete ma nessuno è stato risolutivo. Le porte sono libere (controllato con xampp_portcheck) non ho installato IIS, Skype non è attivo.

La cosa strana è che non mi genera log, nulla, l'unica cosa che mi viene in mente è che ho installato gli ultimi aggiornamenti del sistema operativo posso aver influito?

Consigli, illuminazioni? Confido nella vostra esperienza, attendo con ansia...
Grazie mille a tutti quanti.

P.S.

Aggiungo:

Ho appena aperto il visualizzatore eventi windows:

Citazione
The Apache service named
   
reported the following error: >>>
httpd.exe: Syntax error on line 113 of C:/Users/Mino/Portable/xampp/apache/conf/httpd.conf:

Cannot load C:/Users/Mino/Portable/xampp/apache/modules/mod_mime.so into server: %1 non \xe8 un'applicazione di Win32 valida.

Inutile dire che "mod_mime.so" è al suo posto... non so che fare :-(
« Ultima modifica: 14 Gen 2013, 18:45:05 da baronepiovasco »
Non ci si può mettere a far qualcosa senza che qualcos'altro non vada fatto prima. :-)

Offline matty80

  • Global Moderator
  • Instancabile
  • ********
  • Post: 3969
  • Sesso: Maschio
    • Mostra profilo
Re:Improvvisamente apache xampp non parte più
« Risposta #1 il: 14 Gen 2013, 02:38:30 »
ciao,
a prescindere dal tuo problema ti consiglio di utilizzare la versione 1.7.3 di xampp con joomla, prova a disinstallare ed installare quest'ultima e vedi come va!


hola
Chi non ha mai posseduto un cane, non sa cosa significhi essere amato. Arthur Schopenhauer

Offline baronepiovasco

  • Appassionato
  • ***
  • Post: 389
  • Sesso: Maschio
    • Mostra profilo
Re:Improvvisamente apache xampp non parte più
« Risposta #2 il: 14 Gen 2013, 09:12:01 »
Grazie per la tua risposta,

chiedevo aiuto in questa particolare situazione perchè non avviandosi apache non so come fare ad esportare i db dei siti che sto sviluppando in locale, ci sono metodi alternativi?

C'è un motivo particolare per il quale mi consigli proprio questa versione di xmapp, io uso solo joomla 2.5 e andava una bellezza con la mia 1.7.7 :-(.

Nota aggiuntiva versione che uso è quella portable, qualsiasi consiglio e benaccetto.

Ciao.
Non ci si può mettere a far qualcosa senza che qualcos'altro non vada fatto prima. :-)

Offline matty80

  • Global Moderator
  • Instancabile
  • ********
  • Post: 3969
  • Sesso: Maschio
    • Mostra profilo
Re:Improvvisamente apache xampp non parte più
« Risposta #3 il: 14 Gen 2013, 11:18:52 »
te la consigliavo perche molti utenti hanno problemi con versioni superiori (versione di php ecc...), se tu dici che ti gira bene, valuta tu!
Chi non ha mai posseduto un cane, non sa cosa significhi essere amato. Arthur Schopenhauer

Offline baronepiovasco

  • Appassionato
  • ***
  • Post: 389
  • Sesso: Maschio
    • Mostra profilo
Re:Improvvisamente apache xampp non parte più
« Risposta #4 il: 14 Gen 2013, 11:22:49 »
Non chiedevo per polemica, spero tu non mi abbia frainteso... hai consigli per come esportare i db laddove non riesca a risolvere la situazione?

Ti ringrazio per l'attenzione.
Non ci si può mettere a far qualcosa senza che qualcos'altro non vada fatto prima. :-)

Offline matty80

  • Global Moderator
  • Instancabile
  • ********
  • Post: 3969
  • Sesso: Maschio
    • Mostra profilo
Re:Improvvisamente apache xampp non parte più
« Risposta #5 il: 14 Gen 2013, 11:30:40 »
tranquillo nessun fraintendimento!!  :D
per esportare il db è essenziale che tu riesca ad entrare nel tuo phpmyadmin quindi riuscire ad accedere a mysql, ora non so non avendolo mai fatto se installando mysql come db sul tuo pc riesci a trovare il db in questione! ::)
Chi non ha mai posseduto un cane, non sa cosa significhi essere amato. Arthur Schopenhauer

mau_develop

  • Visitatore
Re:Improvvisamente apache xampp non parte più
« Risposta #6 il: 14 Gen 2013, 17:48:00 »
httpd.exe: Syntax error on line 113 of C:/Users/Mino/Portable/xampp/apache/conf/httpd.conf:
----------------------------------------------------------------------------------------------------------------------------
... che cosa hai fatto a qs file?
...cosa c'è a quella riga?
....il file è utf-8
.... mod_mime.so esiste? (c'è una cartella con tutti i moduli .so)
.... prendendo uno stesso pacchetto sostituendo quel file correggendo la path che succede?
... e sostituendo la cartella con i mime?

Offline baronepiovasco

  • Appassionato
  • ***
  • Post: 389
  • Sesso: Maschio
    • Mostra profilo
Re:Improvvisamente apache xampp non parte più
« Risposta #7 il: 14 Gen 2013, 18:43:33 »
Ciao mau,

ultimamente mi sento come il figlio naturale di Shaggy e Scooby-Doo  :) , avevo la soluzione sotto gli occhi e non la vedevo, ti rigrazio... ho seplicemente cercato la vecchia versione xampp 1.7.7, estratto il file mod_mime.so sostituendolo a quello danneggiato... risolto!!!

Per gratitudine voterò la tua lista  ;D !

Buona serata.
Non ci si può mettere a far qualcosa senza che qualcos'altro non vada fatto prima. :-)

 

Host

Torna su