Autore Topic: Problema ZoomCat (V. 1RC3) Category is not... RISOLTO  (Letto 1488 volte)

Offline signorBianchi

  • Nuovo arrivato
  • *
  • Post: 43
    • Mostra profilo
Ciao a tutti.
Ho cercato nel forum e anche sul forum di zoomfactory.org ma non ho trovato la soluzione al mio problema. Sul mio Joomla 1.0.12 zOOm ho installato "zOOm Media Gallery 2.5.1 RC4 Week 08"

Il problema sul funzionamento di "mambot_zOOmCat1_RC3"
il mambot che servirebbe per far comparire in un articolo le immagini incluse in una gallery pubblicata. Zoom gallery funziona correttamente; ho installato e abilitato il mambot e inserito in uno dei miei articoli il codice {zoomcat   catid=AnyZoomCategory} con il numero di ID della gallery desiderata al posto di AnyZoomCategory. Eppure in frontend mi restituisce questo errore:

Category is not published, is password protected, or does not exist!

Ho provato a disabilitare il css del mambot ma non cambiato niente. La gallery visibile e non protetta da alcuna password.

Qualcuno potrebbe darmi un suggerimento?
Grazie a tutti  :)
Manuele
______________________

Ho provato ad inserire il codice in un articolo nuovo, (cio appena inserito) come suggerito sul forum di Zoom ma non cambiato niente.
Il sito per ora on line da poco, raggiungibile solo tramite link diretto, non ho ancora curato i due "raffreddori":
#  Impostazione PHP register_globals `ON` invece di `OFF`
# Impostazione Joomla! RG_EMULATION `ON` invece di `OFF` nel file global.php
______________________

Questa dovrebbe essere la pagina dell'hotel Cosmopol
http://www.bianchihotels.com/index.php?option=com_content&task=view&id=12&Itemid=1
« Ultima modifica: 29 Mar 2007, 14:52:58 da signorBianchi »

Offline signorBianchi

  • Nuovo arrivato
  • *
  • Post: 43
    • Mostra profilo
Re: Problema ZoomCat (V. 1RC3) Category is not...
« Risposta #1 il: 27 Mar 2007, 12:52:57 »
Ho corretto i due inconvenienti:
#  Impostazione PHP register_globals `ON` invece di `OFF`
# Impostazione Joomla! RG_EMULATION `ON` invece di `OFF` nel file global.php
Ho provato a spostare il codice dall'introduzione al corpo principale della notizia come suggerito su altri forum ma non basta. Il mambot in qualche modo funziona: inserisco {zoomcat   catid=3} nel testo e on line si legge Category is not published, is password protected, or does not exist! Eppure exist!  ;)

Offline signorBianchi

  • Nuovo arrivato
  • *
  • Post: 43
    • Mostra profilo
Re: Problema ZoomCat (V. 1RC3) Category is not...
« Risposta #2 il: 27 Mar 2007, 23:17:05 »
Questa la parte del file zoomcat.php che restituisce l'errore:

   //Check validity and load info about designated catid
   $database->setQuery("SELECT * FROM #__zoom WHERE catid = $ZMCatID AND published='1' AND catpassword=''");
   $catrows=$database->loadObjectList();
   $ZMCatDir = $catrows[0]->catdir;
   $ZMCatName = $catrows[0]->catname;
   $ZMCatDesc = $catrows[0]->catdescr;
   $ZMCatImg = $catrows[0]->catimg;
   if (!$catrows) {
      return 'Category is not published, is password protected, or does not exist!';

vi suggerisce qualcosa? (a me no  :'()

Offline signorBianchi

  • Nuovo arrivato
  • *
  • Post: 43
    • Mostra profilo
Re: Problema ZoomCat (V. 1RC3) Category is not...
« Risposta #3 il: 28 Mar 2007, 18:16:16 »
Si possono fare appelli di questo tipo:
"Ciao Napo, mi pare mi avessi indicato tu questo Mambot, l'hai mai usato? E per caso hai avuto questo inconveniente?"

Prima di fare l'appello domando se lecito.  :P :-[

Grazie comunque.
Magari qualcuno con lo stesso problema ha letto le mie considerazioni e risolto il problema?

Fate sapere magari.    Manuele

Offline signorBianchi

  • Nuovo arrivato
  • *
  • Post: 43
    • Mostra profilo
Re: Problema ZoomCat (V. 1RC3) Category is not...
« Risposta #4 il: 29 Mar 2007, 14:52:16 »
Ecco la soluzione  :D.

Inserendo il codice {zoomcat catid=3} nel contenuto pu succedere (cos nel mio caso), che l'editor HTML scriva tutto questo codice:

<span class="ZMCatDesc"><strong>{zoomcat catid=</strong>3<strong>}</strong></span>

Io avevo controllato l'aspetto html, ma non sapevo fosse sbagliato. Poi ho ricevuto il suggerimento direttamente dal creatore del mambot Thaddaeus Dahlberg, detto il mitico.
Citazione
Make sure there is no hidden coding in your statement (WYSIWYG editors can sometimes do that). You will have to look at your HTML in your editor in order to see this.

In pratica sia nel testo che nell'html il codice deve essere solo: {zoomcat catid=3} Perci: bottoncino html > corretto tutto salvo > e funziona correttamente.

Citazione
I deleted what was there and from the HTML editor entered the mambot code {zoomcat catid=1}. If you do it this way you can be sure that the editor will not add any extra code onto the mambot that will confuse it. When I did this the gallery appeared fine on the front-side of your site. Does this make sense?
Basically, the WYSIWIG editor that creates the content was adding extra formatting code that was confusing the mambot. This doesn't usually happen to me, but I can understand why it does as sometimes the editor tries to hard to format things.

incidentally, I use the latest Firefox 2.0.0.3 and the JCE 1.1 beta editor and have not had much trouble.

Ciao a tutti.
mrWhite

 

Host

Torna su