Autore Topic: Nuovo Contenuto: ID parte da zero  (Letto 1487 volte)

Offline Jianna

  • Nuovo arrivato
  • *
  • Post: 22
    • Mostra profilo
Nuovo Contenuto: ID parte da zero
« il: 27 Mar 2007, 12:23:46 »
Buongiorno,

ho la seguente situazione: due installazioni di Joomla su due PC diversi. Per il porting da uno all'altro sovrascrivo l'intera applicazione a meno del file configuration.php e poi eseguo l'export/import della base dati (descrivo questo perché può essere un'operazione fonte di problemi!)

Ora lavorando sulla nuova installazione, dopo un po', mi sono accorta che creando un nuovo Contenuto, questo viene salvato con ID 0 (quando gli ID, per esempio, sono già oltre il 30).

Questo non da problemi nel momento dell'inserimento, ma li da quando modifico l'informazione (update).

Non so se è un bug di Joomla (improbabile) o un mio errore. In quest'ultimo caso, come risolvere la situazione e riportarla in un punto stabile?

Grazie


Offline napo

  • Instancabile
  • ******
  • Post: 6532
  • Sesso: Maschio
  • NO MP TECNICI, verranno ignorati
    • Mostra profilo
Re: Nuovo Contenuto: ID parte da zero
« Risposta #1 il: 27 Mar 2007, 12:30:05 »
Molto probabilmente è saltato l'autoincremento delle chiavi primarie.
Verifica, nella struttura delle tabelle, la presenza della clausola AUTO_INCREMENT sulle chiavi primarie.
Poi fai una ricerca, ne abbiamo già parlato.


AllOne.it Consulting: http://www.allone.it Gens Joomla, il : http://www.gensjoomla.org  [url=http://www.allone.it/jooml

Offline Jianna

  • Nuovo arrivato
  • *
  • Post: 22
    • Mostra profilo
Re: Nuovo Contenuto: ID parte da zero
« Risposta #2 il: 27 Mar 2007, 17:14:53 »
Grazie tante, il problema era infatti questo

 

Host

Torna su