Autore Topic: [RISOLTO] joomla da remoto a locale ---> 404 Not Found  (Letto 4021 volte)

Offline Max_supertramp

  • Nuovo arrivato
  • *
  • Post: 3
    • Mostra profilo
Ciao a tutti, sono nuovo del Forum e un neofita di joomla. Il motivo che mi ha portato a iscrivermi al forum è proprio il problema che da più di una settimana mi sta attanagliando, dato che non riesco a trovare una soluzione valida che mi permetta di superare l'ostacolo; chiedo scusa in principio se il problema è stato posto in qualche altra discussione... ma cercando non ho trovato nulla.

Vi spiego: ho creato un sito con joomla 2.5 da server remoto sentendo poi la necessità ho deciso di trasferirlo in locale. In locale il mio sistema operativo è windows7, come webserver ho installato wamp ed ho seguito la procedura per migrare il sito in locale con Filezilla:
1. copiato tutti i file dalla root;
2. esportato il Database da remoto e importato in locale (utilizzando phpmyadmin naturalmente);
3. reimpostato il file configuration.php nelle sezioni  $host , $user , $password , $db come specificato in infinite guide presenti sulla rete ....

ma niente il risultato finale è sempre lo stesso quando provo ad aprire il mio sito in locale con wamp: pagina bianca con scritto NOT FOUND e sotto la scritta
The requested URL /joomla/ was not found on this server.

Come ne esco fuori?
« Ultima modifica: 01 Feb 2014, 15:01:43 da Max_supertramp »

Offline maicolstaip

  • Global Moderator
  • Instancabile
  • ********
  • Post: 17623
  • Sesso: Maschio
    • Mostra profilo
Re:jommla da remoto a locale ---> 404 Not Found
« Risposta #1 il: 29 Gen 2014, 15:34:17 »
Benvenuto nel forum di joomla.it Max_supertramp (bel nick!),
dando per scontato che tu abbia una versione della LAMP compatibile, e che tu abbia messo i files e le cartelle di joomla al posto giusto proverei a disabilitare il SEO del sito.
Lo puoi fare tramite il file configuration.php

Ciao!
Non si risponde a PM tecnici. Postate sul forum. Grazie.

Offline Max_supertramp

  • Nuovo arrivato
  • *
  • Post: 3
    • Mostra profilo
Re:jommla da remoto a locale ---> 404 Not Found
« Risposta #2 il: 30 Gen 2014, 11:53:01 »
Grazie Maicolstaip !!!
nella notte ci ho lavorato un pò su e credo di aver trovato la causa del problema ma non so come risolverlo; nel momento in cui ti sto scrivendo naturalmente sto cercando nella rete una soluzione, e comunque ora ti scrivo nel dettaglio cosa posso aver dedotto:
Il sito l'ho creato su altervista e la root che mi si presenta ha 2 file e una cartella ---> la cartella è joomla con all'interno tutti i file e le cartelle del sito, ecc ecc ecc.
i file invece sono index.php e .htaccess.

In poche parole facendo prove su prove ho capito che se nel file index.php della root principale ho questo:

Codice: [Seleziona]
<?php /* Application: joomla16 */

 
header("Location: /joomla/");

 
// Questo file e' stato autogenerato da AlterVista 
 // Modificate o sostituite questo file solo se siete certi di quello che fate!
 //  Per proteggere questo file, disabilitando le funzioni che lo modificano automaticamente,
 // potete eliminare il commento sulla prima riga (tutto cio' che c'e' tra /* e */)
 //
 // This file was autogenerated by AlterVista
 // Modify or substitute this file only if you know what are you doing!
 //  To protect this file, disabling AlterVista's automated functions that edit it from control panel,
 // you can remove the comment on the first row of this file (everything from /* and */)
?>


Wamp sta leggendo un percorso che non trova perchè credo e non vorrei sbagliarmi con i termini non riconosce il percorso relativo che invece andava bene, naturalmente, in remoto.

Quindi l'ho modificato con il percorso assoluto partendo da locale: http://localhost/nomesito/joomla/ al posto del solo /joomla/

non è finita qui sono dovuto anche andare nel file configuration.php all'interno della cartella joomla per modificare questi parametri:

Codice: [Seleziona]
    public $sef = '0';
    public $sef_rewrite = '0';
    public $sef_suffix = '0';

appunto impostandoli su "0";

Ora..... la home si apre e non dà più l'errore; però non posso ritenermi soddisfatto, la home sembra sia stata bombardata; è visualizzata senza criteri come se non riconoscesse moduli o posizioni o css, non lo so.... credo  appunto che alla base di tutto ci siano problemi nel riconoscere i percorsi relativi presenti in tutti i file del sito.

Conosco un pò i forum e so che mi chiederete di mettere risolto al post perchè il problema che proponevo in parte è stato risolto, ma se avete idea di come posso fare per risolvere questa situazione ve ne sarei veramente grato.

grazie :)

Offline Max_supertramp

  • Nuovo arrivato
  • *
  • Post: 3
    • Mostra profilo
Re:jommla da remoto a locale ---> 404 Not Found
« Risposta #3 il: 01 Feb 2014, 14:23:37 »
Ho Risolto da solo!!!!!!! A chi dovesse avere il mio stesso problema consiglio
oltre ai passaggi sopra descritti di andare sul file configuration.php in joomla e alla voce
Codice: [Seleziona]
public $live_site = ' ';togliete il contenuto tra gli apici;

Ciao.

Offline maicolstaip

  • Global Moderator
  • Instancabile
  • ********
  • Post: 17623
  • Sesso: Maschio
    • Mostra profilo
Re:[RISOLTO] joomla da remoto a locale ---> 404 Not Found
« Risposta #4 il: 03 Feb 2014, 12:49:32 »
Ciao Max_supertramp,
corretto.
In genere è sufficiente lasciare vuota a variabile.
L'avevo dato per scontato ;)

Ciao!
Non si risponde a PM tecnici. Postate sul forum. Grazie.

Offline bill_monfortese

  • Nuovo arrivato
  • *
  • Post: 5
    • Mostra profilo
Re:[RISOLTO] joomla da remoto a locale ---> 404 Not Found
« Risposta #5 il: 07 Nov 2015, 11:34:48 »
Grazie. Mi è stato utile.  Dove si imparano queste cosa? ci sono libri o siti?

 

Host

Torna su