Autore Topic: PhpMyAdmin non riesce a partire!  (Letto 4185 volte)

Offline franco_da_vc

  • Esploratore
  • **
  • Post: 144
  • Sesso: Maschio
    • Mostra profilo
PhpMyAdmin non riesce a partire!
« il: 18 Dic 2013, 23:24:34 »
Ho necessità di scaricare dal sito on line il database di mysql, ho ricreato un sito vuoto con i template che ho anche sull'hoster e mi sono procurato phpMyAdmin, peccato che proprio non voglia partire: appena clicco su connetti ottengo il messaggio:
Codice: [Seleziona]
Login senza password è vietato dalla configurazione (vedi AllowNoPassword)
Il problema è che io ho inserito AllowNoPassword ed il database che ho creato all'atto dell'installazione del cms in locale non ha password, ci avevo già provato in una precedente installazione  e si rifiutava di accettarla, di seguito riporto il file di configurazione di PhpMyAdmin:
Codice: [Seleziona]
$i++;
$cfg['Servers'][$i]['host'] = 'localhost'; // MySQL hostname or IP address
$cfg['Servers'][$i]['port'] = ''; // MySQL port - leave blank for default port
$cfg['Servers'][$i]['socket'] = ''; // Path to the socket - leave blank for default socket
$cfg['Servers'][$i]['connect_type'] = 'socket'; // How to connect to MySQL server ('tcp' or 'socket')
$cfg['Servers'][$i]['extension'] = 'mysqli'; // The PHP MySQL extension to use ('mysql' or 'mysqli')
$cfg['Servers'][$i]['user'] = 'root'; // MySQL user
$cfg['Servers'][$i]['AllowNoPassword'] = true; // Allow access without password

Mentre l'impostazione del database è la seguente:
Codice: [Seleziona]
Tipo database: Mysqli
Host: localhost
Nome utente database: root
Nome database: jz61d
Prefisso tabelle database: jz61d_

Vi chiedo aiuto perchè non riesco più a trovare spunti per migliorare la situazione.  :(

Vi ringrazio
http://www.baseballsoftball-vercelli.it
Bye by AFo
Linux users #132554 - Linux machine #104282

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 31266
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
Re:PhpMyAdmin non riesce a partire!
« Risposta #1 il: 19 Dic 2013, 07:56:03 »
Ciao
Ma in locale cosa hai utilizzato per installare il cms? Se usi xampp versione 1.7.3 hai già tutto configurato e  funzionante compreso phpmyadmin. Tieni comunque presente che in fase di export ed import devi agire solo sulle tabelle e sui dati, senza preoccuparti di riportare anche i dati di accesso dei db che possono essere diversi.

Offline mmleoni

  • Global Moderator
  • Instancabile
  • *****
  • Post: 5547
  • Sesso: Maschio
  • Just another *nix coder/sysadmin...
    • Mostra profilo
Re:PhpMyAdmin non riesce a partire!
« Risposta #2 il: 19 Dic 2013, 08:17:12 »
domanda banale: ti sei ricordato di spostare il file di configurazione (config.inc.php) nella root di phpmyadmin?

di base viene creato in /config e va spostato in root, o nella cartella dove c'è la index... quando giocate con quei cosi lì (xaamp e cugini) non si capisce mai niente  ::)

ciao,
marco

mmleoni web consulting - creazione siti web aziendali ed e-commerce avanzati - sviluppo moduli e componenti Joomla

Offline franco_da_vc

  • Esploratore
  • **
  • Post: 144
  • Sesso: Maschio
    • Mostra profilo
Re:PhpMyAdmin non riesce a partire!
« Risposta #3 il: 19 Dic 2013, 22:45:13 »
Ciao Tomtomeight e Mmleoni,

Intanto vi ringrazio per il vostro interessamento, procediamo con metodo:

Il cms che ho installato, di fatto e la versione 2.5.16 che ho scaricato dal sito e poi ho fatto come al solito la procedura di installazione, l'unica cosa strana che ho notato era che il cms era completamente vuoto invece di contenere i soliti file di esempio,... il brutto è che al livello che mi stai dicendo non ci sono ancora arrivato, phpMyAd proprio non parte! per quanto rigurda l'xampp che ho usato di fatto non so quale sia, io lavoro su Suse Linux ed ho scaricato il pacchetto phpMyAdmin stand alone che forse fa parte non di Xampp, bensì di Lampp.

Il file di configurazione io l'ho trovato in /etc/phpMyAdmin però (!!!?!) da li non l'ho spostato ma l'ho solo copiato, non è che la copia nella /etc da problemi? Non vorrei! Oltretutto la root che mi dici qual'è? Io ho di sistema una cartellanella /home/franco/public_html che ho configurato come root di Apache, li dentro è contenuta /NewBaseball ove c'è il cms in locale e /phpMyAdmin ove c'è il file di configurazione di cui stiamo parlando, è quella la root dell'utility? non è che devo portare la configurazione fuori, in /public_html?
http://www.baseballsoftball-vercelli.it
Bye by AFo
Linux users #132554 - Linux machine #104282

Offline mmleoni

  • Global Moderator
  • Instancabile
  • *****
  • Post: 5547
  • Sesso: Maschio
  • Just another *nix coder/sysadmin...
    • Mostra profilo
Re:PhpMyAdmin non riesce a partire!
« Risposta #4 il: 20 Dic 2013, 08:49:59 »
Citazione
l'unica cosa strana che ho notato era che il cms era completamente vuoto invece di contenere i soliti file di esempio
parli di file o di articoli? se parli di file (sql e immagini) il pacchetto non è completo, se parli di articoli magari non li hai fatti caricare (è un'opzione)


Citazione
Il file di configurazione io l'ho trovato in /etc/phpMyAdmin
che ci faccia lì, o come possa essere letto da lì è per me un mistero della pacchettizzazione...

Citazione
Io ho di sistema una cartella nella /home/franco/public_html che ho configurato come root di Apache, li dentro è contenuta /NewBaseball ove c'è il cms in locale e /phpMyAdmin ove c'è il file di configurazione
il file di configurazione deve stare lì in una installazione standard di phpmyadmin, non so dirti però con i pacchetti suse. penso che se è in /etc un motivo ci sia...

comunque se phpmyadmin ti dà il messaggio di errore citato vuol dire che parte, ma che non legge il file di configurazione, o che ignora la direttiva 'AllowNoPassword'.
prova a modificare il file in /etc/phpMyAdmin e dare un restart ad apache, alla peggio ti scarichi il tar.gz dal sito di phpmyadmin e lo decomprimi nella cartella.

ciao
mmleoni web consulting - creazione siti web aziendali ed e-commerce avanzati - sviluppo moduli e componenti Joomla

Offline franco_da_vc

  • Esploratore
  • **
  • Post: 144
  • Sesso: Maschio
    • Mostra profilo
Re:PhpMyAdmin non riesce a partire!
« Risposta #5 il: 17 Feb 2014, 21:56:50 »
Ciao a tutti,

non mi ero più fatto sentire perché dopo aver tentato più volte di far partire il PhpMyAdmin, mi sono convinto che siccome era pronta la nuova versione del mio sistema (Suse 13.1) era meglio installare quella e ripartire con le configurazioni da capo.

Devo dire che sono contento della decisione che ho preso, ora mi ritrovo con il cms in locale reinstallato ex novo, il server apache configurato molto meglio di quanto avevo fatto prima, il mysql anch'esso configurato con molta più precisione e con password mentre prima non l'avevo inserita e penso che quello fosse il motivo principe per cui non mi partiva PhpMyAdmin.

E questo naturalmente grazie anche ai vostri suggerimenti, chiudo quindi qui questo post e vi ringrazio, ma non preoccupatevi infatti sto per caricarne un'ulteriore.

grazie a tutti.
http://www.baseballsoftball-vercelli.it
Bye by AFo
Linux users #132554 - Linux machine #104282

 

Host

Torna su