Autore Topic: Accenti ed apostrofi spariti nel nuovo template  (Letto 732 volte)

Offline Manuela1980

  • Esploratore
  • **
  • Post: 68
  • Sesso: Femmina
    • Mostra profilo
Accenti ed apostrofi spariti nel nuovo template
« il: 18 Feb 2014, 15:07:26 »

Buon pomeriggio a tutti.
Dopo aver installato un nuovo template per un mio blog (Darland di globberthemes), mi sono accorta che in  tutti i titoli di moduli, categorie, articoli ect. gli apostrofi vengono automaticamente cancellati mentre le lettere accentate vengono sostituite da altri simboli. Ad esempio, è diventa и.
Ho verificato la codifica dei caratteri nel DB e risulta
  • Set di caratteri MySQL: UTF-8 Unicode (utf8)
  •   collazione della connessione di MySQL: utf8_unicode_ci
Quindi, come suggerito in altre discussioni, nell'index.php del template ho inserito dopo <head> la seguente stringa:

<meta http-equiv="Content-Type" content="text/html; charset=utf8"/>

ma non è cambiato nulla. Qualcuno potrebbe suggerirmi come posso intervenire per risolvere il problema? :-\ Grazie.

Offline Manuela1980

  • Esploratore
  • **
  • Post: 68
  • Sesso: Femmina
    • Mostra profilo
Re:Accenti ed apostrofi spariti nel nuovo template
« Risposta #1 il: 18 Feb 2014, 15:29:56 »
APPROFONDIMENTO.
Sempre seguendo i suggerimenti sul forum ho scaricato il DB e guardato quale codifica riporta la parte iniziale delle tabelle:
DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci
Purtroppo non sono assolutamente ferrata in materia, quindi non comprendo le possibili differenze e le conseguenze di ciò! Anche se con il precedente template non avevo nessun problema!  :'(

 

Host

Torna su