Autore Topic: Kunena discuss - Non hai il permesso di accedere a questa pagina.  (Letto 1498 volte)

Offline guidocx84

  • Esploratore
  • **
  • Post: 50
    • Mostra profilo
Ciao a tutti!
Vorrei chiedere il vostro aiuto per un problema che mi si sta verificando su un sito Joomla 1.5 con Kunena 2.0.4 (l'ultimo Kunena disponibile per Joomla 1.5).
Ho installato il plugin kunena discuss per fare in modo che


1) gli utenti possano vedere se c'è un topic già aperto sull'argomento di cui parla l'articolo ed il numero di risposte attualmente presenti
2) nel caso non sia stato aperto alcun topic in riferimento all'articolo, possono procedere ad aprire il topic direttamente dall'articolo tramite un form molto semplice.


Per gli articoli che non ho collegato direttamente ad un topic specifico (quelli dunque afferenti al caso 2) non ci sono problemi. Il form viene visualizzato correttamente.


Per gli articoli collegati direttamente ai topic con il codice {kunena_discuss:id_topic}, sembrava tutto ok...


Codice: [Seleziona]
[KunenaDiscuss debug: Constructor called in com_content ]
[KunenaDiscuss debug: onPrepareContent.Deny: There is no default Kunena category ]
[KunenaDiscuss debug: onPrepareContent: we are in article/default page. ]
[KunenaDiscuss debug: onPrepareContent: Article 451 ]
[KunenaDiscuss debug: onPrepareContent: Searched for {kunena_discuss:#}: Custom Topic 10771 found. ]
[KunenaDiscuss debug: showPlugin: Loading Custom Topic 10771 ]
[KunenaDiscuss debug: showPlugin: Displaying only link to the topic ]
[KunenaDiscuss debug: onAfterDisplayContent: Returning content for article 451 ]




Il tutto ha funzionato fino a quando ho collegato i miei articoli a topic creati con Fireboard. Tutti gli articoli che tramite il codice {kunena_discuss:id_topic} cerco di collegare a topic creati da quando ho eseguito la migrazione da Fireboard a Kunena mi danno come esito Non hai il permesso di accedere a questa pagina, non mostrando dunque il link al topic di riferimento né il numero di risposte attualmente inserite nel suddetto topic come invece fa quando collego degli articoli a topic creati quando avevo Fireboard. Questo è il tracciato di debug:


Codice: [Seleziona]
[KunenaDiscuss debug: Constructor called in com_content ]
[KunenaDiscuss debug: onPrepareContent.Deny: There is no default Kunena category ]
[KunenaDiscuss debug: onPrepareContent: we are in article/default page. ]
[KunenaDiscuss debug: onPrepareContent: Article 498 ]
[KunenaDiscuss debug: onPrepareContent: Searched for {kunena_discuss:#}: Custom Topic 11608 found. ]
[KunenaDiscuss debug: showPlugin: Loading Custom Topic 11608 ]
[KunenaDiscuss debug: showPlugin: Let's see what we can do.. ]
[KunenaDiscuss debug: showPlugin: Category said Non hai il permesso di accedere a questa pagina. ]
[KunenaDiscuss debug: onAfterDisplayContent: Returning content for article 498 ]


Il topic lo trova... ma non funziona.


Cosa mi suggerite di fare? (e non ditemi di aggiornare joomla perché è già in programma... aspetto il 3.5)  :D :D :D ;)




 

Host

Torna su