Autore Topic: url impazzite  (Letto 2905 volte)

Offline 01Danny

  • Esploratore
  • **
  • Post: 141
    • Mostra profilo
url impazzite
« il: 08 Ago 2014, 14:08:11 »
Ciao a tutti,
ho da aggiungere una nuova sottovoce di menu a questo sito: http://obsidianretreat.com

Il problema che una volta creata, quando provo a cliccarci sopra mi da 404 e nell'url mi aggiunge uno "/client" che non ho idea da dove arriva e lo fa in tutte le voci di menu che provo ad aggiungere.

potete vedere 3 esempi di questo cliccando su:

-OBSIDIAN/RECRUITMENT   

-OBSIDIAN/TESTING1 

-OUR HEALTH/TESTING2


Qualcuno ha idea da cosa possa dipendere questo?

Grazie mille
« Ultima modifica: 08 Ago 2014, 15:52:34 da 01Danny »

Offline alexred

  • Fuori controllo
  • *
  • Post: 25672
  • Sesso: Maschio
  • Esperto in ozio relaxed
    • Mostra profilo
Re:url impazzite
« Risposta #1 il: 09 Ago 2014, 11:54:38 »
ciao 01Danny,
in configurazione globale prova a disabilitare le URL SEO

Offline 01Danny

  • Esploratore
  • **
  • Post: 141
    • Mostra profilo
Re:url impazzite
« Risposta #2 il: 09 Ago 2014, 12:04:29 »
Ciao Alexred,
Grazie per la risposta.

allora nelle 4 voci di seo setting ho la prima e l'ultima su SI e la seconda e la terza su NO.
Se metto la prima su NO funziona tutto bene ma ovviamente non posso lasciarlo cos.

Hai un'idea su come posso risolvere il problema?

Grazie mille
« Ultima modifica: 09 Ago 2014, 13:49:40 da 01Danny »

Offline alexred

  • Fuori controllo
  • *
  • Post: 25672
  • Sesso: Maschio
  • Esperto in ozio relaxed
    • Mostra profilo
Re:url impazzite
« Risposta #3 il: 09 Ago 2014, 13:34:56 »
hai forse modificato manualmente gli alias di qualche voce di menu?

Offline 01Danny

  • Esploratore
  • **
  • Post: 141
    • Mostra profilo
Re:url impazzite
« Risposta #4 il: 09 Ago 2014, 13:48:45 »
Appena ricontrollato per sicurezza e no tutti gli alias sono ok sulle voci di menu. Hanno lo stesso nome di come lo vedi sui vari bottoni tranne "obsidian" che ha l'alias "home" ed la voce di menu predefinita.


Non riesco proprio a capire il perch mi f questo redirect e mi crea le url con sto /clients in mezzo a tutte le voci di menu appena create. Cioe non riesco pi a creare nessun tipo di voce di menu perch mi d questo errore.


Qualche idea?











Offline alexred

  • Fuori controllo
  • *
  • Post: 25672
  • Sesso: Maschio
  • Esperto in ozio relaxed
    • Mostra profilo
Re:url impazzite
« Risposta #5 il: 09 Ago 2014, 13:58:59 »
puoi provare a cancellare tutti gli alias delle voci di menu, lasciandoli vuoti e salvando Joomla li ricrea corretti automaticamente.

Offline 01Danny

  • Esploratore
  • **
  • Post: 141
    • Mostra profilo
Re:url impazzite
« Risposta #6 il: 09 Ago 2014, 14:27:30 »
Alexred qualcosa si mosso ma ho peggiorata la situazione.


Adesso il problema su tutte le voci di men, vecchie e nuove, mi crea l'url di ogni voce mettendo di mezzo sto "/clients" e mi da 404.


ESEMPIO: cliccando su THE PROGRAM/EXERCISE mi d errore 404 e mi crea questa url:     http://obsidianretreat.com/index.php/Clients/the-programme/exercise


Al momento il sito gira solo se metto su NO la prima voce del seo setting in configurazione globale.
Ovviamente questo mi crea url improponibili e devo risolvere al pi presto.


Come mi muovo adesso?

Offline alexred

  • Fuori controllo
  • *
  • Post: 25672
  • Sesso: Maschio
  • Esperto in ozio relaxed
    • Mostra profilo
Re:url impazzite
« Risposta #7 il: 09 Ago 2014, 14:30:17 »
ma hai forse messo mano anche al file .htaccess?
prova a ripristinare quello originale di Joomla.

Utilizzi qualche estensione esterna per la gestione delle URL seo ?

Offline 01Danny

  • Esploratore
  • **
  • Post: 141
    • Mostra profilo
Re:url impazzite
« Risposta #8 il: 09 Ago 2014, 14:47:57 »
Ok fatto. Copiato il file htacces.txt da una pacchetto joomla della stessa identica versione appena scaricato.


Niente il problema continua. Rinomino il file in .htacces?




Offline 01Danny

  • Esploratore
  • **
  • Post: 141
    • Mostra profilo
Re:url impazzite
« Risposta #9 il: 09 Ago 2014, 15:00:30 »
Allora si di nuovo mosso qualcosa.


Ripristinando il file htaccess.txt tutte le voci di men esistenti (comprese quelle che prima mi davano errore, cioe le ultime create) hanno iniziato a funzionare tenedo su SI "Search Engine Friendly URLs", quindi con le urls corrette.

Adesso mi d lo stesso problema quando creo una nuova voce di men.

Cioe sono punto e a capo con l'unica cosa buona che quelle vecchie adesso funzionano ma sono di nuovo impossibilitato a crearne di nuove. :o




Che sta succendo?

Offline alexred

  • Fuori controllo
  • *
  • Post: 25672
  • Sesso: Maschio
  • Esperto in ozio relaxed
    • Mostra profilo
Re:url impazzite
« Risposta #10 il: 09 Ago 2014, 16:11:52 »
Niente il problema continua. Rinomino il file in .htacces?
si:   .htaccess

Offline 01Danny

  • Esploratore
  • **
  • Post: 141
    • Mostra profilo
Re:url impazzite
« Risposta #11 il: 09 Ago 2014, 16:22:37 »
ok fatto, ma l'errore continua.

In ogni voce che provo a creare, quando ci clicco sopra, mi d lo stesso errore e mi mette sempre sto /Clients in mezzo.

ESEMPIO: prova a cliccare in: obsidian/testing1


Altre modifiche da poter fare?

Offline 01Danny

  • Esploratore
  • **
  • Post: 141
    • Mostra profilo
Re:url impazzite
« Risposta #12 il: 09 Ago 2014, 18:06:25 »
Ho provato a cambiare l'alias della voce di menu "obsidian" e adesso su tutte le sottovoci di quella mi d il solito errore.


Qualche idea di cosa sta succedendo o di qualche prova che posso fare per capire il problema?






Offline 01Danny

  • Esploratore
  • **
  • Post: 141
    • Mostra profilo
Re:url impazzite
« Risposta #13 il: 09 Ago 2014, 18:51:36 »
Ogni volta che cambio qualunque alias non funziona pi la voce di men.


Help please!!!

Offline 01Danny

  • Esploratore
  • **
  • Post: 141
    • Mostra profilo
Re:url impazzite
« Risposta #14 il: 15 Ago 2014, 14:44:40 »
Ricapitolo il tutto per permettere a chi pu di aiutarmi.  :-\


Il problema che ogni volta che su questo sito http://obsidianretreat.com/ creo una nuova voce di menu mi crea delle url assurde.


esempio: se cliccate su THE RETREAT/PRICES vedrete che nella url che crea mi mette in mezzo uno /clients che non ho idea da dove viene (non ho nessuna categoria o voce di menu chiamata cos, in tutto il sito non esiste niente chiamato 'clients') inoltre anche togliendogli manualmente quel pezzo di url non mi fa vedere l'articolo comunque.




Da cosa pu dipendere questo assurdo rewriting delle url?


Grazie mille in anticipo a tutti.

Offline romina

  • Appassionato
  • ***
  • Post: 285
  • Sesso: Femmina
    • Mostra profilo
Re:url impazzite
« Risposta #15 il: 16 Ago 2014, 00:41:03 »
Posta il contenuto del file .htaccess.

Offline 01Danny

  • Esploratore
  • **
  • Post: 141
    • Mostra profilo
Re:url impazzite
« Risposta #16 il: 22 Ago 2014, 14:04:12 »
Ciao Romina,


Ho trovata una mezza soluzione a questo problema. Ogni volta che creo una nuova voce seleziono tutte le voci di menu e clicco su "ribuilt" e tutto funziona bene anche se il problema non risolto.


quetso il mio htaccess:



Codice: [Seleziona]
##
# @package      Joomla
# @copyright   Copyright (C) 2005 - 2014 Open Source Matters. All rights reserved.
# @license      GNU General Public License version 2 or later; see LICENSE.txt
##


##
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE!
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations.  It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file.  If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's.  If they work,
# it has been set by your server administrator and you do not need it set here.
##


## Can be commented out if causes errors, see notes above.
#Options +FollowSymLinks


## Mod_rewrite in use.


RewriteEngine On


## Begin - Rewrite rules to block out some common exploits.
# If you experience problems on your site block out the operations listed below
# This attempts to block the most common type of exploit `attempts` to Joomla!
#
# Block out any script trying to base64_encode data within the URL.
RewriteCond %{QUERY_STRING} base64_encode[^(]*\([^)]*\) [OR]
# Block out any script that includes a <script> tag in URL.
RewriteCond %{QUERY_STRING} (<|%3C)([^s]*s)+cript.*(>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL.
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL.
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Return 403 Forbidden header and show the content of the root homepage
RewriteRule .* index.php [F]
#
## End - Rewrite rules to block out some common exploits.


## Begin - Custom redirects
#
# If you need to redirect some pages, or set a canonical non-www to
# www redirect (or vice versa), place that code here. Ensure those
# redirects use the correct RewriteRule syntax and the [R=301,L] flags.
#
## End - Custom redirects


##
# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root).
##


# RewriteBase /


## Begin - Joomla! core SEF Section.
#
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
#
# If the requested path and file is not /index.php and the request
# has not already been internally rewritten to the index.php script
RewriteCond %{REQUEST_URI} !^/index\.php
# and the request is for something within the component folder,
# or for the site root, or for an extensionless URL, or the
# requested URL ends with one of the listed extensions
RewriteCond %{REQUEST_URI} /component/|(/[^.]*|\.(php|html?|feed|pdf|vcf|raw))$ [NC]
# and the requested path and file doesn't directly match a physical file
RewriteCond %{REQUEST_FILENAME} !-f
# and the requested path and file doesn't directly match a physical folder
RewriteCond %{REQUEST_FILENAME} !-d
# internally rewrite the request to the index.php script
RewriteRule .* index.php [L]
#
## End - Joomla! core SEF Section.
« Ultima modifica: 22 Ago 2014, 14:06:17 da matty80 »

Offline matty80

  • Global Moderator
  • Instancabile
  • ********
  • Post: 3969
  • Sesso: Maschio
    • Mostra profilo
Re:url impazzite
« Risposta #17 il: 22 Ago 2014, 14:07:24 »
ciao 01danny,
mi sono permesso di modificare il tuo post inserendo i tag del codice onde evitare di far diventare troppo lungo e confusionario il post.


hola e buona giornata :D
Chi non ha mai posseduto un cane, non sa cosa significhi essere amato. Arthur Schopenhauer

Offline romina

  • Appassionato
  • ***
  • Post: 285
  • Sesso: Femmina
    • Mostra profilo
Re:url impazzite
« Risposta #18 il: 22 Ago 2014, 14:16:50 »
Intanto ti converrebbe anche eliminare il suffisso index.php dalle URL brutto anche a vederesi. Fai cos: attiva l'opzione 'riscrivi url sef' e svuota la cache di joomla (men sistema->pulisci cache), potrebbe risolversi tutto.

 

Host

Torna su