Autore Topic: problemi sh404SEF  (Letto 4449 volte)

Offline upupax

  • Nuovo arrivato
  • *
  • Post: 20
    • Mostra profilo
problemi sh404SEF
« il: 05 Lug 2007, 14:38:05 »
Ciao a tutti, sto provando per la prima volta a rendere SEF gli url del mio sito.
Ho installato sh404sef e modificato l'htaccess come consigliato nella sua documentazione..
il mio sito è installato in una cartella (www.miosito.it/cartella/), ma l'hosting mi ha configurato la root in modo che vi si possa accedere da www.miosito.it..
ora, io ho installato sh404sef, ma accedendo a www.miosito.it gli url non sono affatto semplificati, anzi continuano ad essere gli stessi di prima..
accedendovi invece da www.miosito.it/cartella/ il sito è visibile con gli url semplificati, ma assolutamente non navigabile..
presumo di aver sbagliato qualcosa nell'htaccess, ma non capisco esattamente cosa..
vi posto qui il codice..

Codice: [Seleziona]
Codice:

##  Can be commented out if causes errors, see notes above.
# Options +FollowSymLinks

#
#  mod_rewrite in use

# RewriteEngine On


#  Uncomment following line if your webserver's URL
#  is not directly related to physical file paths.
#  Update Your Joomla!/MamboDirectory (just / for root)

 RewriteBase /cartella
 
########## Begin - Joomla! core SEF Section
############# Use this section if using ONLY Joomla! core SEF
## ALL (RewriteCond) lines in this section are only required if you actually
## have directories named 'content' or 'component' on your server
## If you do not have directories with these names, comment them out.
#
#RewriteCond %{REQUEST_FILENAME} !-f
#RewriteCond %{REQUEST_FILENAME} !-d
#RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] ##optional - see notes##
#RewriteCond %{REQUEST_URI} (/|\.htm|\.php|\.html|/[^.]*)$ [NC]
#RewriteRule ^(content/|component/) index.php
#
########## End - Joomla! core SEF Section


########## Begin - 3rd Party SEF Section
############# Use this section if you are using a 3rd party (Non Joomla! core) SEF extension - e.g. OpenSEF, 404_SEF, 404SEFx, SEF Advance, etc
#
RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] ##optional - see notes##
RewriteCond %{REQUEST_URI} (/|\.htm|\.php|\.html|/[^.]*)$ [NC]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
#RewriteRule (.*) index.php
#
########## End - 3rd Party SEF Section

un'ultima aggiunta (che magari è utile a capire se è qualcos altro che non funziona): come ho detto il sito www.miosito.it è navigabile, ma se mi loggo con CB, appena faccio il logout il sito non torna a www.miosito.it/index.php, ma a www.miosito.it/cartella/index.php !!
questo non è strano? non significa che prende come root questo URL anzichè l'altro?
spero di aver dato una spiegazione chiara e che possiate aiutarmi!
grazie fin da ora!

Offline zalexo

  • Appassionato
  • ***
  • Post: 520
  • Sesso: Maschio
    • Mostra profilo
    • SEO & WebMarketing
Re: problemi sh404SEF
« Risposta #1 il: 05 Lug 2007, 18:46:33 »
secondo me quel redirect del dominio ti incasina tutto.

Prova a disattivarlo.

Offline upupax

  • Nuovo arrivato
  • *
  • Post: 20
    • Mostra profilo
Re: problemi sh404SEF
« Risposta #2 il: 06 Lug 2007, 10:55:45 »
ho spostato tutto il contenuto della cartella nella root, ho modificato il live site e l'absolute path, ora attivando il SEF di joomla o sh404sef gli url semplificati sono al posto giusto (www.miosito.it/url-semplificato), ma con entrambe le configurazioni non funzionano..
c'è qualche altra cosa che devo considerare?

Offline zalexo

  • Appassionato
  • ***
  • Post: 520
  • Sesso: Maschio
    • Mostra profilo
    • SEO & WebMarketing
Re: problemi sh404SEF
« Risposta #3 il: 06 Lug 2007, 13:45:05 »
Molto strano, senti con chi ti fornisce l'hosting.

Che errore ti da?

Offline upupax

  • Nuovo arrivato
  • *
  • Post: 20
    • Mostra profilo
Re: problemi sh404SEF
« Risposta #4 il: 06 Lug 2007, 14:25:18 »
404..
su tutte le pagine..
ho già chiamato il servizio di hosting e mi dicono che il problema è la mia configurazione e non la loro..
il mio problema è che se mi collego al www.miosito.it no problem.
appena provo un link si apre la pagina www.miosito.it/urlsemplificato, ma ho la pagina 404..
e questo accade sia con sh404sef sia con il sef di joomla..
cosa potrei sbagliare?
la RewriteBase? devo aggiungere altre condizioni?
devo rendere qualcosa scrivibile? devo creare delle cartelle?
non so.. ditemi voi!

Offline upupax

  • Nuovo arrivato
  • *
  • Post: 20
    • Mostra profilo
Re: problemi sh404SEF
« Risposta #5 il: 06 Lug 2007, 16:04:53 »
era una cosa molto + banale di quel che pensassi..
non avevo settato index.php come index di default e quindi ogni volta che cercava www.miosito.com/urlsemplificato/ non andava automaticamente a urlsemplificato/index.php..
ora però devo capire perché non si aprano più i menu a tendina..

Offline zalexo

  • Appassionato
  • ***
  • Post: 520
  • Sesso: Maschio
    • Mostra profilo
    • SEO & WebMarketing
Re: problemi sh404SEF
« Risposta #6 il: 06 Lug 2007, 16:49:34 »
Non dovevi fare altro.

cmq sono contento che hai risolto, cmq se posti il link del tuo sito posso darti una mano in più.

ciao

 

Host

Torna su