Autore Topic: categorie o articoli settati come REGISTERED rispondono 404 pagina non trovata  (Letto 1689 volte)

Offline smart

  • Esploratore
  • **
  • Post: 141
    • Mostra profilo
Salve a tutti,


sto riprendendo in mano joomla per fare un po di test ;)


Ho un main menu con due voci "convocazioni" e "comunicati". Queste due voci di menu sono visibili in modo pubblico.
Queste due voci però linkano alle rispettive categorie di contenuti. Categorie settate come visibili solo ai REGISTERED.
Succede però questo: quando non ho effettuato il login al sito, da utente pubblico, come deve essere, vedo le due voci di menu. Ma da utente pubblico, se clicco sulle voci di menu mi risponde la pagina 404 - pagina non trovata.


Se faccio il login come amministratore, la voce di menu è correttamente collegata alla categoria che elenca tutti gli articoli presenti all'interno, categoria che è correttamente visibile.


Se non ricordo male, tanto tempo fa, quando cliccavo una voce di menu pubblica collegata ad una categoria o contenuto settato visibile solo ai registered, il sistema mi rispondeva "devi effettuare il login per accedere a questa pagina". Ora mi da "404- pagina non trovata".


Riepilogando: voce di menu "pubblica" (sempre visibile) linkata a categoria e/o articolo "registered". Da utente "pubblico" mi risponde: 404 pagina non trovata.


E cosa è successo  ;D ?
« Ultima modifica: 28 Gen 2015, 17:32:50 da smart »

Offline smart

  • Esploratore
  • **
  • Post: 141
    • Mostra profilo
nessuno sa come si gestisce una categoria solo per utenti registrati?
sto impazzendo, non mi ricordavo una cosa così difficile e non ne esco fuori. se seleziono la categoria per REGISTERED... niente, quando clicco sulla voce di menu mi va in pagina non trovata errore 404. cosi anche se faccio su un singolo articolo. se faccio il login tutto ok, quindi, immagino, il collegamento è ok...
qualcuno che puo aiutarmi in questo arcano?
grazie a tutti ;)

Offline smart

  • Esploratore
  • **
  • Post: 141
    • Mostra profilo
ma bisogna davvero fare così?


http://joomlacode.org/gf/project/joomla/tracker/?action=TrackerItemEdit&tracker_item_id=27661


ma nessuno ha avuto questa esigenza?


che cosa macchinosa e strana, sapete se è un bug o proprio una procedura standard?

Offline pstrada61

  • Nuovo arrivato
  • *
  • Post: 5
    • Mostra profilo
ciao anch'io sto riscontrando gli stessi problemi, nel mio caso si tratta di articoli che possono essere visti solo in modalità registered.
Se effettuo il login tutto funziona corrttamente, se accedo senza login, in maniera non sistematica, mi da errore 404 sulle categorie e i link si modificano.
Ho verificato tutta la procedura di indicizzazione, il file .htaccess è quello standard di joomla e  a livello di google non sto riscontrando problemi di indicizzazione.
Ora proverò nel menu nascosto a pubblicare gli articoli "registered" per vedere se cambia qualcosa, ma sto veramente procedendo per tentativi, sia per limiti miei che per mancanza di info a proposito di casi simili

Offline giusebos

  • Fuori controllo
  • *
  • Post: 21435
  • Sesso: Maschio
  • Giuseppe Serbelloni Mazzanti Viendalmare
    • Mostra profilo
non conviene mai accodarsi anche se apparentemente il tuo problema è identico,
a maggiorn ragione quando una discussione è vecchia e senza nessuna risposta da parte di utenti: chiediti il perchè ;)
su www.icagenda.it guide e tutorial con esempi di chronoforms e chronoconnectivity

Offline pstrada61

  • Nuovo arrivato
  • *
  • Post: 5
    • Mostra profilo
Grazie Giuseppe, ho risposto di getto e non ho visto la vetustà del post. Chiedo venia ma avendo finalmente trovato qualcuno con lo stesso problema mi si è accesa una speranza.
Sui perchè della mancata risposta non saprei, o il problema non esiste o non esiste la soluzione, oppure la soluzione è quella prospettata nei link.
Proverò a seguirla e aprirò nel caso un post specifico se potrà essere di aiuto, bye

Offline smart

  • Esploratore
  • **
  • Post: 141
    • Mostra profilo
il chiedersi il perchè non capisco bene cosa significhi. io le mancate risposte le vedo come:

1 non lo so
2 non ho questo problema (anche se a questo punto una risposta sarebbe "eventualmente" gradita, così capisco che sto sbagliando io...)
3 non mi interessa rispondere
4 non ho questa esigenza e mai posto il problema (quindi non so...)
5 altro.....

beh, io che nessuno avesse questa esigenza non credo. che nessuno avesse questo "problema" non lo so (nessuna risposta...). e l'unica soluzione che mi è stata data "dalla rete" è stata quella che linkai sopra (ma proprio l'unica in rete...).

tra l'altro ancora a distanza di tempo mi chiedo se quella linkata fosse l'unico modo di operare, e ancora non ci credo, perchè... insomma... un po farraginoso ;)

pensa... sta servendo a me che ho a distanza di mesi, questa esigenza...
« Ultima modifica: 09 Mar 2016, 21:44:39 da smart »

 

Host

Torna su