Autore Topic: Reindirizzamento "autonomo" in francese  (Letto 1972 volte)

Offline wendy

  • Esploratore
  • **
  • Post: 121
  • Sesso: Femmina
    • Mostra profilo
Reindirizzamento "autonomo" in francese
« il: 24 Mar 2015, 18:26:51 »
Ciao a tutti... sto lavorando al mio nuovo sito e ho impostato il tutto per realizzarlo nelle lingue principali... ho installato le lingue necessarie (italiano, inglese, francese, tedesco e spagnolo), impostato l'italiano come predefinito e inizialmente pareva tutto a posto, solo che dopo qualche giorno ho iniziato a vedere alcune cose che non andavano.


Il primo problema l'ho notato con **** (sì, so che qui non si devono tirare in ballo componenti o altro commerciali, ma in questo caso è solo per capire cosa sta succedendo) quando se andavo nella pagina del profilo di un nuovo amico dal link della bacheca potevo entrare normalmente, mentre se accedevo a quel profilo dal link nelle notifiche mi usciva errore 404 con messaggio in francese... pensando fosse un problema del componente ho cercato di capire che stesse succedendo, fino a che non ho notato che la pagina che caricava non era la it/ ma la fr/ e probabilmente non dipendeva affatto dal **** ma dal sistema stesso, visto che la cosa si è ripetuta anche in altri ambiti indipendenti da questo; ad esempio, se dalla gestione template vado a visualizzare la pagina della disposizione moduli, anziché in italiano me la visualizza in francese, e adesso ho notato che anche se faccio semplicemente il logout dal sito, o se lo apro partendo dall'indirizzo di dominio, automaticamente mi reindirizza alla versione francese anziché alla predefinita italiana!! Qualcuno ha avuto un problema analogo e saprebbe dirmi che da cosa potrebbe dipendere?? Vi ringrazio!!


Dani
« Ultima modifica: 25 Mar 2015, 07:33:47 da tomtomeight »
Non cambierai mai le cose combattendo la realtà esistente; costruisci un modello nuovo che renda la realtà obsoleta! (B. Fuller)

Offline steganoga

  • Abituale
  • ****
  • Post: 1313
    • Mostra profilo
Re:Reindirizzamento "autonomo" in francese
« Risposta #1 il: 24 Mar 2015, 22:59:28 »
sì, so che qui non si devono tirare in ballo componenti o altro commerciali...
---------------------------------------------------------------------

quindi basta non farlo ... semplice no?

...sono dove non ti aspetti di trovarmi, mi alimento della tua supponenza e disseto la mia curiosità nel silenzio.
Non sono un nemico, considerami un ospite.

Offline wendy

  • Esploratore
  • **
  • Post: 121
  • Sesso: Femmina
    • Mostra profilo
Re:Reindirizzamento "autonomo" in francese
« Risposta #2 il: 25 Mar 2015, 00:10:38 »
ciao steganoga, il mio riferimento al componente infatti non era per chiedere consigli o altro su questo, ma semplicemente perché (volenti o nolenti fa parte del sito) è una delle parti in cui si è manifestato il problema del reindirizzamento alla lingua che non è quella predefinita, tant'è che come ho specificato appresso, la cosa si è verificata anche nell'anteprima templates, ovviamente non commerciali, oltre che sul sito stesso, sia all'apertura che al logout... cioè, il problema non è stato localizzato solo alla sezione templates e accesso ma anche in altre parti del sito lato frontend (e non ho controllato tutto il sito pagina per pagina, per cui non so se la cosa possa capitare anche con gli altri componenti free)... pensavo solo che specificare che la cosa si presenta su più parti, e non solo su una o due, potesse essere utile, ma se così non è, basta dirlo...  ;)
Non cambierai mai le cose combattendo la realtà esistente; costruisci un modello nuovo che renda la realtà obsoleta! (B. Fuller)

Offline ste

  • Moderator
  • Instancabile
  • *****
  • Post: 8774
  • Sesso: Femmina
    • Mostra profilo
Re:Reindirizzamento "autonomo" in francese
« Risposta #3 il: 25 Mar 2015, 12:40:15 »
Ciao wendy,
verifica che la lingua predefinita del tuo browser non sia il francese ma l'italiano.
TTI - Team Traduzione Italiano di Joomla.it - Guide su Joomla

Offline wendy

  • Esploratore
  • **
  • Post: 121
  • Sesso: Femmina
    • Mostra profilo
Re:Reindirizzamento "autonomo" in francese
« Risposta #4 il: 25 Mar 2015, 16:34:29 »
Ciao ste, ti ringrazio della risposta!! Ho controllato giusto per scrupolo, ma ovviamente il browser è in italiano (risultano installate, per il browser, solo quella inglese originaria e quella italiana, e comunque interfaccia e il resto sono sempre state in italiano)... ho provato a ricontrollare alcune cose pure sul sito (lingua predefinita frontend e amministrazione, moduli per la selezione lingue, pulizia cache, ecc.) ma mi pare sia tutto a posto... comunque provando ad aprire il sito con altri browser pare che funzioni bene sia l'accesso che le altre cose che vanno in automatico in l'italiano!! Sinceramente non riesco a capire che cavolo succeda, visto che comunque, solo con questo browser, continua ad uscirmi fuori la reimpostazione in francese... grazie ancora!!


Dani
Non cambierai mai le cose combattendo la realtà esistente; costruisci un modello nuovo che renda la realtà obsoleta! (B. Fuller)

 

Host

Torna su