Autore Topic: Creare una semplice lista di notizie con il modulo Latest News Enhanced  (Letto 6742 volte)

Offline alepar

  • Esploratore
  • **
  • Post: 135
    • Mostra profilo
Salve a tutti!
Ho scritto un piccolo articolo su come creare una lista di notizie, semplice e versatile con il modulo Latest News Enhanced.


Link all'articolo: http://www.joomla.it/e-ancora/articoli-community-3x/7793-latest-news-enhanced.html


Spero vi piaccia!
« Ultima modifica: 08 Giu 2015, 21:15:10 da alexred »

Offline andrea99sims

  • Esploratore
  • **
  • Post: 114
  • Sesso: Maschio
    • Mostra profilo
Ciao alepar,


A me non compare l'immagine nell'Head dell'articolo, tant'è che sono stato costretto a metterne una di default. Uso immagini relative (ossia non presenti nelle cartelle del mio sito, ma incorporate da hosting esterno). Quando facevo il test in locale, comparivano tranquillamente, mentre in remoto no. Quindi escludo che il fatto che siano relative sia la radice del problema.

Offline alepar

  • Esploratore
  • **
  • Post: 135
    • Mostra profilo
Ciao
Non ho mai provato con immagini da url remoto, ma se dici che in locale funzionano e in remoto no controlla la versione php in uso, potrebbe essere quello il problema. Comunque domani ci provo anch'io e ti faccio sapere.

Offline alepar

  • Esploratore
  • **
  • Post: 135
    • Mostra profilo
Ero troppo curioso e ho provato adesso...
Funziona bene anche da remoto.
Nelle head options ci sono dei riquadri che dicono se tutto è settato correttamente nelle impostazioni php .
Fammi sapere
ciao

Offline andrea99sims

  • Esploratore
  • **
  • Post: 114
  • Sesso: Maschio
    • Mostra profilo
Ciao, mi dice: L'impostazione PHP allow_url_fopen è attivata ; L'estensione PHP gd2 è caricato


Tutti i supporti di formati di immagini abilitati. Versione PHP 5.4.40

Offline alepar

  • Esploratore
  • **
  • Post: 135
    • Mostra profilo
Strano allora...Hai settato le impostazioni come nella screenshoot dell'articolo?

Offline andrea99sims

  • Esploratore
  • **
  • Post: 114
  • Sesso: Maschio
    • Mostra profilo
Sì, tutto uguale. Compare il riquadro della thumbnail ma non l'immagine.

Offline alepar

  • Esploratore
  • **
  • Post: 135
    • Mostra profilo
Non so che dire, dalle prove che ho fatto funziona bene, prova a sostituire l'URL con un altro e non dimenticare di mettere http://www....

Offline andrea99sims

  • Esploratore
  • **
  • Post: 114
  • Sesso: Maschio
    • Mostra profilo
Può essere il fatto che il sito di hosting ha la sicurezza https, mentre il mio è semplicemente http?

Offline alepar

  • Esploratore
  • **
  • Post: 135
    • Mostra profilo
No, non credo, comunque le thumbnails  vengono inserite di default nella cartella tmp. Non vorrei che nello spostamento da locale a remoto si siano cancellate. Prova a svuotare la cache di joomla e casomai prova a creare un nuovo articolo con immagine remota e vedi che succede.
ciao

Offline andrea99sims

  • Esploratore
  • **
  • Post: 114
  • Sesso: Maschio
    • Mostra profilo
Lo spostamento da locale a remoto è avvenuto circa 1 mese e mezzo fa, ne ho fatti molti di articoli e pulito le cache più volte.

Offline alepar

  • Esploratore
  • **
  • Post: 135
    • Mostra profilo
Hai provato ad impostare Reset Pictures su si?

Offline andrea99sims

  • Esploratore
  • **
  • Post: 114
  • Sesso: Maschio
    • Mostra profilo
Sì ma è lo stesso.

Offline alepar

  • Esploratore
  • **
  • Post: 135
    • Mostra profilo
A questo punto le ho provate tutte e non mi viene in mente nient'altro anche perché dai test che ho fatto funziona tutto.
Quello che posso dirti è di ricontrollare che tutti i parametri siano apposto e se vuoi inviami il link del sito e vediamo se riesco a capirci di più.

Offline pulce

  • Appassionato
  • ***
  • Post: 289
  • Sesso: Maschio
    • Mostra profilo
Ottimo tutorial Alessandro.
Ho bisogno però di un'aiuto. Non riesco a far applicare il Suffisso della classe CSS personalizzato del modulo.
Ad esempio se nel css del mio template imposto il titolo così:
Codice: [Seleziona]
.newstitle {
font-size: 18px !important;
color: #448800;
text-decoration: underline;
text-shadow: -1px 1px #448800;
}
Funziona, ma se metto un suffisso per il titolo (Classe Header) nella scheda avanzate del modulo (ad es.  _titolo), non riesco ad applicarlo.
Come andrebbe scritto il  .newstitle per applicargli lo stile voluto ?
Grazie
Nulla avviene per caso

Offline alepar

  • Esploratore
  • **
  • Post: 135
    • Mostra profilo
Ciao pulce, sono contento che il mio articolo ti è piaciuto e spero che possa essere stato utile.
Per quanto riguarda la classe da applicare al titolo dovrei controllare il codice e da cell non riesco e potrei darti una risposta errata.
Comunque è possibile modificare perché anche io l'ho fatto.
Entro domani ti faccio sapere ok?

Offline alepar

  • Esploratore
  • **
  • Post: 135
    • Mostra profilo
Prova comunque, se ad esempio il titolo è h2, scrivi:
h2.newstitle {
......
}

Oppure

h2.moduletablenewstitle {.....

Offline pulce

  • Appassionato
  • ***
  • Post: 289
  • Sesso: Maschio
    • Mostra profilo
Grazie della gentile risposta. Ho provato, ma non funziona.
La mia esigenza però è un'altra.
Cioè devo personalizzare due categorie di articoli, per questo devo attribuirgli ad ognuno una classe.

In pratica dovrei creare due moduli (questo lo so fare), uno per una categoria e uno per un'altra.
Poi per ogni categoria vorrei appunto personalizzare l'aspetto degli articoli.
Penso si possa fare, ma come scrivevo non riesco a capire come assegnare la classe nel css.
Infatti se nel css del mio template scrivo .newstitle { ecc. ecc. funziona, ma poi come posso lavorare su un'altra categoria per personalizzarla ? Non so se mi sono spiegato.
Ho provato anche con .newstitle_titolo { ... ma non funziona.
Grazie ancora per la pazienza e la disponibilità.
Nulla avviene per caso

Offline alepar

  • Esploratore
  • **
  • Post: 135
    • Mostra profilo
Ciao
Prima di tutto ti chiedo se utilizzi estensioni del browser tipo Firebug. Da lì puoi vedere su quale classe intervenire.


Il modulo Latest News Enhanced permette di scegliere anche quale tag utilizzare per il titolo e se utilizzarlo come collegamento ipertestuale all'articolo intero.
Io ad esempio ho utilizzato il tag h3 con collegamento all'articolo e nelle impostazioni avanzate ho scelto la classe 'notizie'.
Per modificare il titolo quindi ho scritto:


Codice: [Seleziona]
.moduletablenotizie h3 a {

Per visualizzare un nuovo modulo con un'altra categoria in un'altra posizione del template quindi vado a creare una classe diversa es. news e scrivo:

Codice: [Seleziona]
.moduletablenews h3 a {
Spero di esserti stato d'aiuto.

Offline pulce

  • Appassionato
  • ***
  • Post: 289
  • Sesso: Maschio
    • Mostra profilo
Grande ... ho risolto grazie al tuo suggerimento.
 ;D :D ;)
Strepitoso, senza il tuo aiuto non ci sarei riuscito.
Grazie ancora.
Nulla avviene per caso

 

Host

Torna su