Autore Topic: errore aggiornamento da 2.5 a 3  (Letto 4109 volte)

Offline Giuseppedes

  • Nuovo arrivato
  • *
  • Post: 31
  • Sesso: Maschio
    • Mostra profilo
errore aggiornamento da 2.5 a 3
« il: 30 Lug 2015, 15:33:44 »
Ciao a tutti, sto provando ad aggiornare joomla dalla versione 2.5.28 alla 3.4.3, ma ho riscontrato un problema:


provando a fare l'aggiornamento automatico tramite back-end di joomla appare questo errore:


Citazione
ERROR: Could not open LICENSE.txt for writing.


Se invece provo a mettere il contenuto del file Joomla_3.4.3-Stable-Update_Package.zip nella cartella tmp e provo a lanciare l'installazione da cartella, appare la pagina bianca con url http://www.miosito.it/administrator/index.php?option=com_installer&view=install


Ho disabilitato gli url sef e i permessi sono impostati a 644 per i file e 755 per le cartelle.


Sapete se c'è modo di risolvere?


Vi ringrazio anticipatamente.

Offline Gokuale - Takumi

  • Appassionato
  • ***
  • Post: 528
  • Sesso: Maschio
    • Mostra profilo
Re:errore aggiornamento da 2.5 a 3
« Risposta #1 il: 04 Ago 2015, 12:07:51 »
ciao

prima di lanciare l'aggiornamento fai una verifica se i file e le cartelle sono scrivibili

sotto

backend -> Sito -> informazioni di sistema ->permessi cartella devi avere tutto verde con scritto scrivibile, se poi l'hosting e configurato bene troverai solo il configuration.php   ->  Non scrivibile ma questo e' corretto

se tutto non e' scrivibile hai problemi con i permessi e devi sentire il tuo hosting

facci sapere
ciao
 ;D ;D ;D ;D ;D
Puoi arrivare fino a 11.000 giri
Ma soprattutto ........ VINCI!!!!
nd. Bunta - the real DK

Offline Giuseppedes

  • Nuovo arrivato
  • *
  • Post: 31
  • Sesso: Maschio
    • Mostra profilo
Re:errore aggiornamento da 2.5 a 3
« Risposta #2 il: 04 Ago 2015, 12:34:56 »
Grazie mille per la risposta, in effetti è tutto non scrivibile.
Posso risolvere io, o devo contattare l'host?

Offline Gokuale - Takumi

  • Appassionato
  • ***
  • Post: 528
  • Sesso: Maschio
    • Mostra profilo
Re:errore aggiornamento da 2.5 a 3
« Risposta #3 il: 04 Ago 2015, 14:15:31 »
ciao

dipende da che tipo di accesso hai al server/spazio hosting

io comunque una chiamata al fornitore la farei per stare tranquillo

ciao
Puoi arrivare fino a 11.000 giri
Ma soprattutto ........ VINCI!!!!
nd. Bunta - the real DK

Offline Giuseppedes

  • Nuovo arrivato
  • *
  • Post: 31
  • Sesso: Maschio
    • Mostra profilo
Re:errore aggiornamento da 2.5 a 3
« Risposta #4 il: 05 Ago 2015, 11:49:41 »
Va bene, proverò a contattare il servizio di hosting!
Grazie per l'aiuto!!

Offline dettoChiaramente.it

  • Esploratore
  • **
  • Post: 85
  • Sesso: Femmina
    • Mostra profilo
Re:errore aggiornamento da 2.5 a 3
« Risposta #5 il: 13 Ago 2015, 20:07:14 »
Da me è tutto segnato su "Scrivibile"
ma succede la stessa cosa che dice lui sopra, una volta lanciato l'aggiornamento,
sparisce tutto e resta solo una pagina bianca...


...qualcuno ha risolto questo problema?


Se almeno mi desse un qualche messaggio potrei indicarlo, ma non dà proprio nulla...  :(

Offline Giuseppedes

  • Nuovo arrivato
  • *
  • Post: 31
  • Sesso: Maschio
    • Mostra profilo
Re:errore aggiornamento da 2.5 a 3
« Risposta #6 il: 25 Ago 2015, 11:08:57 »
Io ho risolto contattando il servizio di hosting e facendo sistemare i permessi...

Offline leonardo1984

  • Nuovo arrivato
  • *
  • Post: 4
    • Mostra profilo
Re:errore aggiornamento da 2.5 a 3
« Risposta #7 il: 29 Ago 2015, 09:02:03 »
Ciao, io sono nuovo del forum,
ho avuto anche io un problema con il passaggio da 2.5 a 3. Durante l'upgrade l'installazione si è bloccata all'89% e dopo parecchio che era rimasta inchiodata ho ricaricato la pagina e nulla funziona. Quello che appare, sia se provo a caricare front che back end è questo messaggio:
Notice: Use of undefined constant DS - assumed 'DS' in /home/pontesan/public_html/plugins/system/mailster/mailster.php on line 27Warning: require_once(/home/pontesan/public_htmlDSadministratorDScomponentsDScom_mailsterDSmailsterDSincludes.php): failed to open stream: No such file or directory in /home/pontesan/public_html/plugins/system/mailster/mailster.php on line 27Fatal error: require_once(): Failed opening required '/home/pontesan/public_htmlDSadministratorDScomponentsDScom_mailsterDSmailsterDSincludes.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/pontesan/public_html/plugins/system/mailster/mailster.php on line 27

cosa posso fare? Ho provato a creare una sottocartella contenente il backup del sito e ho ripristinato un nuovo database. Non riesco però ad accedere alla cartella! Qualcuno sa dirmi come posso riparare questo mancato aggiornamento? Grazie mille, spero di aver inserito la mia domanda al posto giusto. Ciao a tutti.

Offline dettoChiaramente.it

  • Esploratore
  • **
  • Post: 85
  • Sesso: Femmina
    • Mostra profilo
Re:errore aggiornamento da 2.5 a 3
« Risposta #8 il: 31 Ago 2015, 08:58:21 »
Ciao Leonardo,


provo a esserti utile con quello che ho capito dall'aggiornamento...
(che non sono mai riuscita a fare, alla fine sto trasferendo il sito a mano e per l'occasione faccio un restilyng completo...)


hai già controllato, PRIMA di fare la migrazione alla 3, che TUTTI I PLUGIN che hai installato siano COMPATIBILI con la 3?

Se per caso non l'hai già fatto, sarebbe bene fare un giro in "gestione estensioni",
dove vanno lasciati tutti quelli che come "Autore" hanno il team di Joomla,
mentre vanno verificati tutti quelli fatti da altri, che quindi probabilmente hai aggiunto tu rispetto alla versione base,
e dovresti capire a cosa servono, così quelli che nn ti servono (probabilmente quelli disattivati) magari li butti via o ti segni il nome per ri-scaricarli nuovi un domani,
e quelli che ti servono, vai a controllare (sul sito di chi li ha prodotti o nell'elenco di estensioni di Joomla sul sito ufficiale) se sono compatibili con la 3, se non sono compatibili, o guardi se si può scaricare la versione nuova compatibile, oppure se c'è un altro plugin che magari fa la stessa cosa ed è compatibile.
Però credo che più riesci a disattivarne meglio è. Magari segnati i loro nomi, che se erano cose che ti servivano poi li recuperi.

Per l'uso del forum, da quello che ho capito funziona che ci si accoda quando si trova una discussione su un problema quasi identico,
mentre se ci sono avvisi di errore diversi o altri problemi allora si apre un topic dedicato.
Poi, se il problema viene risolto, si torna sul primo post della discussione (se è fatto da te) e dopo il titolo si aggiunge [RISOLTO].

Ciao, spero che riesci a saltarci fuori,  :)
magari qualcun'altro sa darti altri consigli più specifici...

Chiara

Offline alexred

  • Fuori controllo
  • *
  • Post: 25672
  • Sesso: Maschio
  • Esperto in ozio relaxed
    • Mostra profilo
Re:errore aggiornamento da 2.5 a 3
« Risposta #9 il: 31 Ago 2015, 09:02:41 »
Ottima osservazione dettoChiaramente.it,
nello specifico l'errore riportato da leonardo1984 fa riferimento all'estensione esterna "Mailster"

Offline leonardo1984

  • Nuovo arrivato
  • *
  • Post: 4
    • Mostra profilo
Re:errore aggiornamento da 2.5 a 3
« Risposta #10 il: 31 Ago 2015, 11:43:19 »
Ciao Alex e ciao dettochiaramente...GRAZIE GRAZIE GRAZIE, per avermi risposto.
-purtroppo non riesco ad accedere al backend di joomla. Quando mi connetto ricevo lo stesso identico errore postato prima.
-ho ritrovato accedendo in ftp la cartella mailster che credo sia quella a creare problema.


Cosa mi suggerite di fare? Cancellare la cartella mailster e vedere cosa succede?
L'installazione di joomla 3 però si era fermata all'89%. Ripartirà?


Ho anche un file backup dell'intero sito ma vorrei prima provare a vedere se funziona. Dove lo posso fare? Nello stesso dominio e hosting è possibile?
Vi ringrazio in anticipo del vostro prezioso aiuto.
buona giornata :)


Offline giovi

  • Instancabile
  • ******
  • Post: 9835
  • Sesso: Maschio
    • Mostra profilo
Re:errore aggiornamento da 2.5 a 3
« Risposta #11 il: 31 Ago 2015, 12:10:08 »
ciao leonardo, puoi provare a disabilitare l'estensione tramite il database.
Altrimenti per assicurarti di fare un lavoro pulito puoi ripristinare il backup sul tuo computer, effettuare li l'aggiornamento e poi ritrasferire tutto online.

Offline dettoChiaramente.it

  • Esploratore
  • **
  • Post: 85
  • Sesso: Femmina
    • Mostra profilo
Re:errore aggiornamento da 2.5 a 3
« Risposta #12 il: 31 Ago 2015, 12:25:09 »
Ciao Leonardo, se vuoi provare a lavorare non sul tuo sito ma su una "fotocopia" di esso sul tuo computer,
devi installare un programma che funziona da server, cioè fa come se tu fossi on-line,
e ti fa funzionare il database,


io non ho il PC, saprei spiegartelo per il MAC (uso Mamp),
però ti ho trovato questo articolo che ti spiega come fare su PC:


http://www.joomla.it/e-ancora/articoli-community-3x/7697-come-installare-joomla-in-locale-con-xampp.html


Magari ci perderai un pò di tempo per imparare, ma ti serve poi anche in futuro, per altri aggiornamenti, oppure quando vorrai fare un restilyng totale del sito senza lavorare on-line.


Oppure, se vuoi rimanere on-line sul tuo sito, e avere uno spazio dove lavorare, puoi:
- creare (usando il Cpanel del tuo sito) un sotto-dominio e installare la copia del sito lì,
- oppure creare una cartella


Se sei su un sito gratuito guarda di avere un pò di spazio libero, che non si impalli tutto perchè manca spazio  ;)


mentre per il consiglio "puoi provare a disabilitare l'estensione tramite il database."
non ho la più pallida idea di come si disabiliti un'estensione con il database.... spero per te che tu lo sappia, altrimenti chiedi.

Ciao, buon lavoro
Chiara

Offline leonardo1984

  • Nuovo arrivato
  • *
  • Post: 4
    • Mostra profilo
Re:errore aggiornamento da 2.5 a 3
« Risposta #13 il: 02 Set 2015, 08:33:50 »
Ho disattivato mailster plug in dal database ma ora quando carico la home page ho questo errore:
1054 - Unknown column 'c.version' in 'field list' SQL=SELECT c.id, c.asset_id, c.access, c.alias, c.checked_out, c.checked_out_time, c.created_time, c.created_user_id, c.description, c.extension, c.hits, c.language, c.level, c.lft, c.metadata, c.metadesc, c.metakey, c.modified_time, c.note, c.params, c.parent_id, c.path, c.published, c.rgt, c.title, c.modified_user_id, c.version, CASE WHEN CHAR_LENGTH(c.alias) != 0 THEN CONCAT_WS(':', c.id, c.alias) ELSE c.id END as slug,COUNT(i.`id`) AS numitems FROM h43mq_categories as c LEFT JOIN h43mq_categories AS s ON (s.lft <= c.lft AND s.rgt >= c.rgt) OR (s.lft > c.lft AND s.rgt < c.rgt) LEFT JOIN (SELECT cat.id as id FROM h43mq_categories AS cat JOIN h43mq_categories AS parent ON cat.lft BETWEEN parent.lft AND parent.rgt WHERE parent.extension = 'com_content' AND parent.published != 1 GROUP BY cat.id) AS badcats ON badcats.id = c.id LEFT JOIN `h43mq_content` AS i ON i.`catid` = c.id AND i.state = 1 WHERE (c.extension='com_content' OR c.extension='system') AND c.access IN (1,1) AND c.published = 1 AND s.id=7 AND badcats.id is null GROUP BY c.id, c.asset_id, c.access, c.alias, c.checked_out, c.checked_out_time, c.created_time, c.created_user_id, c.description, c.extension, c.hits, c.language, c.level, c.lft, c.metadata, c.metadesc, c.metakey, c.modified_time, c.note, c.params, c.parent_id, c.path, c.published, c.rgt, c.title, c.modified_user_id, c.version ORDER BY c.lft
In compenso riesco ad accdere al backend del sito. Il gestionale di joomla appare molto scomposto e moltissime cose non funzionano.
Ho provato ad installare mamp, (io ho mac) ma non riesco a capire dove caricare i database.








Offline dettoChiaramente.it

  • Esploratore
  • **
  • Post: 85
  • Sesso: Femmina
    • Mostra profilo
Re:errore aggiornamento da 2.5 a 3
« Risposta #14 il: 02 Set 2015, 08:46:20 »
Per vedere i database:


Apri MAMP > Avvia server > Apri la home page > scheda "PhpMyAdmin" > e, dentro, scheda "Database"


Da quella scheda hai i comandi se ti serve creare un nuovo database,
oppure (più semplice) sulla scheda UTENTI > aggiungi utente (e nel crearlo selezioni l'opzione che, nello stesso momento, crea da solo un Database che si chiama uguale e gli abbina già l'utente con tutti i permessi).


Se invece quello che devi fare tu è:
- prendere tutto il sito vecchio
- installarlo in fotocopia sul Mac


Allora, sul sito vecchio (non ricordo se accedi ancora o se è sparito però...) installi Akeeba Backup, che ti scarica un solo file, tu lo butti dentro la cartella principale di Mamp, quella public_Html, insieme ad un altro filettino, e poi entrando in versione sito parte l'istallazione.
E' molto semplice da fare, se vuoi ti spiego e ti passo il file necessario, però dipende tutto se riesci prima a rientrare nel vecchio sito, installare Akeeba e ottenere il file del Backup da cui partire.


Ciao
Chiara

ps: per l'uso del forum, è sempre meglio quando si trovano nuovi problemi specifici, aprire discussioni specifiche, perchè se si trattano troppi temi tutti dentro una unica discussione un domani non sarà utile a nessuno perchè troppo incasinata. Invece aprendo un post tipo "come installo il mio sito in locale su Mac con Mamp?" diventa una discussione che sarà utile a tutti quelli che devono fare quel singolo passaggio e la troveranno facilmente quando usano il cerca...  ;)  Ovvio che prima devi avere già controllato che non esista già, per non fare doppioni.

Offline leonardo1984

  • Nuovo arrivato
  • *
  • Post: 4
    • Mostra profilo
Re:errore aggiornamento da 2.5 a 3
« Risposta #15 il: 06 Set 2015, 18:02:52 »
Niente, sono ad un punto di non ritorno.
Update joomla 2.5 a 3 bloccato all'89%, front end del sito morta, back end posso accedere al pannello joomla ma tutto appare molto confuso. Tra informazioni di sistema la versione di joomla segnalata in uso è la 3.
Questo è il messaggio che compare quando carico la home page del sito:
Ho disattivato mailster plug in dal database ma ora quando carico la home page ho questo errore:
Cosa mi suggerite di fare?
Bel casino vero?
grazie

1054 - Unknown column 'c.version' in 'field list' SQL=SELECT c.id, c.asset_id, c.access, c.alias, c.checked_out, c.checked_out_time, c.created_time, c.created_user_id, c.description, c.extension, c.hits, c.language, c.level, c.lft, c.metadata, c.metadesc, c.metakey, c.modified_time, c.note, c.params, c.parent_id, c.path, c.published, c.rgt, c.title, c.modified_user_id, c.version, CASE WHEN CHAR_LENGTH(c.alias) != 0 THEN CONCAT_WS(':', c.id, c.alias) ELSE c.id END as slug,COUNT(i.`id`) AS numitems FROM h43mq_categories as c LEFT JOIN h43mq_categories AS s ON (s.lft <= c.lft AND s.rgt >= c.rgt) OR (s.lft > c.lft AND s.rgt < c.rgt) LEFT JOIN (SELECT cat.id as id FROM h43mq_categories AS cat JOIN h43mq_categories AS parent ON cat.lft BETWEEN parent.lft AND parent.rgt WHERE parent.extension = 'com_content' AND parent.published != 1 GROUP BY cat.id) AS badcats ON badcats.id = c.id LEFT JOIN `h43mq_content` AS i ON i.`catid` = c.id AND i.state = 1 WHERE (c.extension='com_content' OR c.extension='system') AND c.access IN (1,1) AND c.published = 1 AND s.id=7 AND badcats.id is null GROUP BY c.id, c.asset_id, c.access, c.alias, c.checked_out, c.checked_out_time, c.created_time, c.created_user_id, c.description, c.extension, c.hits, c.language, c.level, c.lft, c.metadata, c.metadesc, c.metakey, c.modified_time, c.note, c.params, c.parent_id, c.path, c.published, c.rgt, c.title, c.modified_user_id, c.version ORDER BY c.lftIn compenso riesco ad accdere al backend del sito. Il gestionale di joomla appare molto scomposto e moltissime cose non funzionano.
Ho provato ad installare mamp, (io ho mac) ma non riesco a capire dove caricare i database.









Offline dettoChiaramente.it

  • Esploratore
  • **
  • Post: 85
  • Sesso: Femmina
    • Mostra profilo
Re:errore aggiornamento da 2.5 a 3
« Risposta #16 il: 06 Set 2015, 18:40:11 »
Ciao Leonardo,


sul problema tecnico specifico non so aiutarti, spero che qualcuno che ne sà un pò ti risponda,
quello che io ti consiglio, se non hai più di 100 articoli (e hai modo di vederli e recuperarli in qualche modo)
è di pulire tutto il sito, installare la 3 non come passaggio dalla 2 ma partendo proprio dal sito vuoto senza joomla dentro,
poi vai nel Cpanel del tuo hosting, entri in quella parte (da me si chiama **** o qualcosa del genere) dove ti propongono l'istallazione di CSM e quant'altro, e fai partire da lì l'istallazione automatica di Joomla, che si presume sia già nell'ultima versione.
Io ho fatto così...
..ho fatto prima a rifare tutto il sito in 3 giorni che a perdere una settimana per capire tutti i problemi, cercare risposte, studiarmi le robe, e via dicendo.
Secondo me il passaggio dalla 2 alla 3 è stato studiato un pò alla cavolo perchè ha dato enormi problemi, penso che adesso che ho la 3 non aggiornerò mai più a meno che non sono costretta, perchè mi ha fatto perdere tanto di quel tempo che se lo monetizzassi in ore non so che cifra sarebbe. E poi joomla era molto più bello prima che aveva le icone colorate, adesso sono sparite ed è tutto grigio monocromatico, e la pagina mi si carica sempre due volte, una volta per caricare le scritte e poi ricarica le immagini dei pulsanti, fastidiosissimo perchè mentre clicchi le cose ti si spostano da sotto il mouse, si perde solo più tempo per chi ha una connessione non ottima. Vabbèh...

Se puoi, salta il problema a piè pari e rifai il sito, fai molto prima e ti incacchi di meno  ;)

Ciao!
Chiara
« Ultima modifica: 06 Set 2015, 18:46:07 da tomtomeight »

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 30246
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
Re:errore aggiornamento da 2.5 a 3
« Risposta #17 il: 06 Set 2015, 18:50:00 »
@dettochiaramente

Ciao, volevo ricordarti che è vietato citare prodotti commerciali e anzi sconsiglio proprio di utilizzare procedure automatiche per installare il nostro cms, che forse è anche causa dei tuoi problemi che hai menzionato. Impara ad installare il pacchetto che puoi scaricare da questo sito o da joomla.org,
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.8.x - DEMO Gestione Magazzino

Offline Gokuale - Takumi

  • Appassionato
  • ***
  • Post: 528
  • Sesso: Maschio
    • Mostra profilo
Re:errore aggiornamento da 2.5 a 3
« Risposta #18 il: 06 Set 2015, 20:13:50 »
ciao a tutti

in una situazione come la tua leonardo1984, io avrei la morbosa curiosità di trovare l'inghippo e proverei off-line ma se il tuo problema e' anche urgente, prova:

visto che riesci ad entrare in backend, disinstalla se non lo hai gia' fatto il componente che ti crea il problema, inoltre visto che l'aggiornamento non e' andato a buon fine nella pagina dove vengono fatti gli aggiornamenti o installate le applicazioni c'e' un menu a sx che si chiama "Database", verifica che non sia in errore nel caso premi FIX (o RIPARA in italiano) e vedi se cosi' funziona il tutto

per il problema in frontend potrebbe essere un modulo specifico per l'estensione che hai disinstallato che comunque e' rimasto a causarti il problema o un plugin verifica anche questo

inoltre i template dalla 2.5 alla 3 mi sembra che siano leggermente diversi prova sempre in backend ad attivare come default uno di quelli preinstallati e vedi il risultato

man mano che farai i passaggi suggeriti se troverai degli avvisi di errori REQUIRE oppure REQUARE_ONCE, verifica cosa richiame quel particolare file che serve, a volte e' un modulo  o plugin che rompe le scatole poiche' dalla vecchia versione alla nuova sono cambiati parecchi richiami e avendo un'installazione frizzata a meta' potresti avere ancora dei file vecchi

comunque una sovrascrittura con un pacchetto completo di una nuova installazione lo farei per essere sicuro che tutti i file siano dell'ultima versione almeno per il core di Joomla

ovviamente fatti un backup sia di file che di DB prima di qualunque cosa

ciao e buon lavoro
 ;) ;) ;) ;) ;) ;)
« Ultima modifica: 06 Set 2015, 20:16:02 da Gokuale - Takumi »
Puoi arrivare fino a 11.000 giri
Ma soprattutto ........ VINCI!!!!
nd. Bunta - the real DK

 

Host

Torna su