Autore Topic: Problemi con sito aggiornato a joomla 3  (Letto 3825 volte)

Offline TITANUM

  • Nuovo arrivato
  • *
  • Post: 37
    • Mostra profilo
Problemi con sito aggiornato a joomla 3
« il: 22 Set 2015, 10:54:07 »
Buongiorno a tutti, ho un problema con un sito web che ho migrato da joomla 2.5.28 alla 3.6

Ho scaricato il sito in locale e ho fatto la migrazione, sul mio computer e sul mio server locale funzionava perfettamente,
ma dopo averlo caricato ho notato che la home funziona, ma non visualizzo alcune sezioni e non visualizzo più gli articoli.

Non riesco memmeno ad accedere all'area riservata, abilitando gli errori ottengo questi messaggi:

se clicco su un articolo ottengo:

Strict Standards:  Declaration of JTableContent::_getAssetParentId() should be compatible with JTable::_getAssetParentId($table = NULL, $id = NULL) in htdocs/www.giovanisalerno.it/home/libraries/legacy/table/content.php on line 375
 
 Catchable fatal error:  Argument 1 passed to JTableObserverTags::createObserver() must be an instance of JObservableInterface, instance of JTableContent given, called in /web/htdocs/www.giovanisalerno.it/home/libraries/legacy/table/content.php on line 33 and defined in htdocs/www.giovanisalerno.it/home/libraries/joomla/table/observer/tags.php on line 81

se provo ad accedere all'area administrator ottengo:

 Notice:  Undefined property: LoginController::$input in htdocs/www.giovanisalerno.it/home/administrator/components/com_login/controller.php on line 38
 
 Fatal error:  Call to a member function set() on a non-object in htdocs/www.giovanisalerno.it/home/administrator/components/com_login/controller.php on line 38

In locale funzionava tutto perfettamente, i problemi sono subentrati quando ho caricato il sito sul server:
Ho importato il db tramite phpmyadmin (il db pesa 17 mb), caricato i file sul server e modificato il file configuration.php

Un grazie a chi mi aiuterà a risolvere questo guaio!

Offline $Red

  • Team Joomla.it
  • Instancabile
  • *******
  • Post: 5155
  • "Bastard Inside"
    • Mostra profilo
Re:Problemi con sito aggiornato a joomla 3
« Risposta #1 il: 22 Set 2015, 11:36:12 »
ciao, hai selezionato il file php.ini per joomla nel pannello di controllo del tuo host?
alterjoomla Guide joomla altervista - RedWebSite  joomla! e non solo joomla

Offline TITANUM

  • Nuovo arrivato
  • *
  • Post: 37
    • Mostra profilo
Re:Problemi con sito aggiornato a joomla 3
« Risposta #2 il: 22 Set 2015, 11:44:51 »
Si, il sito ospitava già joomla 2.5 quindi era già impostato in quel modo

Offline TITANUM

  • Nuovo arrivato
  • *
  • Post: 37
    • Mostra profilo
Re:Problemi con sito aggiornato a joomla 3
« Risposta #3 il: 22 Set 2015, 12:50:17 »
Ho fatto anche un altro tentativo, guardando la versione di php in locale ho notato che è diversa da quella del server, così ho cambiato la versione di php sul server (ho messo la 5.6) ma non è cambiato nulla. Qualche altro suggerimento?

Comunque la cosa che non capisco è come mai in locale funziona e sul server no, è legato alla migrazione oppure no?
« Ultima modifica: 22 Set 2015, 13:30:14 da TITANUM »

Offline $Red

  • Team Joomla.it
  • Instancabile
  • *******
  • Post: 5155
  • "Bastard Inside"
    • Mostra profilo
Re:Problemi con sito aggiornato a joomla 3
« Risposta #4 il: 23 Set 2015, 09:33:56 »
il database è ok? googlando mi era capitato di trovare un post su joomla.org con un errore simile, purtroppo non lo trovo piu :-[ , prova a controllare ad estensioni/gestione al menu di sinistra database poi clicca su correggi
alterjoomla Guide joomla altervista - RedWebSite  joomla! e non solo joomla

Offline TITANUM

  • Nuovo arrivato
  • *
  • Post: 37
    • Mostra profilo
Re:Problemi con sito aggiornato a joomla 3
« Risposta #5 il: 23 Set 2015, 10:22:49 »
Putroppo non posso accedere al backend di joomla, se vado su administrato trovo questo errore

 Notice:  Undefined property: LoginController::$input in htdocs/www.giovanisalerno.it/home/administrator/components/com_login/controller.php on line 38
 
 Fatal error:  Call to a member function set() on a non-object in htdocs/www.giovanisalerno.it/home/administrator/components/com_login/controller.php on line 38

La cosa che non mi spiego è come mai in locale la migrazione è andata a buon fine ma caricandolo sul server non funziona più...

Stavo pensando ti ripristinare il backup precedente con la 2.5.28 e tentare di nuovo la migrazione, ma a questo punto dovrei provare a farla direttamente sul web...

Online tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 30273
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
Re:Problemi con sito aggiornato a joomla 3
« Risposta #6 il: 23 Set 2015, 11:29:10 »
Se in locale funge ed in remoto no l'unica spiegazione è che in remoto hai una versione php non idonea, inferiore a 5.3.10 hai quel tipo di errori. Verifica ed adegua la versione php magari agendo anche da pannello spazio host.
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.8.x - DEMO Gestione Magazzino

Offline $Red

  • Team Joomla.it
  • Instancabile
  • *******
  • Post: 5155
  • "Bastard Inside"
    • Mostra profilo
Re:Problemi con sito aggiornato a joomla 3
« Risposta #7 il: 23 Set 2015, 11:50:09 »
ciao tomtom, pure io avevo pensato alla vers. php ma wappalyzer mi segnalava 5.5.. ma avevo letto male... è la 5.6.13 forse un pò troppo "fresca" e misà che dovrebbe provare a scendere un pò..
alterjoomla Guide joomla altervista - RedWebSite  joomla! e non solo joomla

 

Host

Torna su