Back to top

Autore Topic: Compatibilità php  (Letto 1278 volte)

Offline lucantropo

  • Appassionato
  • ***
  • Post: 705
  • Sesso: Maschio
    • Mostra profilo
Compatibilità php
« il: 27 Ott 2015, 19:39:38 »
Buona sera, ho "ereditato" un sito joomla che era fermo alla 2.5.4. Il piano è portarlo all'ultima versione 3.4.5.
Ho scaricato un backup del sito sul pc, con xampp. Il sito restituisce una lista di errori php infinita.
Ci sono tantissimi errori anche su estensioni tipo k2 o phoca gallery.
A memoria ricordo che joomla 2.5 gira con php 5.2 o 5.3, la mia versione di xampp gira con la 5.5.19.
Gli errori possono dipendere da "poca retrocompatibilità" delle versioni php?
Se così fosse aggiornando alla 3.4.5 con aggiornamento dei componenti e plugin tutto dovrebbe funzionare correttamente?

Grazie in anticipo

Offline Alex21

  • Appassionato
  • ***
  • Post: 645
    • Mostra profilo
Re:Compatibilità php
« Risposta #1 il: 28 Ott 2015, 10:10:17 »
Gli errori possono dipendere da "poca retrocompatibilità" delle versioni php?
Se così fosse aggiornando alla 3.4.5 con aggiornamento dei componenti e plugin tutto dovrebbe funzionare correttamente?
Una lunga lista di warning può davvero essere disarmante, ma una volta che avrai aggiornato il sito se tutto funzionerà come previsto potrai ritenerti soddisfatto, penso.
L' aggiornamento è abbastanza delicato ed è meglio leggere le guide, anche in italiano su questo forum.
Attenzione ad un comportamento curioso di joomla. Se hai il sito in locale, la connessione aperta e fai l' aggiornamento on-line, quello che viene aggiornato è il sito 'in produzione' !
Ciao


Offline hnoor0011

  • Nuovo arrivato
  • *
  • Post: 1
    • Mostra profilo
Re:Compatibilità php
« Risposta #2 il: 11 Dic 2015, 08:24:43 »
L' aggiornamento è abbastanza delicato ed è meglio leggere le guide, anche in italiano su questo forum.

Offline giovi

  • Instancabile
  • ******
  • Post: 9835
  • Sesso: Maschio
    • Mostra profilo
Re:Compatibilità php
« Risposta #3 il: 11 Dic 2015, 09:45:55 »
Gli errori possono dipendere da "poca retrocompatibilità" delle versioni php?
Dipende dagli errori: magari sono tutti notices e sono dovuti semplicemente ad uno stile di sviluppo poco ortodosso ma possono tranquillamente essere ignorati. Altri tipi di warning possono dare noie più grandi...

Offline lucantropo

  • Appassionato
  • ***
  • Post: 705
  • Sesso: Maschio
    • Mostra profilo
Re:Compatibilità php
« Risposta #4 il: 11 Dic 2015, 10:27:49 »
Scusate il ritardo nel rispondere.
Il sito l'ho migratori e funziona.
I warming sono diminuiti ma non scomparsi del tutto.
Riguardano quasi esclusivamente componenti tipo phoca gallery o phoca download.
Il sito funziona lo stesso e anche meglio di prima.
Devo dire che la migrazione del core come sempre è stata abbastanza semplice. Non posso dire la stessa cosa per i componenti phoca.

 



Web Design Bolzano Kreatif