Autore Topic: problema glyphicons  (Letto 879 volte)

Offline memma1989

  • Nuovo arrivato
  • *
  • Post: 15
    • Mostra profilo
problema glyphicons
« il: 07 Apr 2016, 12:31:59 »

Buongiorno a tutti,


mi chiamo Giulia e sono una giovane programmatrice.


Ho iniziato da poco ad avventurarmi nel mondo Joomla e ho riscontrato un problema che non riesco a risolvere in nessun modo.


Parto dicendo che ho sviluppato un mio template personalizzato; vorrei a questo punto aggiungere un modulo html personalizzato e per farlo sono andata in Estensioni -> Moduli -> +Nuovo e infine Personalizzato. Il codice che dovrei aggiungere in questo modulo è molto semplice ed è il seguente:




<h3>Login</h3>
<span class="glyphicon glyphicon-search" aria-hidden="true"></span>
<p>Esegui il login per accedere all'area riservata della applicazione</p>
<div>
<p><a class="readmore btn btn-primary" href="#">Accedi</p>


A questo punto clicco su salve e chiudi e la glyphicon non compare. Andando a riaprire il codice html ho notato che la riga di codice della glyphicon non c'è, è stata eliminata dall'editor.Ho installato un modulo esterno di terze parti che a suo interno ha una glyphicon che viene visualizzata correttamente.


Non riesco proprio a capire perchè nel mio modulo personalizzato la glyphicon non compaia e in quello preconfezionato sì. Qualcuno ha qualche idea geniale per aiutarmi a risolvere il mio problema?


Grazie a tutti in anticipo, anche solo per l'ascolto
Aspetto risposta,
buon pomeriggio
Giulia
« Ultima modifica: 07 Apr 2016, 12:36:48 da memma1989 »

Offline tonicopi

  • Global Moderator
  • Instancabile
  • ********
  • Post: 12762
  • Sesso: Maschio
    • Mostra profilo
Re:problema glyphicons
« Risposta #1 il: 07 Apr 2016, 12:49:14 »
Ciao Giulia e benvenuta nel forum  ;)
La soluzione è molto semplice: inserire quel codice senza l'editor, proprio disabilitandolo.
Per farlo con maggior praticità e velocità installa questo plugin.
joomlacsszengarden.com = il giardino dei css di Joomla!
L'attesa del piacere è essa stessa... piacere!

Offline memma1989

  • Nuovo arrivato
  • *
  • Post: 15
    • Mostra profilo
Re:problema glyphicons
« Risposta #2 il: 07 Apr 2016, 13:00:07 »
Ciao Giulia e benvenuta nel forum  ;)
La soluzione è molto semplice: inserire quel codice senza l'editor, proprio disabilitandolo.
Per farlo con maggior praticità e velocità installa questo plugin.


Ciao tonicopi,
ti ringrazio infinitamente per la risposta tempestiva.


Ho disabilitato l'editor cliccando in fondo a destra su Editor sì/no per disabilitare l'editor, ho inserito il codice e clickato su salva e chiudi. In questo modo mi aggiunge solo un blocchetto racchiuso nel tag pre
e mi visualizza il pezzo di codice. Ho fatto qualcosa di sbagliato?[/size]Per quanto riguarda il plugin, proverò immediatamente, grazie!
« Ultima modifica: 07 Apr 2016, 14:19:01 da memma1989 »

Offline giusebos

  • Fuori controllo
  • *
  • Post: 19666
  • Sesso: Maschio
  • Giuseppe Serbelloni Mazzanti Viendalmare
    • Mostra profilo
Re:problema glyphicons
« Risposta #3 il: 07 Apr 2016, 13:29:02 »
guarda nelle impostazioni dell'editor (cosa usi) li ci sono le opzioni per fargli accettare html, css, php, js, iframe.....
su www.icagenda.it guide e tutorial con esempi di chronoforms e chronoconnectivity

Offline memma1989

  • Nuovo arrivato
  • *
  • Post: 15
    • Mostra profilo
Re:problema glyphicons
« Risposta #4 il: 07 Apr 2016, 14:21:38 »
Grazie mille giusebos e tonicopi, con il vostro aiuto sono riuscita a risolvere il problema!


Ho risolto semplicemente disabilitando l'editor, esattamente come mi avete detto voi. Grazie ancora, spero di risentirvi presto  ;D

 

Host

Torna su