Autore Topic: Upgrade 2.5.6 -> 3.5: JInstaller: :Install: Non è stato possibile trovare il fil  (Letto 4300 volte)

Offline TonyHef

  • Nuovo arrivato
  • *
  • Post: 8
    • Mostra profilo
Buongiorno, ho la necessità di aggiornare la versione joomla del mio sito dalla 2.5.6 all'utlima disponibile, ovvero la 3.5.0.
Seguendo la guida ho provato a
  • copiare tutto il contenuto di Joomla_3.5.0_ita-Stable.zip nella cartella "tmp"
  • dalla "gestione estensioni" ho specificato il percorso "/tmp"
Ma, cliccando su "installa" riscontro l'errore:

JInstaller: :Install: Non è stato possibile trovare il file di setup XML
Il percorso non ha un pacchetto valido.

Mi sfugge qualcosa?  :o

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 31311
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
Ciao e benvenuto nel forum

Cortesemente ci indichi in quale guida hai letto quello che poi hai eseguito? No perché se è una nostra guida provvediamo subito a correggere.

Offline TonyHef

  • Nuovo arrivato
  • *
  • Post: 8
    • Mostra profilo
Ciao e benvenuto nel forum

Cortesemente ci indichi in quale guida hai letto quello che poi hai eseguito? No perché se è una nostra guida provvediamo subito a correggere.

Grazie per il benvenuto!

La guida che ho seguito è questa http://www.joomla.it/notizie/7485-guida-all-aggiornamento-dalla-versione-2-5-alla-3-di-joomla.html

Ho provato ad aggiornare anche uploadando il file zip, ma vien fuori l'errore:
JFolder::create: Non è stato possibile creare la cartella
Attenzione: fallito spostamento del file!

 
Vorrei specificare che questa l'installazione è di backup, ed è avvenuta replicando il database e copiando manualmente  tutti i file del sito originale via ftp.
Ho pensato che potrebbe essere un problema di permessi di scrittura, ma ho settato i permessi 777 su tutti tutte le directory e sottodirectory ma senza risolvere nulla!

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 31311
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
Citazione
•copiare tutto il contenuto di Joomla_3.5.0_ita-Stable.zip nella cartella "tmp"

Mi dici dove sta questo passo?

Offline TonyHef

  • Nuovo arrivato
  • *
  • Post: 8
    • Mostra profilo
Mi dici dove sta questo passo?

Sotto "Aggiornamento con la procedura manuale":
[...]
Scarica il file dedicato all'aggiornamento da Joomla 3.x.x all'ultima versione di Joomla 3 disponibile nell'area download di Joomla.it (solitamente è l'ultimo file dell'elenco).
Decomprimi il pacchetto di aggiornamento che hai scaricato nel tuo computer.
Collegati via FTP alla cartella tmp del tuo sito Joomla 2.5 e verifica che sia vuota o che contenga solo il file index.html.
Trasferisci via FTP tutte le cartelle ed i file, contenuti nella cartella dell'aggiornamento, nella cartella tmp del tuo sito Joomla. Accedi all'amministrazione del tuo sito Joomla 2.5 ed alla gestione estensioni[...]

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 31311
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
E ti pare la stessa cosa

aggiornamento  da Joomla 3.x.x all'ultima versione di Joomla 3

con
 
contenuto di Joomla_3.5.0_ita-Stable.zip


Offline TonyHef

  • Nuovo arrivato
  • *
  • Post: 8
    • Mostra profilo
E ti pare la stessa cosa

aggiornamento  da Joomla 3.x.x all'ultima versione di Joomla 3

con
 
contenuto di Joomla_3.5.0_ita-Stable.zip

Osservando meglio ti do ragione. Però se l'intero articolo si intitola "Guida all'aggiornamento dalla versione 2.5 alla 3 di Joomla!", per chi legge è sottointeso che tutte le procedure descritte riguarderebbero sempre la 2.5!

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 31311
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
Si ma tu hai letto in fretta ed hai preso un file per un altro e tutti e due riguardavano la versione 3, d'altronde se il titolo riguarda l'aggiornamento da 2 a 3 è ovvio che i file devono riguardare la versione 3.  :)

Dai rifai la procedura e facci sapere.

Offline TonyHef

  • Nuovo arrivato
  • *
  • Post: 8
    • Mostra profilo
Ok  ;)

Ho optato nel procedere con la procedura automatica
Non ho trovato la sezione per l'aggiornamento di joomla, presuppongo quindi che, per attivarla, dovrei aggiornare all'ultima versione della 2.5, ovvero la 2.5.28, correggetemi se sbaglio.

Nella scheda "informazioni di sistema" ritrovo che la versione installata e la 2.5.6  ??? :
Joomla! 2.5.6 Stable [ Ember ] 19-June-2012 14:00 GMT           
e questo già mi sembra strano, è superiore all'utlima (2.5.28)?

Inoltre eseguendo l'upload di Joomla_2.5.28_ita-Stable.zip dalla "gestione estensioni", mi ritorna l'errore
JFolder::create: Non è stato possibile creare la cartella
Attenzione: fallito spostamento del file!


Non trovo modo di avanzare...
« Ultima modifica: 09 Apr 2016, 18:24:55 da TonyHef »

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 31311
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
Rifai sempre lo stesso errore, non devi prendere le versioni stabili, ma quelle aggiornamento.
Poi 2.5.6 è inferiore a 2.5.28

Offline TonyHef

  • Nuovo arrivato
  • *
  • Post: 8
    • Mostra profilo
Sono riuscito ad aggiornare alla 2.5.28, nonchè alla 3.5.1, fra 1000 difficoltà...
Ora al posto del sito appare una pagina bianca, sicuramente a causa di una o più estensioni non compatibili.
Siccome le estensioni installate da controllare sono un bel po', mi conviene escludere quelle con autore "Joomla! Project"?
Poi devo disinstallarle del tutto o posso anche solo disabilitarle?

Offline TonyHef

  • Nuovo arrivato
  • *
  • Post: 8
    • Mostra profilo
Sono riuscito ad aggiornare alla 2.5.28, nonchè alla 3.5.1, fra 1000 difficoltà...
Ora al posto del sito appare una pagina bianca, sicuramente a causa di una o più estensioni non compatibili.
Siccome le estensioni installate da controllare sono un bel po', mi conviene escludere quelle con autore "Joomla! Project"?
Poi devo disinstallarle del tutto o posso anche solo disabilitarle?
Qualcuno può togliermi ho darmi una dritta? Scusate ma sono un neofita dell'argomento, vorrei imparare!
Grazie!

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 31311
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
Prova a resettare i permessi, su come farlo interpella il tuo servizio hosting.

Offline TonyHef

  • Nuovo arrivato
  • *
  • Post: 8
    • Mostra profilo
Prova a resettare i permessi, su come farlo interpella il tuo servizio hosting.
Ho risolto. L'errore non era attribuito ai permessi ma alle estensioni non pienamente compatibili con la nuova versione di Joomla.
Se può tornare utile in futuro a qualcun altro, riassumo i passaggi che ho eseguito
  • Disabilitato (senza disinstallarle) tutte le estensioni con autore diverso da Joomla! Project
  • Settato al massimo il livello il logging degli errori da System -> Configurazione globale -> Server -> Rapporto errori : "Massimo"
  • Riattivare man mano le estensioni disabilitate e identificando quelle che crashano il sito, provando a correggerle nel loro codice PHP, aggiornandole o sostituendole.
Grazie per tutto il supporto e la tua pazienza tomtomeight!

 

Host

Torna su